CoreELEC 20.0-Nexus Amlogic-ne Discussion

Dunno what is investment for you, S905X3 will get also CE21-ng (my bad if I get it wrong), it works now with CE20-ng, so you are covered 4-5 years at least.

Investment? Everything I need to spend money on :slight_smile: It’s not a question on how much I spend, rather than on WHAT I spend. And where the money is better invested. I know that I KODI will not stop to work all of a sudden, but eg there are boards with S905Y4 that are 30% cheaper than S905X3, that’s why I ask if my money is better spent there. What do you think?

I’d get an odroid c4 and get used to all it can do, everything for now at least. Then when the next lot come out on with some hefty differences look for a new box, you’ll likely need a new TV to go with it or there’s not much point paying so much. Or spend twice as much for no difference as a media player and ask the same question in a couple years when you get a new TV and the old box is a stable player, server, whatever else you’ve done with it.

Just to qualify, I’ve had 5 amlogic boxes, oldest being a beelink mini mx. Although it seems sluggish now it can still serve my oldest decent TV all it needs, which is a 55ks7000, a TV at its time, 7 8 years ago was a revelation to me and still is.

Completely wrong!
LE is right now only at Beta, not 20.0 stable. And about Amlogic:
Support for Amlogic S905, S905X/D, and S912 devices resumes
and:
No formal support for newer S905X2/D2/Y2, S905X3, S922X, A311D devices

So don’t think about S905X4/Y4, S905W2 or A311D2, it will never happen!
Sure it boot “mainline” kernel but without hardware decoder support. So useless as media center.

Here you can see all SoC listed and how much they are:
https://wiki.coreelec.org/coreelec:ce_dev_cycle#development_status

But “real” support of hardware by LE is ended at S912.
CoreELEC is already 6 generations ahead and the next one S5 S928X is already on the way…

1 Like

Any update on your VIM1s? Did it freeze on you after all?

When mine freezes I have to do dirty reboots and when I do that, logs aren’t saved. So it’s impossible for me to upload logs for you guys to debug.

Well I never got answer here:

There a about 70 VIM1S running CE right now, so I guess it’s a issue with your config or a used addon.

Really? Hmm.

Why would the same config and add-ons run fine on the HK1 S905X4 though? I know it’s different hardware etc. It’s not that I don’t believe you, just find it odd.

You think I got a bad unit? It freezes if I run it off the emmc or SDCard. Same result.

I’m using it tonight to watch some live tv, personal library and netflix addon. No freezes so far,

Okay thanks for keeping me updated.

I really don’t know what to think now. I have the same config and add-ons running fine on my Le Potato and a HK1 S905X4 box.

I even installed Android on my VIM1S and installed Kodi 20 with the same config and add-ons and haven’t encountered a freeze up.

The lockups I get on my VIM1S reminds me of when I first got my Le Potato and installed CoreELEC years ago and it would freeze if I transferred more than a gigabyte of data. That was eventually fixed though.

Like I mentioned before, I have CoreELEC running on a Le Potato, HK1 S905X4 box, Kodi 20 on a FireTV Stick 4K Max and Kodi 20 on an Onn Android TV box. All running fine.

I was thinking of replacing my Le Potato with the VIM1S but I guess that’s not going to happen anytime soon. I’ll keep testing though.

When you don’t start to share logs you will never get a solution:

I understand what you’re saying but the last time I uploaded my logs you said you didn’t see anything wrong in the logs.

When it does freeze, it locks up completely. I can’t ssh into it or use the remote to reboot. Only solution is to unplug the power cord (dirty reboot).

If I perform a dirty reboot, logs aren’t saved for me to upload. If I do upload any logs after a dirty reboot, I get the “I don’t see anything wrong with the logs” answer.

It’s a catch-22… I’ll keep downloading and testing nightlies in hopes, either by chance or fluke, I will come across a solution.

When somebody will read the wiki and know about his hardware he would know he a have a UART port where such logs can be captured… :innocent:

Last statement from my side about logs and this item as there today already 3 persons what are not able to provide info.

No log, no problem!

You’re right, I didn’t read the Wiki about my specific hardware having a UART port. I’ll definitely look into it.

Right off the bat, the wiki doesn’t list the VIM1S as being supported. I’m sure it’s a typo but it says VIM1L.

1 Like

Thanks for noticing that. It’s been corrected.

Hi all. I have vontar x4(s905x4 4/32), and xiaomi Bluetooth gamepad.
I connect it with my vontar, but it not responding for any pushing the bottom. Why?

Go to settings/system/input/driver settings and change it from Linux to udev.

See if that helps.

1 Like

Because Kodi/CoreELEC sees gamepad as both
Mouse and keyboard
Or Joystick and keyboard
At the same time.

I have Xiaomi gamepad bluetooth same as yours

Same results after pairing

Have been researching/reading last 2 days.

There is a udev rule Action thst can be applied
Still working on it…

Happy Testing

Same problem with Sony PS4 bluetooth controler …(work perfect with coreelec Matrix).
Pairing work but the controler not work …

There are also bluetooth sound how not work corectly and impossible to use jack 3.5 audio output for connect with cable …on Beelink GT king 2,i have try all sound output settings, 3 of them is sound on HDMI, bluetooth (not work corectly) , optical (i Can not test) ,so for the moment the only way to listen music is sound with hdmi ,TV must rest on :frowning: ,

If you truly are a music lover than I strongly advise you get yourself a decent HiFi AVR set up with some good speakers. No headphones or other sound systems come even close to immersive realism of a good surround sound system. If money is short look for a good second hand unit or maybe an out of date AVR model available new on a bargain promotion.

Appreciate some folk are not as lucky as I and cannot play music at any realistic volume through speakers. If that is the case then you most certainly need to buy the best headphones you can afford and for best quality do not use BT but connect via a cable.