CoreELEC 20.0-Nexus Amlogic-ng Discussion

I tested CoreELEC 20.0 Nexus and found that DVD folders cannot be played from a NAS. This affects both an upgrade from CE 19.5 to 20.0 and a clean install. I’ve tried about a dozen DVD folders, all to no avail. The same folders, copied to a USB drive, are played back without any problems. DVD ISOs can also be played from the NAS. DVD folders from the NAS also worked under all versions of CE 19, as did under CE 9.

Here are the log files from the clean install:

My hardware:

  1. X88 King (S922x)
  2. X96 Max Plus (S905X3)
  3. NAS: Synology DS 218

You might test this with Windows or Linux Kodi?
I am not sure if and what the problem could be. I only have ISO from DVDs on my NAS and all can be played normally. I did not try DVD folders with VOB files.

I’ve seen the same here, just the error message “One or more items failed to play” when trying to open a DVD folder using the context menu and selecting Play. This is over an NFS share on my PC.

I was able to reproduce the “stuttering video after first subtitle appears” in CE-20. Fixed by jumping back 10 seconds, and the same issue with CE-19 for a long time now.

I’m seeing the same issue that @Doppelgaenger mentioned: I can see wireless networks available but I can’t connect to any of them. This worked great in 19.5 ng, but doesn’t work in a clean install of 20.0 ng. Happy to help troubleshoot this, let me know what I should try.

Tanix TX3 using DTB gxl_p281_2g

I have now tested the DVD folders on Kodi 20.0 for Windows. All can be played back without any problems.

serafis reported the same issue with CE 20.0_beta1: CoreELEC 20.0-Nexus_beta1 Discussion - #25 by roidy

And orlov at CE 20.0_rc1: CoreELEC 20.0-Nexus_rc1 Discussion - #5 by borygo

Regarding whitelisting, is it something that could be developed in CE or in Kodi only?

In my media library, I have mostly 720p sources with video resolutions ranging from 1280x536 to 1280x720 depending on the AR. Refresh rates 23.976 fps, 24 fps or 59.94 fps.

I have set all the 4K and FHD related resolutions as whitelisted. Now when I play a 720p file, CE chooses to output matching some of the FHD ones, I suppose because the refresh rate matches. I would very much like to avoid this unnecessary 720p → 1080p upscaling part and get 720p output to the TV so I can use its HQ upscaler to display at the panel’s native 4K resolution. Is this matching behaviour possible to adjust so that it would check also the difference in resolution?

What I know Kodi will never switch “down” to a lower resolution, only up.

If you want 720p or 576p file played without upscaling you need to whitelist those resolutions.

I can replicate DVD play issue and will try to solve it.

Yes, that is true. I was just astonished to see that the refresh rate alone can be a deciding factor when a match is sought. After all, both vertical and horizontal resolution differ greatly from 1920 x 1080 – and my resolution of choice in the GUI is 2160p anyway.

EDIT: I had a slight brainfart with this, I noticed. What I actually would like to have is to have Kodi upscale 720p/23.976 or 24 fps to 4K and not 1080p. Looking at the log, my HDMI connection doesn’t support 720p at those refresh rates, seems to be a common thing. But I’d still like to retain the possibility to output 1080p as is and keep those selections whitelisted.

I have the same problem @Doppelgaenger and @fish reported and I’m also using the gxl_p281_1g file with a clean install. Does anyone with a 905W device have wifi working with CE20?

Speed tester addon is 1.1.2. . You need 1.1.3
Releases · add-ons/script.speedtester (
Open zip from add on to update.
Link given to me by another member on here :slight_smile:


I have 2 TV-Boxes (both X96 Max+, S905X3, 4/64, gigabit) with CoreELEC 19.5 Matrix (ng) installed internal (eMMC).

Should I consider “safe” updating them to 20.0 ( to update folder; reboot) or should I try other method to use 20.0 ng in eMMC in these 2 boxes?

When I say “safe”, I do NOT mean that everything works perfectly when updating from 19.5 to 20.0. I guess that some add-ons might not work, etc. (this will NOT be a big problem). When I say “safe”, I mean that, when updating, the TV-Box boots with 20.0 without giving errors that prevent the system from loading.

That’s what I did with my Odroid N2+. Just dropped the .tar file into the update folder on my 19.5 build. No issues so far, but I don’t run any add-ons apart from “Radio” that I use to stream IP radio stations.

There have been many posts
Regards to this method

Not recommended
Always clean install on prepared media

Maybe use CoreELEC tools on one of the boxes
And send from emmc back to external SD
Keep in safe location

Now prepare new media SD/USB…

And Test 20 ng on one box to compare.

Happy Testing

I’m running this on N2 and use the superb audio output thro the jack to feed a stereo amp.

I’m starting to notice clicks/pops when starting/stopping video and audio that I’m certain we’re not there in 19.5. I can’t be more specific at this time but I hope to be in the coming days when I’ve had time to swap to nightly and do more direct comparison against 19.5.

I just thought I should mention this now in case it is something that’s known about.


The part of 20.0 testing in a microSD was done and it was OK for me.
Even the part ot migrating from19.5 to 20.0 in a microSD and testing was done, and, also, OK for me (some addons did NOT work, but no big problems) :rofl: :rofl:

My doubt was specific about doing that (the same things) with CoreELEC in eMMC, because I’m worried specifically about all the bootloader stuff and I don’t want to brick the TV-Box.
I do backups frequently, so the problem is not losing the configuration. The problem for me would be that the tv-box would not start after 19.5 to 20.0 in eMMC.

Well… finally I did it in one of the boxes (migrating from 19.5 to 20.0 in eMMC; .tar file to update folder). I did it in the “less critical” one :rofl: :rofl: :rofl: , a box that I use as tvheadend client.


  • Samba, ssh working without issues
  • All 3 VPNs (Zerotier, Tailscale, Wireguard) that I was using via entware, working perfectly well
  • PVR HTS tvheadend client working perfectly well
  • Most of the addons that I use (3rd party sources) working well (in some cases I had to update “manually”, .zip file, etc., but no problem at all)

So far so good!

Next step for me: doing the same thing with the other TV-Box with CE in eMMC (the “critical” one :rofl: :rofl: :rofl: ) that I use as tvheadend server in a place where I don’t live. Same addons (even less) than the other… but tvheadend server inside.

1 Like

Here is test image for playing DVD folder from network. Feedback welcome.

look for a nightly link little down

Good to see you also had no issues using the .tar file update. In my case, I could always go back to a clean install and re-scan my audio and video libraries, but others may have a big or complex setup which they may not want to risk.