CoreELEC 20.0-Nexus Amlogic-ng Discussion

Yes indeed it is with a capital F. I am so used to Windows where the file name is not case sensitive.

Not really. Nexus is brand-new, it will last a couple of years. NG devices will also get the next version (Omega, I think).

So relax, lean back and watch what will come. You have plenty of time to enjoy your NG device.

Thank you very much for the link. I guess this gives time for odroid to release another decent board before i have to change :slight_smile:

Also reading a post of NE vs NG from past October. Nice insights.

Did you grab the correct release ? worked for me first try no issue.

Is it possible to do a clean install but use the v19 databases? I’d hate to lose the watched statuses collected over time.

You could use the watchedlist addon to make a backup of your watched status.
Then just import that after you recreate your databases if wanted.

1 Like

I was able to get around the problem by using Ember Media Manager to read the stuff from Kodi (using the webserver interface) to its local database, install v20, set things up and sync data from EMM to Kodi. The Kodi setup took me maybe an hour including the databases creation from added sources, everything went very smoothly on my Odroid N2.

I tested CoreELEC 20.0 Nexus and found that DVD folders cannot be played from a NAS. This affects both an upgrade from CE 19.5 to 20.0 and a clean install. I’ve tried about a dozen DVD folders, all to no avail. The same folders, copied to a USB drive, are played back without any problems. DVD ISOs can also be played from the NAS. DVD folders from the NAS also worked under all versions of CE 19, as did under CE 9.

Here are the log files from the clean install: http://ix.io/4mqo

My hardware:

  1. X88 King (S922x)
  2. X96 Max Plus (S905X3)
  3. NAS: Synology DS 218

You might test this with Windows or Linux Kodi?
I am not sure if and what the problem could be. I only have ISO from DVDs on my NAS and all can be played normally. I did not try DVD folders with VOB files.

I’ve seen the same here, just the error message “One or more items failed to play” when trying to open a DVD folder using the context menu and selecting Play. This is over an NFS share on my PC.

I was able to reproduce the “stuttering video after first subtitle appears” in CE-20. Fixed by jumping back 10 seconds, and the same issue with CE-19 for a long time now.

https://paste.kodi.tv/haziqesuse.kodi

I’m seeing the same issue that @Doppelgaenger mentioned: I can see wireless networks available but I can’t connect to any of them. This worked great in 19.5 ng, but doesn’t work in a clean install of 20.0 ng. Happy to help troubleshoot this, let me know what I should try.

Tanix TX3 using DTB gxl_p281_2g

I have now tested the DVD folders on Kodi 20.0 for Windows. All can be played back without any problems.

serafis reported the same issue with CE 20.0_beta1: CoreELEC 20.0-Nexus_beta1 Discussion - #25 by roidy

And orlov at CE 20.0_rc1: CoreELEC 20.0-Nexus_rc1 Discussion - #5 by borygo

Regarding whitelisting, is it something that could be developed in CE or in Kodi only?

In my media library, I have mostly 720p sources with video resolutions ranging from 1280x536 to 1280x720 depending on the AR. Refresh rates 23.976 fps, 24 fps or 59.94 fps.

I have set all the 4K and FHD related resolutions as whitelisted. Now when I play a 720p file, CE chooses to output matching some of the FHD ones, I suppose because the refresh rate matches. I would very much like to avoid this unnecessary 720p → 1080p upscaling part and get 720p output to the TV so I can use its HQ upscaler to display at the panel’s native 4K resolution. Is this matching behaviour possible to adjust so that it would check also the difference in resolution?

What I know Kodi will never switch “down” to a lower resolution, only up.

If you want 720p or 576p file played without upscaling you need to whitelist those resolutions.

I can replicate DVD play issue and will try to solve it.

Yes, that is true. I was just astonished to see that the refresh rate alone can be a deciding factor when a match is sought. After all, both vertical and horizontal resolution differ greatly from 1920 x 1080 – and my resolution of choice in the GUI is 2160p anyway.

EDIT: I had a slight brainfart with this, I noticed. What I actually would like to have is to have Kodi upscale 720p/23.976 or 24 fps to 4K and not 1080p. Looking at the log, my HDMI connection doesn’t support 720p at those refresh rates, seems to be a common thing. But I’d still like to retain the possibility to output 1080p as is and keep those selections whitelisted.

I have the same problem @Doppelgaenger and @fish reported and I’m also using the gxl_p281_1g file with a clean install. Does anyone with a 905W device have wifi working with CE20?

Speed tester addon is 1.1.2. . You need 1.1.3
Releases · add-ons/script.speedtester (github.com)
Open zip from add on to update.
Link given to me by another member on here :slight_smile: