CoreELEC 20.0-Nexus Amlogic-ng Discussion

I am disappointed with how subtitles are handled in Kodi 20.0.

In Kodi 19.5 there is option “Below video” and that means below video but in Kodi 20.0 there is no “Below video” but “Bottom of video” and “Bottom of screen” - both giving the the same result and none of these two is the same like in “Below video” in Kodi 19.5 - not possible to set position at very bottom of the screen!
There is also option “Manual” in Position on the screen but what it does and how to use it? I have no idea.

In Kodi 19.5 there are 3 fonts available: DejaVuSans, Arial, Teletext. In Kodi 20.0 only DejaVuSans.
Subtitles colour in Kodi 20.0 is gone.
Italic subtitles in Kodi 20.0 are italic very little in compare with italic in Kodi 19.5.

And the most irritating issue: sometimes two lines of dialog are displayed apparently without respecting subtitle position: very high!!!

In general big disappointment.

Few examples:
Italic one line:

One normal line:

Two normal lines:

Two lines dialog - total disaster:

1 Like

I’ve been using CE20 for almost a year, all the functions are there, you can use any font you like, just copy to .storage/.kodi/media/Fonts (if no Fonts folder, create it). First, use the default skin and then you will see that the skin you used before is not 100% compatible with the Nexus. The display of subtitles works fine for me, just like before.

OK, position “Bottom of screen” and Vertical margin" set to 0% is what I was looking for to have subtitles at very bottom of the screen.
And colour is missing in the skin I’m using but once selected in Estuary remain in my skin.

Issue with two lines of dialog being displayed very high is really annoying especially that it is happening only on some of these dialogs… I tried to see if something is wrong with these particular two lines on the last example I presented above but nothing found. Hope it will not happen too often.
Case closed.

1 Like

Just out of curiosity, was it an update from CE19 or a clean install? Nexus default settings are fine.

Clean install.
Some default settings are not what some people prefer. :slight_smile:

1 Like

I am new to using CoreELEC. This is the first time I have updated, going from 19.5 → 20.0. Can anyone tell me how to go about installing Inputstream Adaptive? I see that it was an issue with installing on rc1 but according to this it should have been fixed with an update. Has it been fixed and if so could someone please tell me how to install the update?


I’ve installed 20.1 nightly update, and also from coreelec repo the amiga emulator.
Something must have happened lately, because now it is too slow, and audio and video stutters everywhere, which was not the case before, when i tried the last time, 1 month ago.
On S905x4 generic device X96_X4.

Maybe some problem with PUAE .

I installed from zip an older version, works much better.

I have problems with 3D switching with the Minix Neo U22-XJ Max. When I disable 3D mode, the picture distorts and the resolution is not correct anymore. With the Minix Neo U1 it works.

Thanks for the tip. I disabled mpeg-dash and it now works. Still has issues with fast forwarding but is usable.

Not sure if the update was just released or something else was going on, but the inputstream adaptive addon just updated after a reboot. I did try clicking on check for updates several times and that didn’t work and I had also rebooted a couple times prior to this as well. But it fixed itself so all good.

3D is obsolete since a few years. Nobody have a 3D TV so we even not able to debug such issues.

Subtitle font look real strange for me.
Any way to add another font the previous used in matrix?

In /.kodi/media/ make a folder and name it Fonts Then drop in this new /.kodi/media/Fonts folder any free/open_source .ttf font that you like. After Kodi reboot you’ll be able to choose that font.

1 Like

What is that:

It popup twice or 3 times since I have installed Nexus 20 on my Odroid-N2.
Every time it was popup I did a reboot but then few hours later it was again.

I have seen this popup too.

I got it after disabing the heatbeat LED on N2. Thought it was normal.
You will get this message one time when you change something in CE DTB settings.
When rebooted it should not come again until you change something else.

I just tried Nexus 20.0 amlogic-ng from a clean install to a SD card on my N2+. When I played back some BD ISOs I noticed some bad aliasing of the image.
When I disable the amlogic hardware decoder, the image is fine again. Am I missing something?

Exactly my toughts

You can do it manually.

Go to Settings - Player - Subtitles. Enter Position on screen. Choose Manual.

Start Video. Enter Settings - Video Settings. Choose Video calibration. Set the short bar down to your choosing. Save calibration. Hit back. Enter Again Video Settings. Choose Set as default for all media.

Or if Video calibration doesn’t work, @Sholander has a solution described here CoreELEC 20.0-Nexus_rc2 Discussion - #66 by Sholander

1 Like