CoreELEC 20.0-Nexus_rc2 Discussion

Anyone else having issues with SSH on rc2? CoreELEC closes the SSH session as soon as the connection is made. Rolling back to rc1 solves the issue with no other changes. Upgrading back to rc2 and the SSH connection issue returns. I am connecting using PuTTY, no issues connecting to my other devices.


First make sure you are running the latest version of putty or use a direct ssh client.

Just tried it out. No problems here with either Putty on windows or Termius on android.

Can you copy the output from ssh client you get on connection?
And do you have entware installed?

I get no output, it just closes the connection. No error. Nothing. You just see the login screen for a fraction of a second then it closes.

Yes I have Entware installed for the CoreElec HW monitor.

You can try to run this command but your issue looks different.


Get the following output.

sh: line 1: /usr/bin/sed -e s|^export LANG=\(.*\)|#export LANG=\1|g -e s|^export LC_ALL=\(.*\)|#export LC_ALL=\1|g -i /opt/etc/profile: No such file or directory

Is it really so hard to copy EVERYTHING from terminal? I don’t know what did you actually execute.

I executed the command specified but I had to add a login name or I got an error and added my device IP.

C:>ssh -l root ‘/usr/bin/sed -e “s|^export LANG=(.)|#export LANG=\1|g" -e "s|^export LC_ALL=(.)|#export LC_ALL=\1|g” -i /opt/etc/profile’
root@vontarx3-lan.local’s password:
sh: line 1: /usr/bin/sed -e s|^export LANG=(.)|#export LANG=\1|g -e s|^export LC_ALL=(.)|#export LC_ALL=\1|g -i /opt/etc/profile: No such file or directory

Ah, running this from Windows … I only run this from Linux console. Looks like single and double quotes behave differently.

1 Like

Ran the same command from my linux server and its now working. Thank you for your help. Merry Christmas!

1 Like

I tried kodi nexus on windows and the calibration works fine, just not working on corelec on the le potato board.

I had no problem with Kodi Leia 9.2.8 in controlling my amplifier’s volume but with Nexus RC1, it has no effect despite the fact I have the same setup.
Any help?

I’m using nexus rc2 on Tanix TX3 and I noticed if you disable gui scaling, you will see more image stutter when you using kodi gui(video playback is totally ok) compare to 19.5rc3(most image flick on 19.5rc3 shows during boot process,after then you can barely notice broken image)

I ran xbian with a kodi nexus installed on the rpi board and got the same problem as on coreelec, cannot callaborate the video scaling so it seems its a kodi issue.

1 Like

I’m getting a bit of noise in the picture when playing 4K on my GT King. It is not completely broken, it just has a little noise over it. Looks like there are some drops on the HDMI (TV OSD keeps popping up). I’ve been using 9.2.8 until now without any problems. Any hints on what might be wrong?

  • The device is GT King Pro (S922X rev b).
  • I’ve been running 9.2.8 from eMMC without any issues until the update.
  • I’ve done the update to 20.0rc2 manually by placing the .tar to .update folder.
  • Playing local files up to 1080p works fine (including HDR and audio passthrough).
  • Playing my local test file in 4K HEVC HDR shows the issue (the same file was playing fine in 9.2.8).

Also “Display supported HDR types” in System Info panel shows “None”, but my TV (older Sony from 2018) supports HDR10 and it seems to be working when playing HDR content (TV switches scene to HDR automatically).

Thank you for any hints.

The information is that section of System Info is to disregard at the moment. It gives no real indication of your setup capabilities. HDR10 , JDR10+ and HLG are supported in CoreELEC for years.
You can start by checking HDMI cable and your PSU (if you have another compatible one at hand).
After this initial tests, if the problem persists please collect some logs:

Thank you for the confirmation about the System Info HDR support section. I know there is ongoing work on the HDR support in the open source drivers stack. Possibly this should be removed from the CoreELEC as it is not going to work for the vendor kernel?

Regarding the HDMI cable and the PSU, the playback of the same file worked fine in 9.2.8, so there is probably no hardware problem.

Also I’m aware that I went through the unsupported way of doing the update from Leia to Nexus and I know I’m going to need to remove and reinstall everything Python related (not many in my case), but I don’t expect this could have an impact on the local file playback, right?

If you’re sure everything is alright I’m your setup, please provide logs. Regarding that information in system info, as I said, disregard it for now, it’s a low priority issue to solve.

This is correct, it’s not recommended to upgrade from older versions. When you really want to have help you will need to start again with a clean fresh install. You will see some issues will be solved by itself.