CoreELEC 20.0-Nexus_rc2 Discussion

Please use this thread for general CoreELEC 20.0-Nexus_rc2 discussion

Before posting an error please follow these troubleshooting steps.

2 Likes

Has RC2 been pulled? Only RC1 seems to be available.

I just found a merge error in last second so you got lucky at got the 30min where the release was offline…

Thanks Portisch!

When i try to do a video calibration, when pressing the arrow buttons nothing is happening. tried a keyboad and getting the same results. i can select the different over scan settings (top left, bottom right, subtitle positon, pixel ratio adjustment) but no adjustment is made when pressing the arrow buttons.

Done a clean install of CoreELEC 20.0-Nexus_rc2 and am finding that ‘scanning for new content’ is taking forever.

There is also a 4sec or so delay before playing movies.

The log shows multiple instances of ‘Unable to lookup host: ‘readyshare’

(readyshare being the ‘Server name’ for the SSD card ‘Server1’ holding my media files: this is just an SSD on my home network, and is not a server as such).

I have tried:

  • using an eMMC, and then a MicroSD card for the system files

  • re-instating 19.5_rc3 using a different eMMC card – but it is not having any of these problems

I am using an Odroid N2+, hardwired to the media SSD on my Network.

The log URL is http://ix.io/4jh2

Grateful for any advice.

Same behavior on other platforms like Linux or Windows?

There is an error in script - I don’t know if readyshare comes from the same script too.

022-12-22 14:34:30.242 T:3819    error <general>: /storage/.kodi/addons/script.skin.info.service/default.py
2022-12-22 14:34:30.242 T:3819    error <general>: :46: 
2022-12-22 14:34:30.242 T:3819    error <general>: SyntaxWarning
2022-12-22 14:34:30.242 T:3819    error <general>: : 
2022-12-22 14:34:30.242 T:3819    error <general>: "is not" with a literal. Did you mean "!="?
2022-12-22 14:34:30.242 T:3819    error <general>: 
                                                   
2022-12-22 14:34:30.253 T:3819    error <general>:   
2022-12-22 14:34:30.253 T:3819    error <general>: if (self.selecteditem is not ""):
2022-12-22 14:34:30.253 T:3819    error <general>: 
                                                   
2022-12-22 14:34:30.387 T:3816    error <general>: Unable to lookup host: 'readyshare'

haven’t tried it on linux or windows, im running CoreElec on the Le Potato board.
the video calibration works perfectly fine when i was using 19.5_rc3 on the same Le Potato board but only see this issue when upgraded or clean install to version 20. I even reverted back to 19.5 and everything worked fine.

Hello all!
I have a an openvpn client installed from Entware repository.
It is configured to connect to a TAP openvpn server. With CE 19, everything was fine. But in CE20 openvpn client somehow cannot get IP address through DHCP from OpenVPN server.
The error on openvpn log is:

WARNING: OpenVPN was configured to add an IPv4 route. However, no IPv4 has been configured for tap0, therefore the route installation may fail or may not work as expected.

If I assign address and routes manually, everything works fine like in CE 19:

ip addr add 192.168.72.95 dev tap0
route add -net 192.168.72.0 netmask 255.255.255.0 gw 192.168.72.95
systemctl restart kodi

What’s your opinion, is it an incompatibility with CE20 in openvpn package or a bug in CoreELEC ?

Thanks very much vpeter.

Uninstalling script.skin.shortcuts has fixed the playback issue, and dramatically reduced the time scanning for new content.

‘Scanning for new movies content’ at startup is still hanging for a time at 80%, and then again at 92%, with the log showing ten “Unable to lookup host: ‘readyshare” errors.

I don’t know much about Netgear’s Readyshare, apart from it enables me to connect a USB storage device to my Netgear router and make it available over my network.

I do know however that it works fine with 19.5_rc3, so I am wondering if this is a CoreELEC 20.0-Nexus_rc2 issue.

The log URL is http://ix.io/4jls

I know a little bit more.
It´s slow and not very stable.

Thanks Tim.
However, I must say that over the 5 years that I’ve owned my current Netgear router, this is the first occasion that I’ve encountered a problem with Readyshare. Indeed, personally, I’ve always found it fast and reliable for sharing videos, music, and photos over a wide variety of devices and versions of Kodi.

Consequently, I wasn’t expecting a problem with 20rc2, as the Odroid N2+ on which it runs is hardwired to my router.

I should add that Readyshare continues to work very well with my other devices.

Regarding hostname resolution on your LAN (which is what your issue appears to be), I would suggest checking the following in CoreELEC,

Settings >> CoreELEC >> Services >> Enable Avahi (Zeroconf) <<< Make sure this is enabled and then reboot CoreELEC.

Alternatively, you could instead map your network drive using it’s IP address rather than the hostname, however, you would likely then need to rescrape your entire media collection as the kodi database entries would then be invalid.

You could also try adding an entry for your file server into /storage/.config/hosts.conf and then reboot

the entry in hosts.conf would be something like:

192.168.0.1 readyshare

Note that 192.168.0.1 should be changed to whatever the IP address is of your Netgear router.

Brilliant!!!

Enable Avahi (Zeroconf) was enabled, however your suggestion re editing /configfiles/hosts.conf
to include:
192.168.0.[readyshare location] readyshare
was the answer.

Odd that I have never had to edit hosts.conf with previous versions of Kodi, but I’m just grateful it’s solved.
Thanks again!

If two add-ons share a dependency and one add-on is disabled, uninstalling the active one removes the shared dependencies.

Currently using Nexus rc2, but it happened on rc1 and beta1 as well (didn’t tested alpha).

Anyone else having issues with SSH on rc2? CoreELEC closes the SSH session as soon as the connection is made. Rolling back to rc1 solves the issue with no other changes. Upgrading back to rc2 and the SSH connection issue returns. I am connecting using PuTTY, no issues connecting to my other devices.

Log: ix.io/4jxr

First make sure you are running the latest version of putty or use a direct ssh client.

Just tried it out. No problems here with either Putty on windows or Termius on android.