CoreELEC 20.0-Nexus_rc2 Discussion

Can you copy the output from ssh client you get on connection?
And do you have entware installed?

I get no output, it just closes the connection. No error. Nothing. You just see the login screen for a fraction of a second then it closes.

Yes I have Entware installed for the CoreElec HW monitor.

You can try to run this command but your issue looks different.

2 Likes

Get the following output.

sh: line 1: /usr/bin/sed -e s|^export LANG=\(.*\)|#export LANG=\1|g -e s|^export LC_ALL=\(.*\)|#export LC_ALL=\1|g -i /opt/etc/profile: No such file or directory

Is it really so hard to copy EVERYTHING from terminal? I don’t know what did you actually execute.

I executed the command specified but I had to add a login name or I got an error and added my device IP.

C:>ssh -l root 192.168.88.154 ‘/usr/bin/sed -e “s|^export LANG=(.)|#export LANG=\1|g" -e "s|^export LC_ALL=(.)|#export LC_ALL=\1|g” -i /opt/etc/profile’
root@vontarx3-lan.local’s password:
sh: line 1: /usr/bin/sed -e s|^export LANG=(.)|#export LANG=\1|g -e s|^export LC_ALL=(.)|#export LC_ALL=\1|g -i /opt/etc/profile: No such file or directory

Ah, running this from Windows … I only run this from Linux console. Looks like single and double quotes behave differently.

1 Like

Ran the same command from my linux server and its now working. Thank you for your help. Merry Christmas!

1 Like

I tried kodi nexus on windows and the calibration works fine, just not working on corelec on the le potato board.

Hi,
I had no problem with Kodi Leia 9.2.8 in controlling my amplifier’s volume but with Nexus RC1, it has no effect despite the fact I have the same setup.
Any help?
Thanks.

I’m using nexus rc2 on Tanix TX3 and I noticed if you disable gui scaling, you will see more image stutter when you using kodi gui(video playback is totally ok) compare to 19.5rc3(most image flick on 19.5rc3 shows during boot process,after then you can barely notice broken image)

I ran xbian with a kodi nexus installed on the rpi board and got the same problem as on coreelec, cannot callaborate the video scaling so it seems its a kodi issue.

1 Like

Hi,
I’m getting a bit of noise in the picture when playing 4K on my GT King. It is not completely broken, it just has a little noise over it. Looks like there are some drops on the HDMI (TV OSD keeps popping up). I’ve been using 9.2.8 until now without any problems. Any hints on what might be wrong?

  • The device is GT King Pro (S922X rev b).
  • I’ve been running 9.2.8 from eMMC without any issues until the update.
  • I’ve done the update to 20.0rc2 manually by placing the .tar to .update folder.
  • Playing local files up to 1080p works fine (including HDR and audio passthrough).
  • Playing my local test file in 4K HEVC HDR shows the issue (the same file was playing fine in 9.2.8).

Also “Display supported HDR types” in System Info panel shows “None”, but my TV (older Sony from 2018) supports HDR10 and it seems to be working when playing HDR content (TV switches scene to HDR automatically).

Thank you for any hints.

The information is that section of System Info is to disregard at the moment. It gives no real indication of your setup capabilities. HDR10 , JDR10+ and HLG are supported in CoreELEC for years.
You can start by checking HDMI cable and your PSU (if you have another compatible one at hand).
After this initial tests, if the problem persists please collect some logs:

https://wiki.coreelec.org/coreelec:debuglogs

Thank you for the confirmation about the System Info HDR support section. I know there is ongoing work on the HDR support in the open source drivers stack. Possibly this should be removed from the CoreELEC as it is not going to work for the vendor kernel?

Regarding the HDMI cable and the PSU, the playback of the same file worked fine in 9.2.8, so there is probably no hardware problem.

Also I’m aware that I went through the unsupported way of doing the update from Leia to Nexus and I know I’m going to need to remove and reinstall everything Python related (not many in my case), but I don’t expect this could have an impact on the local file playback, right?

If you’re sure everything is alright I’m your setup, please provide logs. Regarding that information in system info, as I said, disregard it for now, it’s a low priority issue to solve.

This is correct, it’s not recommended to upgrade from older versions. When you really want to have help you will need to start again with a clean fresh install. You will see some issues will be solved by itself.

So I’ve tried and booted a clean installation from SD card. Unfortunately the issue persists.

Here is exactly what I did in case I’ve missed something:

  1. I’ve run fw_setenv upgrade_step 3 on my internal CE installation.

  2. I’ve booted a legacy CE 9.2.8 from SD card to verify that the file still plays there without issues. It does, so there is no hardware issue. It plays flawlessly in native 4K HDR and with DD+ passthrough.

  3. I’ve created a clean SD card with CE 20.0rc2 (Generic Amlogic-ng). Booted from it and the issue is the same as with my internal installation.

System info:
CoreELEC (official): 20.0-Nexus_rc2 (Amlogic-ng.arm)
Machine model: Beelink
CoreELEC dt-id: g12b_s922x_beelink_gt_king
Amlogic dt-id: g12b_w400_b

The device:
It is a Beelink GT King Pro (blue aluminum case) with S922X rev. B SoC. It might be worth mentioning that it is one of the older revisions (those were specific by not turning itself on after power loss). When I was trying CE on it for the first time, there was the “green screen” issue. It was solved by the Android update and because everything was working fine, I’ve done internal installation using the ceemmc. Since then I was doing updates by placing .tar to update folder.

The test file:
The file is regular Dolby presentation file downloaded from the internet (Core Universe.m2ts). It is HEVC 4K@24 (probably Dolby Vision) with multiple audio streams (ATMOS and DD+).
It is about 980 MB (SHA1 60b1d34a434e8f933dee0cfa3f69c3a3b1bdeb93).
I’m not sure if I can place a direct link here, so just search for Dolby Trailers Core Universe.

The TV:
Sony KD-43XE7096.

Logs:
For some reason automatic upload of system logs from CE addon doesn’t work for me, so I’ve placed it here:
http://koprajs.mx-net.cz/CE_logs.zip

Try to limit colour depth to 8 or 10 bits in expert display settings.

That was fast! And it works indeed, limit colour depth to 10 bits solves the issue. Thank you for the super fast support and happy new year!

1 Like