CoreELEC 20.2-Nexus Amlogic-ng Discussion


Please use this thread for general CoreELEC 20.2-Nexus Amlogic-ng discussion

Before posting an error please follow these troubleshooting steps.

1 Like


I am using this version on La Frite with 1 GB RAM
but hardware decoder for HEVC videos does not work - in fact it does not work since version 19.5-Matrix_rc2 -
on 19.5-Matrix_rc1 HW decoder works fine.
Is there any chance that it can work again ?
19.5-Matrix_rc1.log (15.8 KB)
20.2-Nexus.log (9.8 KB)

After updating my X96 Max+ to todays release 20.2 I cannot play video from my NAS anymore (all of those files were working fine on 20.1).

Here’s the log: hastebin

There are mutliple errors with the decoder:

2023-07-02 16:29:12.742 T:5194    debug <general>: CVideoPlayerVideo - video decoder returned error
2023-07-02 16:29:22.743 T:5194     info <general>: Skipped 9057 duplicate messages..
2023-07-02 16:29:22.743 T:5194    debug <general>: CVideoPlayerVideo - video decoder returned error
2023-07-02 16:29:32.744 T:5194     info <general>: Skipped 9050 duplicate messages..
2023-07-02 16:29:32.744 T:5194    debug <general>: CVideoPlayerVideo - video decoder returned error

I have also noticed that my TBS 5520SE USB DVB-S2 tuner stopped appearing in the TVHeadend. TVH has been updated right after the update to the 20.2 so it’s at the newest version. There were no CrazyCat driver updates.

Edit: I tried to do the downgrade to 20.1 using tar file but for some reason its still the same - maybe kernel did not got updated since it was a downgrade or what…

please post the link you get for:
cat /sys/class/amstream/vcodec_profile | paste

best for 19.5_rc1 & 20.2, thx

Your config looks like broken:
CAMLCodec::OpenAmlVideo - cannot open V4L amlvideo device /dev/video10: No such file or directory

This can not be happen. Try with clean new install on different boot media.

Here are the links


Ok, looks your S805X is h265 capable, but not in 4k:

VP9 P2 1080P30
H.265 MP10@L4.1 1080P60
H.264 HP@L4.2 1080P30

The problem is now that the kernel remove all functionality when not 4k capable.
I will look how to fix this.

I think you are right, something during the update broke the config. When I did a new clean install it worked fine, but when I restored a backup to that new installation - it was broken again. Do you know maybe if I can just copy the proper configuration from old backup to fix it or is seting up everything the only way to go?

This is the preferred way, yes.

Ugoos X3 pro Bluetooth not working :frowning:
Wi-Fi - OK

Thanks, that’s what I did and now everythings good. No idea what was it but it has never happened before. Anyways, its good now! Thanks!

@oklio you will upload a sample like 100MB of h265, 10bit. I do not find some in 1080p, only 4k.
SHA256: 7f0d2b5dc9803039ae725903d89ef15d9cc904524bd661b931ccdbdbf8bf7bf9

Please, let me know when you download file so I can remove it from GDrive

Ok, I see now the issue and might be able to fix it. All parameter are just ignored when not 4k capable.

The fix will be in next nightly and ongoing release.

Safe to install on the Odroid N2+? No issues like on the S805X?

Why? Is N2+ a S805X?


Just asking, excuse me.

now HW HEVC decoder works - thanks :sunglasses:

1 Like