CoreELEC 21.0-Omega_alpha2 Amlogic-ne Discussion


Please use this thread for general CoreELEC 21.0-Omega_alpha2 Amlogic-ne discussion

Before posting an error please follow these troubleshooting steps.

Is this based off nightly 2806 or 2906?

Latest which means 2906.

1 Like

Hello, I am using a Tx3 Mini+ 4/64 GB using S905w2, with s905w2 4g dtb, MD5 (756215565431E81D74B9EACEC560E845). With the latest alpha, booting through microsd is erratic, sometimes it works, sometimes not? the install freezes on resizing partition. I keep rebooting until it goes to main screen. Sometimes its stuck on the coreelec logo and many times I only get a black screen. Using the same sdcard on a USB reader works perfectly and I have no issues.

Here is the log using USB reader :

I don’t know how to get the logs from the device while it is still booting.

Latest CE Omega made my Tox3 box working with aarch64. Until now I had lost hope for make it a daily driver until the final version. Talking about running from SD card. Still I’m using the Odroid C4, too bad Hard Kernel didn’t pull something new with AV-1 codec.
Nevermind my runt, things are looking good and Kodi Omega Beta is already open as milestone.

What is the current set of HW supported by the “ne”? Mainly interested in Beelink GT King Pro (S922X rev. b).

1 Like

To be honest we have some news in background:
Amlogic Kernel 5.15

This will bring back G12B (S922X/A311D) and SM1 (S905X3) back to Amlogic-ne.

Because of the currently destabilized Kodi Omega status we try to re-configure CoreELEC-20 and CoreELEC-21. This mean Dolby Vision is on plan to be backport to CoreELEC-20 and the new Kernel 5.15 is planed for CoreELEC-21.

The Kernel 5.15 CoreELEC-21 will have no GXL support anymore as there will be no more Amlogic-ng device with Kernel 4.9. We are not sure about G12A (S905X2), maybe it’s supported or maybe not.


As an owner of a S922x box that is good news.

A stupid question though - apart from DV support for licensed SOCs, are there many media playback improvements that the newer kernel brings with it?

As the hardware stay same… no?

Sure the hardware stays the same, was just checking if the new kernel or media modules saw any improvements/fixes from AMLogic that would be user noticeable, e.g. to the poor tonemapping that G12B devices have compared to SM1 devices, or the somewhat poor quality upscaling?

I suppose if/when it is available to try I can find out for myself.

If im reading this correctly, in future we can expect for sm1 boxes (s905x3) be upgraded from ng to ne and support 5.15 kernel

No, ne is on aarch64. New/fresh install needed. If I am wrong, please correct me CE team.

Yes, it’s correct. It is always preferred to make a fresh install from another device or major version to prevent unknown issues.

5.15 will be Amlogic-ne aarch64 with the knowledge we have today, yes.

1 Like

Will it be possible to add a driver to NE to support HDMI->DVI adapter? In alpha2 it is still impossible to use such adapter (see a post about the problem here). Since NG works with such adapter, it seems that NE should be able to as well.

Hi, are there known issues causing graphical glitches with 21.0 amlogic-ne alpha and nightly? (thin horizontal colourful stripes across the screen). I tried last and previous nightly as well as alpha2. With sc2 4g and 4g + 1gb generic DTBs.
It looks like it’s stuck and bootloops. Only blue led lights up whereas when running stock Android 11, red led also lights up.

This is on a H96 Max X4 (S905X4) (documented as working here, I can confirm ng arm works alright on my device, I got a 4GB/32GB) but I’m only interested in actual aarch64.

Opened it up, no serial clearly marked. I noticed a 4pin 2.0mm unpopulated header, took a bet and soldered a header but no luck trying to get anything out of the Android boot (serial speed 921600). :frowning:

Couple of observations
Link you posted
No Gbit ethernet on your boxes.
Try device tree 100 Mbit

Fir serial rs232

Hi @freddy and thanks :slight_smile: I did try the 100Mbit image mostly! I just tried the gigabit out of luck.
I did also try 115200. Nothing. 921600 seems to be often reported as serial speed for sc2. What I appear to have gotten wrong is the pinout as it was just a wild guess. Any other guesses? :slight_smile: (The header was added by me, it was unpopulated)

EDIT: Fwiw, android dmesg:

:white_check_mark: :checkered_flag: It turns out the issue was because using an HDMI to DVI adapter on the screen, using another HDMI screen shows that latest amlogic-ne 21.0 nightly is actually working!
What difference in configuration could I check to match ng with ne with regards to this sort of issue? Probably some graphics options… Wow okay post #17 had this clearly explained sorry…