CoreELEC 8.95.7


#1

CoreELEC 8.95.7

CoreELEC 8.95.7 is now available and can be downloaded from our GitHub page here.

Features

Fixes

  • fixed 4K HEVC resync after skip
  • fixed AVL6862 detection
  • fixed DTB’s not updating
  • fixed WiFi resume after wake from sleep
  • fixed WoL for devices with RTL8211F

Updates

  • improved ethernet connection speed
  • reverted CEC changes introduced in previous release

Additions

  • added boot logo support for LePotato
  • added device support for Mecool M8S Plus DVB
  • added eMMC boot/install support for LePotato
  • added support for gpioplug-ir-recv on Odroid C2
  • added support for MT7610U based WiFi adapters
  • added WoL support for LePotato

#3

Just perfect !! Excellent work ! The bugs are now nonexistent for me !

When do we move to improvements decided by community referendum? :smile:
Support for AV1.
High definition pouch.
HDR10 symbols in file information.
Thumbnail when moving forward (like Netflix). Ability to easily reload all Kodi settings from one device to another automatically (like Netflix with account system for exemple)
Etc.


#4

All that with Kodi 19 :wink:


#7

Thank you for your great work!
Is there any reason why you blacklisted the “mono” add-on?
It is needed for the very useful WebGrabPlus add-on to get PVR EPG data.


#8

I believe its been replaced with .Net Core Runtime addon.

Shoog


#10

@Fenderman
It was blacklisted because it’s more trouble to build than it is worth.
.NET Core has been included for a while now, but WebGrabPlus needs to be updated by the addon authors to build correctly against it.
We will keep the existing build of Mono in the addon repo, so even though it will not be updated anymore, it’ll still be there if you need it.


#11
  1. AV1 : AOMedia Video Codec (futur…), but it’s for Kodi Team too, no cpu support at now !

#19

Can you give more details or tests about this?
Thanks :slight_smile:


#21

The wrong IRQ trigger type for the macirq was causing the connection speed to drop after a few hours when stress testing the DUT. The fix seems also to fix another long standing issue with EEE.


#22

Thanks, was wondering about that myself.


#25

Hi, I have three Odroid C2 devices and all of them auto updated to this version today. Unfortunately now none of them work after a reboot.

I’ve wiped one, done a clean install and it’s working fine but as soon as I copy my advancedsettings.xml file (for my shared MySQL library) the box will not start at all. Before the update everything/box has been working fine, the XML file is standard

Any ideas?


#26

Anyone else getting brutal popping with pt-dts when the stream inits? Happens with file playback when the stream doesn’t start at the beginning.


#27

Could you please provide the full contents of your advancedsettings.xml?


#28

Did this happen to you before with 8.95.6? Which device are you using and how is it connected to your equipment?


#29

1.) No, this seems to be new.
2.) S905
3.) HDMI
4.) Passthrough


#30

I have the same setup (S905 (Wetek Hub) / HDMI / passthrough > AVR > TV) and can’t reproduce the problem.
I just tried it with different video files/audio formats when resuming, and it never happened to me.

Did you try to activate the “keep audio device active” options?

Which device exactly do you own?
Maybe someone with the same device can reproduce it.


#31

It’s a niche device from a China -> Canada manufacturer unfortunately (Zoomtak T8V). I haven’t noticed it on non-DTS files; just 3 times on House Bluray.

STR:
1.) Play a DTS file.
2.) Skip ahead so Kodi will preserve its mid-play timestamp.
3.) Play an AAC file.
4.) Start 1. Again.

It may have something to with the audio packets as passthru doesn’t kick in for atleast a couple seconds and then the pop.


#32

I can’t find any AAC encoded audio streams in my library, so I can’t exactly follow the steps above. But just resuming videos with dts sound works flawless for me.
Is it only happening to you, when an AAC stream is played prior to the dts one?

Did you try the “keep audio device active” option mentioned above?


#33

Thanks for all your efforts!


#34

Is A95x’s remote working in latest build without the involvement of putty’s command?