CoreELEC 8.99.1.1 breaks wifi with MT7610U

#1

Hi,

After upgrading from 8.95.7 to 8.99.1.1, wifi no longer works for me with MT7610U adapter.

Also what happed with skin support from 18.0 RC to 18.0 Final ? - My Aeon Nox skin got disabled automatically.

Br,
Miwer

#2

Team Kodi made a GUI API bump in the final of Leia so the skin needs to be updated by the developer.

I’m aware of the other issue and looking into it.

1 Like
#3

Is the wifi issue with this adapter fixed in 8.99.2 or should I hold the update for another version ?

Br.

#4

Hi,

This is still broken in 9.0.1.
Is there any progress in getting this wifi adapter working again in CE ?
I would be nice with a working 802.11ac adapter, as I’m stuck with an older adapter right now.

If it helps, here’s an output from dmesg when plugging in the device:

[  374.322445@2] usb 1-1.3: new high-speed USB device number 6 using dwc_otg
[  374.438157@2] usb 1-1.3: New USB device found, idVendor=148f, idProduct=761a
[  374.438161@2] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  374.438164@2] usb 1-1.3: Product: WiFi
[  374.438166@2] usb 1-1.3: Manufacturer: MediaTek
[  374.438169@2] usb 1-1.3: SerialNumber: 1.0
[  374.469032@1] rtusb init rt2870 --->
[  374.469702@1] 
[  374.469702@1] 
[  374.469702@1] === pAd = ffffff8003e10000, size = 895280 ===
[  374.469702@1] 
[  374.469822@1] <-- ERROR in Alloc Bulk buffer for HTTxContext!
[  374.469824@1] ---> RTMPFreeTxRxRingMemory
[  374.469834@1] <--- RTMPFreeTxRxRingMemory
[  374.469837@1] ERROR!!! Failed to allocate memory - TxRxRing
[  374.470071@1] <-- RTMPAllocAdapterBlock, Status=3
[  374.470094@1] rt2870: probe of 1-1.3:1.0 failed with error -1
[  374.470342@1] usbcore: registered new interface driver rt2870

Thanks :slight_smile:
/Miwer

#5

It will be fixed in tomorrows nightly, apologies for the delay.

2 Likes