CoreELEC 8.99.1.1


#25

I tried to upgrade an Odroid_C2 that uses Xbox One tuner to 8.99.1: booting stopped after CoreELEC 8.99.1 message

To revert to 8.85.7, I copied corresponding image to STORAGE/.update of the eMMC, using a Linux PC

In order to avoid a repeat, I have disabled auto-update in the settings

I hope that you will be able to fix this problem without too much effort


#26

the update automatically still does not work?


#28

My adjusted remote key bindings doesn’t seem to work anymore. Not with the remote.conf stuff or with meson-ir. It seems the remote config is a standard one because if I disable both remote.conf and the meson-ir configuration the remote does still haves the same behaviour. it’s also not precise anymore, I have to push a button several times to get a result and then it does all the pushes in once. All with my NEC remote.
I had also my sony RMT-B127P remote configured with the meson-ir way and this one doesn’t do anything anymore (remote.conf for NEC remote is deleted). I go back to the previous coreelec version without the remote.conf feature.

By the way, I’m on a KVIM S905x


#29

Rather than just reverting it would of been helpful if you had opened a thread on your issue so that we could try and assist you, if meson-ir was not working then you still had a copy of remote.conf in either /storage/.config or /flash, remove it from both locations and reboot and meson-ir will work as normal.


#30

@adamg
indeed there was still a remote.conf on the root of my sd-card.

Sorry if I didn’t sounded polite and didn’t open a new thread. Just thought it wasn’t worth it to open a new thread for it.


#33
ssh yourboxipaddress
cd .update
wget https://github.com/CoreELEC/CoreELEC/releases/download/8.99.1.1/CoreELEC-S905.arm-8.99.1.1.tar
#or for S912
#wget https://github.com/CoreELEC/CoreELEC/releases/download/8.99.1.1/CoreELEC-S912.arm-8.99.1.1.tar`
reboot

#64

Please do not use this build if you use media_build dvb drivers, we are investigating an issue that causes boot loops when these are enabled.

-edit
This has been fixed now in our latest nightly image.


#66

I tried Netflix on my X92_S912 box (overclocked GPU) and must say that it works perfect with subtitles. It does raise CPU temp so it needs a box with decent cooling.
The temperature on my box, with a bigger passive cooler, runs at steady 58°C temp while playing hardware decoded material it stays at 48°C.

One thing, the info shows that Netflix runs at 1280x720i instead of 720p. Is there some setting that I overlooked to get 720p?


#67

Many thanks for the new release! But subtitle stutters seems worse for me as well. Minix U9-H.

I can’t really recall why this is an issue, is it only with the 912 SoC?


#68

Yes, it’s only with S912 SoC.
On many boxes it can be avoided with a line in “advancedsettings.xml”

This is my advancedsettings.xml:

<advancedsettings>
  <gui>
    <algorithmdirtyregions>0</algorithmdirtyregions>
  </gui>
</advancedsettings>

When placed in “storage/.kodi/userdata” folder (and reboot) it solves subtitle stutter on my S912 box


CoreELEC 8.99.2
#69

Autoupdate isnt working - i appreciate the advice on how to manually trigger update, buy was wondering still why autoupdate isnt working? Is it because of confusion on the new version numbering?

Otherwise there was an error in the server about a month ago which broke autoupdate, but then the developers noticed it and fixed it and it worked again - maybe thats again?


#70

Because we had issues with the original 8.99.1 build, and just want to make absolute sure that everything is working as expected before enabling automatic updates for everyone.


#71

Auto update Programmed ?


#72

No its being skipped in favour of 9.0.0


#73

I’ve tried that, but that didn’t solve it for me completely unfortunately. Any more details why only 912 SoC’s are affected and why it’s happening, just curious. Will it be possible to fix in the future?


#74

@e2zippo we already have a fix for it but it needs further testing.


#75

@e2zippo, I sent a link to you in personal messages if you want to try it. But possible it has some issues for SW decoding.


#77

Is it possible to update from Version 8.95.7? What do I need for settings to update CoreElec?

I tried to set Manual as Update Option, but when I try to select an Update Channel and available Versions both lists are empty.

Or is there some Tty Command for updating CoreElec?

Sorry if I missed something, I am new and have only used Libreelec before.


#78

Auto updates are disabled currently, until all problems are solved.

For manually updating take a look at @Ray’s answer above: