CoreELEC Amlogic-ng(4.9 kernel) for S905X/S905D/S905W - FunHouse builds

I think I found the cause.
Link Auto Negotiation was disabled on my Mikrotik router for the port that was connected to Le Potato. It was manually set to 100Mbps Full Duplex. I did that for some troubleshooting purposes a while ago.
I re-enabled Auto Negotiation and it doesn’t hang up anymore.

Hey everyone.

Not sure if this is the best place to ask, but what skin/settings are you using with this build?
I’m experiencing lag with Mecool KI Pro no matter what skin I use…
no lag when there’s nothing playing in the background, but when anything is playing, GUI seems unusable… I’ve seen it can be fixed when not using 1080p60, but I’d like playback of 1080p60 content. Thanks for any help.

By default it’s the default kodi estuary skin.

Using the funhouse build on a LePotato(so s905x soc) with the gui set to 1080p60 and default skin. I just tried browsing a list of movies while playing 1080p and 4k content and didn’t notice any real difference between content playing and not playing.

Is this with the default skin, and what part of the gui in particular? menus, libraries, etc…?

1 Like

Cannot boot with the latest build on my Tanix TX5 Pro.
The boot logo appears to be static, with no extraction % lines in upper left corner.
I remember booting successfully a few builds ago.

Do you have the Factory Android on your TX5 Pro ?
Or a custom Android 8 or 9…

Is this a new image install or an update from previous Funhouse using .tar ??

I presume you are trying to boot from SD Card / USB stick

If your box is this you are in the wrong topic.
Amlogic S905X2 / 4 GB DDR4 + 32 GB EMMC / 2.4G + 5G WiFi / BT4.2 / 100Mbps / USB3.0

Thanks for the tip.
Another ridiculous brand model naming from the Chinese.

Member routir has been around CE for a while and has used Funhouse before.

I have the factory Android and trying to boot from USB stick with a new image using the toothpick method.

The Amlogic-ng(4.9 kernel) for the S905X/S905D/S905W devices has all been merged into the main repository. So tonight’s(20200716) nightly build will have everything that the last funhouse build had, and once tonight’s nightly build is available I would recommend switching to the nightly builds to continue testing.

Thank you very much to everyone that has helped with testing.


Is there anybody here that has both a Tanix TX3 and a uart adapter? (and is preferably comfortable with attaching one to the other)

I need a log from the serial console of what is happening when the device reboots instead of shutdown, to help determine the cause.


I saw you got the TX5 Pro S905X to boot. Can you let us know what happened ??

I installed the none-ng build:
And then updated with .tar and .nocompat

1 Like

So funhouse_2028.2 fresh install failed ?

I tried several times with different USB sticks - no success.

Have to see if other hardware shows same result.

Today, for the first time, I tried using amlogic-ng build (last funhouse and last nightly) on my ‘Trongle X4’ (s905x / 1Gb / 8Gb / 100Mbit), but both don’t work.

I tried with ‘gxl_p212_1g.dtb’ (the same one I use with CoreELEC stable - kernel 3.14) and with ‘gxl_p212_1g_slowmmc.dtb’.

What happened:

  1. I wrote CoreELEC on SD card (first the funhouse build, then the last nightly build).
  2. I turned on the TV box (started Android), I inserted the SD card, I opened the terminal emulator and I ran the command ‘reboot update’.
  3. The TV Box has been restarted in CoreELEC.
  4. Coreelec has checked the filesystem, resized the system partition and restarted the box.
  5. After rebooting, the TV Box has stuck on the Coreelec startup logo, no message has been displayed and after a few minutes of waiting the TV Box has restarted automatically (started CoreELEC).
  6. Continually repeats step 5 (boot loop).

Do you have any advice to give me to solve it?
Did I do something wrong?

Thats strange cause the resize works.

You did nothing wrong… Can you check the flash partition on your uSD card after it does not reboot, to see if the dtb.img and kernel stayed the same and did not get somehow corrupted?
Btw, with which program did you burn your uSD card? I get best results using “Balena Etcher” on PC…

Xoro HST 260s, gxl_p231_2g_dvb, CoreELEC-Amlogic-ng.arm-9.2-nightly_20200717 = Black screen.

@Ray @Sholander
I updated step 5 and added step 6 to my previous post.

I recorded a short video (2 minutes).
EDIT: In the video the colors are not exposed correctly, but on the screen they are displayed correctly.

Partitions of the SD card after recording the video::

  2. STORAGE’ (it has been resized correctly).

I tried with two new SD cards, and I wrote the image on SD cards with ‘balena etcher’ with the ‘validate write on success’ option enabled (as I usually do), but tv box get stuck in boot loop.