CoreELEC Amlogic-ng(4.9 kernel) for S905X/S905D/S905W - Getting Started

hi there, keep up the great work!
I’m having trouble finding the device tree file.
I looked here: but it doesn’t seem to link to actual files.
I also looked here:
But they haven’t been updated for a number of years, and refer to DTS file types, while the new ‘-NG’ on 4.9 refers to DTB file types. Where do I find the new device trees?

After you burn the image using your PC

Look for a folder named Device Trees on the SD Card or USB you are using .

They’re all in there.

Don’t forget to rename the appropriate dtb to


1 Like

Excellent, thanks! It had been a long while since I needed a new device tree.


I am not sure if this is the right place for this discussion – so if there is a better location, eg on the forum(?), then let me know and I’ll post it there! Thanks

Okay, it upgraded successfully via the \upgrade folder.
I have a X96 2g, using the: gxl_p212_2g.dtb
This was working on the Amlogic 3.xx kernel, using an older version of CoreElec which probably hadn’t been upgraded in about a year, likely more. It runs off a microSD card

However, on the first reboot after the upgrade, I only get the x96 splash screen for a long while. I unplugged the device and pressed the hidden button with a toothpick and plugged power back in, but no variation.

Any suggestions? Do I need to burn the new image to the microSD card instead of doing an upgrade?

Yes, upgrade via \upgrade folder is only for same version. Since you want -ng version you have to make a fresh installation. You can use backup (from non -ng version) and restore to -ng version, at least this worked for me on my S905X box…

Hello, today I had try to update my 905X with the NG version but something goes wrong. Here below the screenshoot.

Create an empty .nocompat file in the .update folder.

1 Like

Nothing went wrong.
“Amlogic” and “Amlogic-ng” are based on different kernel versions, thus, it’s strongly recommended to do a clean install.
If you want to upgrade your existing installation, the instructions are right there on the screen.

1 Like

Well @TheCoolest @kostaman thank’s. I will try.

This afternoon I tried the nightly version on my 905x since the remote control doesn’t work anymore. Meanwhile, it is much slower than starting. Plus it often crashes. Best of all, no remote control works continuously. Sometimes it works and sometimes it doesn’t. Neither the original nor the smart one nor the keyboard. I don’t think it is an incompatible model problem. I repeat that until a few releases ago everything was fine. Now nothing goes. Nothing, not even the power on. Now I will have to reinstall the stable version from scratch and never again will I use the nigthly that was recommended to me.

When will possible to use new kernel on device with S912 such as device Mecool KIII Pro?

A post was merged into an existing topic: CoreELEC 19 Matrix Discussion (Kodi RC1)


First of all, thanks for all the effort and hard work that as gone in to this project. I am an happy core elec user for quite some time now!

I have a question, and i can’t seem te get te right answer on the forums of anywhere else on the net.
I have an eminent 7680 streamer, wich is build around an S905X soc. when following this thread I am not able to boot the 9.2.6 NG image. This thread seems to imply the S905X soc is comptable with the new kernel. After flashing the SD card and copying the right device tree it starts re-sizing the partitions, reboots and just shows the corelelec logo. After some time it reboots again.

Is there something different with this S905X soc?

If this is not the right place to ask these questions, please let me know.



@Hiu80 give the most recent nightly build found here a try.

Alright, will do. I will report back with the results.

Sadly, the same result. Re-sizes the partitions, reboots and only shows the coreelec logo. After some time the unit reboots. (bootloop)
I tried CoreELEC-Amlogic-ng.arm-9.2-nightly_20210305-Generic.img.

At the moment i am running 9.2.6 Stable ( Non NG ) wich works fine, but i like to upgrade to matrix. I understand this is possible with an S905X soc. Is this correct?

It is possible on most S905X devices. Unfortunately some of the S905X devices have a really old boot loader, that doesn’t work well with the the newer kernel.

I have added some work around for some of the more common problems caused by some of the old boot loaders found on some of these devices. However this doesn’t work for every device. Which generally means updating the firmware for the device, to get the newer boot loader to solve the problems.

If you are able to ssh into the device then we can get some logs to see what is happening. (Or better yet if you are able to make a uart connection to the device, though ssh should be good enough in this case)

journalctl -a |paste

The above will dump the logs to a pastebin site and give you a url that you can post here.

Note: there is a bit of a chicken and egg issue with ssh on CoreELEC. In that you normally need to access the gui to enable it. However it can also be enabled by editing the config.ini file and adding the following to the end of the file.


Alright, will give it a try later today! I doubt it is possible to set up an ssh connection to the device since it keeps rebooting, but maybe it will work between reboots. Just have to be fast.

Thanks for your answers and time, will let you know how it goes.

Tried multiple options to get some information from the device while booting, including setting up an SSH connecion. Also tried the debugging parameter in the config.ini. I can’t get any information out of it to where it goes wrong. I think i just stick with the 9.2.6 non NG release and maybe in the near future buy an Odroid N2+ wich has en newer and better soc.

If you have any more idea’s i’d like to hear and try them!


I have made an screenshot of the systeminfo when i am running the non NG build. Does this tell you a bit more on why i can’t load an NG build?