Coreelec does not boot in X96 mini


#1

I am running into a second problem.

I installed Coreelec successfully on a x96 mini 6 weeks ago. All is working fine.
I tried to duplicate the same things with a new x96 mini which I bought recently. Same model.
I downloded the recent image onto a USB stick, changed the and tried the toothpick method (like last time)

Now all what i get is this

What am I doing wrong? How can I fix this?
Thx for your help


#2

Does the installation on SD card/USB stick from first box work on this new box?
There are 2 versions of X96 mini boxes, with S905W and S905X processors…


#3

No, all gets me to this page…
I tried both the “new” and the “old” USB stick…
Will double check the processor, though


#4

It’s the Amlogic 905W processor


#5

IIRC that screen means the USB stick is not ‘seen’.

Will the new USB stick boot on the old device?


#6

What is the Android version on the box?
My X96mini_S905W box is on Android 7.1.2 and it’s rooted.
What about yours?


#7

No, it doesn’t. But I tried with two different USB sticks and a Micro SD card…


#8

That’s exactly my version


#9

And the “old” USB stick doesn’t work on it either. And on top of it I tried with two different x96 boxes which just arrived…