CoreElec freezes on welcome screen

Hi - i confess i’ve had this problem with LE, but when i asked for help on the LE forum none was forthcoming, so i thought i’d see if CoreELEC worked.

Unfortunately the problem manifests itself in exactly the same way with CE, but i’m happy to switch allegiance if anyone here can help :wink:

Everything seems to go well as far as the CE welcome screen but then nothing on the remote works and the only thing i can do is pull the power cable and reboot to android.

I’ve tried everything i can think of, including flashing the firmware but nothing seems to help. I’m getting pretty desperate and would be extremely grateful for a solution.

The box is a brand new magicsee Iron S905X (2gb/16gb) I’m using device tree gxl_p212_2g.dtb

Hi and welcome.
It’s possible that the remote your box came with doesn’t work with any of the built-in remote configuration files. In that case you’ll have to connect a USB keyboard and/or mouse to the box for the initial setup.
Make sure that you enable SSH, as you’ll need it to configure your remote.
Read this post fully, and you should be good to go pretty quickly.

1 Like

Hi - and thanks so much for this, it does look as if this could be the problem. However, i’m really not up to speed on this sort of stuff, particularly Android and i have some questions if you could explain a little further, please?

Of the two methods described the first has masses of information that i simply don’t understand. The second (amremote) looks by far the easier- is there any reason i cannot use this method?

Having said it looks simpler, i still have no idea what it means by "simply copy your remote.conf file to either the root folder of your SD card / USB flash drive or to /storage/.config/remote.conf ".

Where do i find my ‘remote.conf’ file? How do i copy it to my SD card? Do i have to use Android on the Magicsee or is there some way of using my PC? Easily?

When/how in the process do i use a usb mouse/keyboard and what is SSH?

Is there an idiots’ guide somewhere - i think the link you sent me is way out of my depth.

Hi there.

I’m afraid moving from Android and getting started on this stuff can seem very daunting. Either you need to do a bit of reading or you can simply get a decent cheap 2.4G remote which will work straight away without any hassles.

I use this one…

Just plug it in and go. About a tenner.

(Edit) - This also has 5 learning buttons so you can use it to switch your box on/off.

1 Like

It also happened to me with my remote IR but I was able to manage Kodi with the remote IR CEC remote of the TV.

Setting up a remote IR is very easy, it is only necessary to follow the guide How to configure IR remote control using the ‘meson-ir’ method.

1 Like

I really do appreciate the replies. I would love to set up my remote but i really don’t know where to start. I already have the link to the guide and it’s far too arcane for me.

Could i use the process described at the end of the video here to copy the remote.conf from the Magicsee ROM to the CoreELEC sd boot card? Or have i missed the point completely?

Perhaps there is a cheap box someone would recommend that would work? There’s an A95X F1 on ebay that has a pretty good spec for the price and i understand IR remote configurations are built into CE for A95X?

CoreELEC is Linux based, not Android.

Yes, you can follow that guide.

1 Like

Thanks - i realise CE is Linux - what did i say to make you think i didn’t know? I ask this simply because i really am struggling and it seems i may be in error over something without realising it.

I did install an app called terminus, which i think is a ssh client - which allows me to communicate with my PC (right?) but could not make head or tail of it.

Regarding the video it seems my box must be “rooted” for the method to work. Is there an easy method to do this that you would recommend?

SSH lets you connect TO your CoreELEC system, and allows you to execute commands on it from your PC.
You don’t have to install anything for it to work, you just need to enable it on the first setup screen you get when you start up a clean CE install.

You should extract the “remote.conf” file from your Android OS, burn CoreELEC to your SD card.
Place the remote.conf file on the root of the SD card (using your PC)
Then put it in the box and try to boot it again.

1 Like

I think you are confused with your Android on your box. You are mentioning “app” and “rooted”, which are relevant ONLY to Android. Forget ALL about it when you want to use CoreElec, which is a Linux version for Kodi working off an external SD card (or USB Stick), and has nothing to do with Android installed to internal memory on your box.

1 Like

You should plug a USB mouse or keyboard or both to your box before starting to install CoreElec. That way you can have complete control of Kodi during initial setup and later on if you choose…

1 Like

But i believe i have to “root” my android box to get access to and extract the “remote.conf” file before i can add it to my SD card? The video shows me how to do this using ESFile Explorer and superuserSU so i was wondering what the best method was to root the box.

Thanks for explaining about the mouse/keyboard, but i still need to sort my remote.

TheCoolest - thanks for the info, but you see the Catch-22: i can’t get past the welcome screen before i sort out the remote :frowning:

I believe that you can copy needed remote.conf in Android from once installed CoreElec, like you can copy Android dtb.img to CoreElec.
First install CE using USB mouse/keyboard, and then move on to solving remote problem :wink:

1 Like

Right OK! I’ve finally got past the welcome screen using a mouse, enabled SHH and set a password. But i still can’t see how to copy remote.conf in Android to the CE SD card. Do i root the box and then reflash the original firmware when i’ve done the deed? Or perhaps i should look at the meson-ir instructions again. (How do i “SHH into my device”?)

Well, i seem to have screwed the device. I managed to copy the remote.conf file on to the SD root folder using ES File Explorer and Superuser, but without ‘rooting’ the box. But the remote still didn’t work. Now the machine will boot off the SD card into CE but if i remove the SD and reboot it just gets as far as Magicsee and stalls. Can’t get to the Android home screen and I can’t get the burning tool to recognise it any more either.

If you can navigate ce with a usb kB, you are just about there.
You now need to read a previous post, about how to configure the remote.
Make a note of the IP address
You should be able to use windows explorer to copy correct files to the correct location.
I use coreftplite to do this.
I think you can forget about android for the time being.
I don’t have your device, search the forum to see if anyone else can tell you the correct device tree.

1 Like

Thanks but every sentence you have written throws up 2-3 things i don’t understand :frowning:

I have managed to reflash the box. I also managed in Android to copy remote.conf from the NAND to the root of the SD and also to /storage/.config/. But neither worked. This i assume is method 2 (amremote) of the previous post you referred me to?

Are you now saying i should try method 1 (meson -ir)? I would love to but i’m stuck on the first instruction because i don’t know what it means. How do i “ SHH into my device ”? If someone would just explain what this means i could maybe get started on this method.

I found my IP address but why do i need it? What are the “correct files”? None of the ‘remote files’ seems right for my device. But are you suggesting i try some of these using coreftplite to communicate between my PC and my device?

With regard to the device trees, I have used gxl_p212_2g.dtb which i assume is the correct one or i would not have got as far as the welcome screen, would I? Or are you suggesting that a wrong device tree could be the cause of the problem rather than the remote?

EDIT: I installed coreftplite on my windows laptop and i believe i have “SHH’d into my device” :slight_smile:
Could anyone possibly tell me how to stop Kodi and eventlircd using the commands given?

Hi again.

I’m not convinced that coreftplite is actualy for SSH. Looks like a file transfer program to me. To SSH into box, download and run Putty from here…

After running, type the IP address of your box into the “host name or ip address” box of Putty and click “open”. Click “Yes” to the security alert. Login as root, password is coreelec or whatever you set it to.

The commands to stop Kodi and eventlircd will now work.

1 Like

Hi Daaave - i am actually connected via coreftplite. What is really throwing me is where people say things like “type in the following command…” My question is: where? Where do i type in all these commands; which application on which device? I’m sure it’s a really stupid blindingly obvious question but i really have no idea! Will the answer be obvious if i install Putty?

Yes, very obvious. Install Putty to Windows laptop, run it, log in, type commands in the Putty window.

1 Like