CoreElec N2 Stopped Working - Cannot Boot

Error message upper left -
(3 hash tags) Starting debugging shell for boot step:
mount_flash… type exit to quit ###
*** Error mount _flash: Mount _command,
Could not mount UUID = 1509-2411***

Kodi/CoreElec/N2 system all working great until tried to control with Kore mobile app on LG K7 Android 5.1.1
Finally got Kore to install on phone after a doz tries, only to find it did nothing to control Kodi.
After that, when I tried to go back to my remote it would no longer work.
Changed batteries from other working device (troubleshooting step for remote), and remote still would not work.
Had to unplug N2 to shutdown, and after that would not reboot.
Unplugged Odroid wifi dongle, all external hds, hdmi cable - everything and waited a minute.
Tried again - nothing.
Pushed all cables into ports to make sure well connected and booted interface showed up without booting as if never shut down, but remote would still not work.
Used mouse to try to play music playlist, but Kodi now couldn’t find playlist as if it had been deleted.
Unplugged hd after which Kodi hung up - progress wheel in center of screen with no progress.
Unplugged N2 and rebooted.
This time I got true boot - Hard Kernal screen, then CoreElec screen, but then went blank instead of loading Kodi and error message appeared.
Unplugged N2 and tried to reboot several times to no avail, and no error message.
There is a steady (not blinking) red light on the N2, but Odroid wifi dongle no longer has flashing blue light.
Odroid WiFi Module 5A 802.11a/b/g/n/ac Dual Band

IR Remote

Sounds to me like a corrupted SD card. Try a fresh install.

It could be a corrupted, badly formatted or damaged SD Card.

If you are using MS Windows, you can try by cleaning the SD Card following the instructions from this link.

Be careful choosing the correct drive when doing so. Cleaning a drive will erase everything, including partitions.

Once the card is cleaned, try a fresh install, without using a remote configuration file and see if the system boots entirely.

By SD card do you mean the tiny card that’s like a SIMM card on a cell phone?
Is fresh install the only fix?
Instructions here say only 1 of the 9 methods may work.

Which one works?
I’m O.D.ed on tech trial and error.
Is this corruption of SD card a common occurance?
Did the Kore app cause corruption?
If not what did?
I want something stable, not another marginally functional piece of tech I have to continually babysit.

On the N2 you just burn the Odroid_N2 image to the card according to the instructions, and then plug it back into the device. You don’t have to mess with dtb files or press any buttons.

I don’t remember when the last time I had an install go corrupt, but it can happen.
It could happen just because something in the card caused it, maybe there was a power outage or the N2 was restarted without proper shutdown. Maybe it was something you or an application you installed did.

For the most part CE is stable, and as long as the sd card is good, you should be ok with it long term.

How do I clean SD card using Mac 10.13 (High Sierra)?

Everything was working fine until I tried accessing Kodi with Kore app.
Kore loaded movies, but I couldn’t get it to play anything or do anything else.

Did Kore corrupt the SD card?

I don’t think so, could be just a coincidence.
I never used Kore, but I use Yatse almost on a daily basis with multiple devices, and never had a problem with it.

So where do I get the Odroid_N2 image?
And how do I burn it to the SD card?
Does the Odroid_N2 image include everything - CoreElec os and Kodi browser app?
I’m on Mac 10.13 (High Sierra) and have a USB SD card reader with micro SD slot.
Can I load card on my Mac with micro SD card reader and install that way?
I didn’t install any apps on N2 that triggered issue, I just tried to control Kodi with Kore mobile app from my Android phone.
No power outage, but I did have to disconnect power supply to shut down bc Kodi was frozen and remote wouldn’t work.
But CoreElec Kodi was already corrupted at that point - remote wouldn’t work at all, and playlist wouldn’t play anymore.
Seems to me like Kore wireless connection to Kodi is the culprit, if that’s possible.

Everything is in the guide linked above.

What link above? I only see the forum link that I posted and I don’t understand it. Only 1 out of 9 methods might work?

Is this the method you mean?

  1. Download the latest .tar file from here .
  2. Copy the .tar file to the /storage/.update folder on your device.
  3. Reboot to start the update process.

No, I mean the New Installation part, steps 1 - 3. (step 4 is not applicable to N2)

OK, downloaded only N2 file on page - [CoreELEC-Amlogic-ng.arm-9.2.2-Odroid_N2.img.gz]
But I’ve never used Rufus.
Can I use Rufus on Mac?

I’m not sure. I never used a Mac. You’ll need to search for a tool to burn ISOs/image files to a SD card for Mac.

No, rufus is windows only
You can use etcher ->

Thanks. Just found Etcher at OSX Daily -

Before reinstalling, are there settings files I can copy from existing install in order to save my Kodi setup?
After reinstalling and setting up Kodi again, is there any way to make a backup to make reinstalling easier in the event I have to reflash SD card in future?

Before flashing SD card, can I connect N2 to Mac with ethernet and copy Kodi setting files that I can then copy back later to salvage my existing setup?
Which files should I copy?
Or do I have to post that question at Kodi forum?

You can’t really do that if you can’t boot up the N2.
I’m not sure whether OSX can see the secondary partition on the SD card or not. I know Windows can’t, but Linux can. In such case you can, technically, do a manual backup, but it’s not “novice friendly”. There are threads on the forum that deal with performing manual backups. Try to search the forum if it’s important to you.

Without the SD card there is no operating system to copy out of, so no you cannot copy your settings out of the N2 since they live on the corrupted SD card.
You can attempt to recover them from the SD card if you can get the mac to mount it first.