CoreELEC not booting - Nexbox A95X


Device : Nexbox A95X ( S905X , 32GB Rom , 2GB Ram)

i tried to boot latest CoreELEC from SD and it stuck at Nexbox boot logo , after that i taken out the SD card
ti check the device tree i found all devices trees inside then i removed all and left “gxl_p212_2g.dtb” which the same file name that used to work fine for me in LibreELEC.
again tried and same result stuck at boot logo.

i tried again the tooth picker method didn’t boot , re-flash the SD card , an repeated every thing same result.
but back the old SD with LibreELEC it boots fine .

any hint for something i miss in the process.


Look at the detail process how to install, mainly the section below, [How to install CoreELEC]

From the Device Trees Folder, now present on the SD/USB, copy the correct xxxxx.dtb image file to root folder of SD / USB and rename it to dtb.img

Correct file dtb files vs. your box are defined in [❓ Which DTB do I use?]

thanks , i will try that today knight

this was the missing part once i selected the correct dtb file for my device gxl_p212_2g.dtb and copied it to the root folder and renamed it dtb.img , it boots like magic now

#pebkac strikes again

@anon88919003 we all make mistakes

Yet another case solved :v: