Coreelec on MyGica ATV 495X-B (Amlogic S905X-B)

Hi all,

I try to boot Coreelec from SD/USB (or Libreelec - i am indifferent) in a MyGica ATV 495X (Amlogic based S905X-B) without success.

I have raised the issue too in libreelec forum, but no one has responded …

At least, since then I have gained root priviledges in the TV box (probably in Android OS itself (?)) by applying a patch from MyGica. Also, I have opened the box to explore where I could potentially solder a button in order to try the “toothpick” method too. The box does not have a reset button, hence I have tried all other methods which land me in the Android recovery prompt.

I have tried EVERYTHING and have followed the instructions here and in LE forum word-by-word.

Is it just a support/compatibility issue or am I missing something?

I trust Coreelec community is closer to Amlogic TV Box owners to help.


Your Quote from LE “Where I end up, is the Android recovery utility, asking me if I want to reboot, update from EXT, etc…
I understand that the Android recovery utility comes after the bootloader, hence my USB/SD card is not able to “cheat” the bootloader and kick in LibreElec.”
Firstly burn CoreELEC onto SD Card and use correct Device tree for your box specs. Rename dtb.img. Now make a fake Zip file. Just zip up a text file. Copy that to a USB stick. Insert the USB stick and the SD Card with CoreELEC.
Now do exactly what you’ve done before and point to the External USB stick and Choose the fake ZIP file. Click on it and your box MIGHT reboot and Boot into CoreELEC on the SD Card.

Thanks Kostaman.
Unfortunately, this did not work either. The “upgrade” app in the Android OS does not see my zip file in the USB drive to select for update.
However I tried all other possible methods (“update reboot” command via terminal, holding power key and inserting power cable) with the USB (holding the dummy zip file) pluged in and with Coreelec on the SD card.
I also tried 5 different device trees as well as both USB ports.
Fyi, the image below shows where i end up…
If you have any other idea or guidance, it would be much appreciated.

Maybe , Just Maybe ??
Name the zip .


Renaming the zip to did not resolve the issue. I tried again all different combinations using different device trees.

However, I got Coreelec finally working by the following inspiration!!:

I made a copy and renamed “aml_autoscript” to “factory_update_param.ubt”. In a way this fooled Android firmware as if I prompted a legitimate firmware update…, however in effect it was executing the commands to load up Coreelec. After that, it booted to Coreelec and anytime after powering up or restarting the TV box.

Now, I need to read about how I can get the IR remote working.

Would you recommend installing Coreelec to internal memory or there is not any real benefit of doing so?

At the moment, I am using a 2GB SD card; would this be enough for Coreelec or is it defo too small in the long term for an average Coreelec user?


You should get yourself a decent SD Card with fast read write speeds. I’m guessing that 2gb SD Card is not. Samsung Evo Plus 32gb is my preferred sd card.

@ Poida : Well-noted. I am leaving then Coreelec installed on the SD card as is.

@ Kostaman: Considering the low cost of SD cards nowadays, I purchased a 32GB Kingston Canvas Go micro SD card (90MB/sec Read & 45MB/sec Write) for £8 …

I figured out the issue with IR remote too. The guide in the forum was really accurate.


Hi - how did you do that i.e. the process that made renaming the aml_autoscript to factory_update_param.ubt work? I am doing as below:

  1. Burned the Coreleelc 9.0.1 download on to a USB using Rufus
  2. Copied the relevant dtb file from the device tree folder and pasted in the USB root and then renamed it to dtb.img
  3. Made a copy of the aml_autoscript to factory_update …
  4. Inserted the USB into the device and powered it on with the reset button pressed
  5. I release the reset button when the device logo appears on the screen

But that’s where I am stuck. It does not move past this screen. I have tried different device tree dtbs. It seems my device is locked somehow and does not want to boot into Coreelec software. Could you please share some thoughts on how to possibly fix it? Thank you!

Please use a current stable release.
9.0.1 was released decades ago and may contain some serious bugs.
Since today we are at 9.2.4.

Thank you for responding to my post. Your comments have helped me in that I managed to revive an older Tanix TX3 Mini box with the latest 9.2.4 CE image. I tried several previous versions of CE on the same TX3 Mini box without luck. It’s running now via USB and the performance is not too bad. Ideally I would like to install to the internal memory and I tried, “installtointernal” command via SSH but it didn’t work saying something like the file system is not recogonised or found etc. Could you or someone here please share some hack that I can try to overcome this issue?

My original issue is still there i.e. I am unable to install CE on to my X96 Mini box. I have tried all sorts of different CE / LE versions with a number of different dtb files but it just won’t boot. I have been reading a few posts on different forums and it seems either my box is fake with some chipset / hardware configuration that is not supported by any of the dtbs or it’s dual boot locked - not sure what that means and how to unlock it.

installtointernal is not officially supported.
Newer devices can use ceemmc, which is actively developed and supported.
Unfortunately it isn’t working on your device.

CE on X96 Mini is being used by some users here and should work flawless.
Please try it with gxl_p281_1g.dtb or gxl_p281_2g.dtb (depending on the RAM being used in your device).
Also take a look at the following thread:

I’ve been trying both and more but it does not want to boot. I have a similar X96 mini that I bought a while ago and that works flawlessly. This particular box is either locked by the vendor somehow, has a different hardware than it’s showing, or something else. The Android boots up fine and works as per normal. Some posts suggest that maybe it’s a Rockchip box - but not sure how to confirm that and then find the suitable dtb for it.

I’ve also tried to update the firmware to see if the new firmware unlocks it somehow but cannot even update the firmware. Getting the attached screenshot messages.

According to your second screenshot, it is indeed an Amlogic device (p281), so the dtb suggested before should be the right one. Which CE image did you download?

You said, that you also tried to install LE on this box.
Afaik the LE installation automatically modifies the bootloader during the first boot, so the device is unable to boot CE afterwards until you recovered it with a stock Android image from the box vendor.
Please take a look here:

I downloaded the latest CE version i.e. 9.2.4. I tried LE but that didn’t boot either so I don’t believe the original bootloader has been modified. I have tried to install the stock Android image but as per the screenshots shared, it’s giving errors saying the signature cannot be verified etc.

Use Amlogic Burning Tool

I did not use the USB Burning tool and instead used the Burn Card Maker. It did allow me to flash the firmware but I still cannot boot the CE using gxl_281_1g or gxl_281_2g dtb files. It just does not want to boot. It looks like it’s coming down to using the correct dtb file. I’ll try a few more to see any of them work.

It is the right dtb for sure.
But you didn‘t answer which image you used and only mentioned the version. It‘s important to use the non-ng version.

Sorry I did not think that way. I used the CoreELEC-Amlogic.arm-9.2.4-Generic.img.gz.