Coreelec on Tanix TX3 S905X3

Hello again.I’m going to install coreelec on a friend’s Tanix TX3.Which image to choose?Stable or latest nightly?

Does anyone know which file to download on Tanix TX3 S905x3?

You need the ng version

1 Like

Cause 2 reasons.One is that many months have passed since then (finally I didn’t buy the box yet) i gonna install CE on a friend’s tanix.So many things may have changed.And other is i see something about vfd files,that i am not familiar,cause on my Vorke Z6 process was more easy.

批注 2020-07-04 145037
I want to use my remote to power on my box,who can tell me the code of remotewakeup?

Edit: Thanks for moving the post due to my weak milkdrinker searchfoo…

Great, seems that I can assume one can install to mmc and all hardware work (?) = this will be a great for experiments.

Anyone got experience with the Tanix TX3? (thinking of buying it)
Information seem a bit more scares then usual, might not be a good sign.

Not the mini, nor the max, or the pro apparently for that matter; just the plain average lukewarm Tanix TX3.
I for one, would welcome a hexadecimal naming system…

A little late, sorry.
You need to temporary remove any remote.conf from .config or touch a new file /storage/.config/remote.force_meson_ir and reboot. Then the ir-keytable -u is working as it uses meson-ir, not meson-remote.

Anyone managed to install CE to emmc?
It’s not supported so:

    TX3:~ # ceemmc

    Starting CoreELEC eMMC installation tool...

    System is not supported: sm1_s905x3_4g!

Oh nevermind stoopid me, I ran:

TX3:~ # ceemmc -x
Seems to work as described on the tin.

Does ethernet work?
Can’t seem to get mine going.

ethtool tells me a tall tale about me being lazy and not plugging in the cable. Which is obviously a lie. Things can be borked though…

Use sm1_s905x3_4g_1gbit for 1GBit, or sm1_s905x3_4g 100MBit.
There are different hardware configurations out there all called TX3.

Boot Android and you will see what type of connection LAN should be.

1 Like

Hm, alright. It said on the tin that it was a 100mbit, and that’s just about enough for me. However, you are right. It’s a 1000mbit.

Thanks for the 900mbit’s!

Hello, can someone tell me whether this 4GB version has 100 or 1000Mbps? The product description of the dealer says only 100Mbps

Ask the dealer or seller.
This forum is not for seller’s verification of what they sell.

Best recommendation ever :rofl: :rofl: :rofl:.
I thought in such a forum you can get some advice. The China dealer definitely does not always write down the correct specifications. The dealer will only confirm what is written in the description, I can read that myself. Or do you think the dealer will ask the manufacturer to give me a highly qualified answer?
Here some write from 1000mbps on this model. Hence the question. Well, got really smarter now.

Maybe go to Tanix manufacturer’s website and see if such a box is manufactured by them.

You are asking for specifications advice on a Tanix branded box which does not exist on their official website.

Maybe ask the seller if it is a fake clone using the Tanix brand ?

Tanix sell a Tanix TX5 Plus with non variable specifications.
Users on this forum have reported this box as working with no reports of mixed specifications.

Dual WiFi – Gbit LAN

I just got my TX3, fired it up into the installed Android, set it up and checked that it is indeed a S905X3 with 4GB of DRAM and a 100Mbps Ethernet port (as shown by my Ethernet switch). I also install a Start_CoreELEC app that I found somewhere on this site. I install the aforementioned CoreELEC daily on a USB stick, copy sm1_s905x3_4g.dtb to the root folder and rename it dtb.img, pop it into a USB port on the TX3 and invoke the app to reboot, the plan being to copy remote.conf and vfd.conf to a SMB mount.

The activity light on the USB stick blinks but nothing on the display. I pull the power plug and the USB stick out and repower the box. Interestingly, it appears to boot at least to the extent that the VFD eventually shows the correct time but nothing on the display.

What can I try next?


If you are saying that Android now only shows black screen when you pull out the CE USB
then i can tell you i had this happen to me on a TX3 Mini S905w 2gb/16gb.

Mine was running CE via SD Card and it happened to Android only.
CE was still booting via SD Card.

I reflashed Android Rom .

I haven’t been able to find an OEM ROM yet but will keep looking


Have a look here

I tried that in lieu of an OEM firmware but it did not work. All is not lost since CE still boots from a USB stick