Disable update notification on 9.0.3

I have an s905x box running 9.0.3, i set the update to manual, disabled notification but after reboot it still pops up. I prefer to stay at 9.0.3.

Unfortunately you will have to deal with the OS Update Notification until you update to current 9.2.0
Same as the members who use Nightlies and decide to stop on a particular Image.

Yes, I noticed update notifications being forced on stable builds too.
Out of interest: how does the reasoning followed for nightlies apply here ?

9.0.3 is no longer the current stable build when 9.2.0 is released.

Your system settings to disable add-ons notifications does not disable
CoreELEC OS notifications for OS updates.
It’s been discussed in nightlies and nightly builds are where issues are resolved through testing before a stable release is pushed.

1 Like

This is not correct.

Updates are not forced on stable builds.

Your receiving the notification as there is a new build available, it’s your prerogative as to whether you choose to update or not but there is no reason that you shouldn’t.

Allright, Ive got notification. But why Ive got the same notification, after I close it? I already know, that new version is available.

Isnt there option to show/not show notification within CE Setting plugin: “Show Update Notifications”? I dont get, why is this option suddenly broken since last few days…

I’m not happy to see the update notification during watching a movie.
It should be pop-up when I’m in the GUI not when I’m watching something.

This is probably a bug as you should not be seeing any notification I believe when playing a movie, I will have to look into it.

Thank you!

Find bug within this commit which breaks Show Update Notifications option in Menu.

I think this
if self.oe.BUILD == 'official':

should be
if self.oe.BUILD == 'official' and self.struct['update']['settings']['UpdateNotify']['value'] == '1':

Is it need to create PR for this? As you will already review that addon…

No I don’t think this is correct because the idea of that commit is that a notification is sent and if the user clicks no then that is the end of the update procedure/notification.

The problem is that the notification is reoccurring even if the user clicks no after a set amount of time and that is what needs fixing, I will look into it tonight.

I did not say updates were forced.

I see… But then

msgctxt "#32365"
msgid "Show Update Notifications"
msgstr ""

in strings.po should be changed to something like

msgctxt "#32365"
msgid "[non-official versions] Show Update Notifications"
msgstr ""

propably with decription line “you cant disable notifications in stable versions, this setting is only for community/nightly builds” or something like that…? Because it makes confusion about settings functionality…

I would prefer first fix though :slight_smile:

1 Like

Yes, correct.
Thanks for looking into it, although not really a severe issue imo :wink:

Thanks for looking into this, since 9.0.3 is not nightly it should have the option to disable update notifications.

I’m sorry, but because of the Bluetooth & CEC problems (even on my N2) with 9.2.0, I don’t consider it stable.
So I would like to disable those notifications too.

If your having issues then report them in the correct subcategory otherwise they will never be solved.

Bluetooth and CEC is unchanged vs previous release, I think your blaming the wrong thing here.

1 Like

I don’t want to “blame” anybody and please don’t take it personally. I respect and appreciate all the work the CE team is putting into this, for free!
Nevertheless, there are / where definitely Bluetooth problems introduced in CE 9.2.0:



Same for CEC, but that can be a personal issue. But even for this, I can clearly see a difference in behaviour between CE 9.0.3 and CE 9.2.0 on the same hardware setup.

The CoreELEC team will never blame you for reporting a problem.
However DO THE RIGHT THING open the topic with as much information as possible logs, among other important information.
Sure the whole team will try to help!
I don’t understand why people are afraid to say what’s up with their boxes.
Trying to reset the box might help.

BT issue was already solved for K3 Pro in nightly, fix will also be in the next stable.

1 Like