Do amlogic-ng builds work well on GXL(S905X/S905D/S905W) devices?

Ah, okay. Thank you.

Ok. Here’s an update to my problem:

It seems to be related to the audio channels. 2.0 works fine, 4.0 seems to work, but all the other options either have no sound, or cause the stuttering and crash. I was using the 5.0 setting before.

Select HDMI Multi-Channel audio device and set channels to 7.1 - That is useful for non-passthrough.
And obviously, enable the Passthrough toggle at the bottom of the audio menu (make sure you’re in Expert mode first)

Thanks for the suggestion, but I’ve tried both of those things including most other combinations in the audio settings!

The number of channels you set in Kodi doesn’t affect passthrough in any way.

I normally use passthrough because my amplifier is capable of decoding most formats.

Remember, not every video is affected with the glitch on my setup, some play fine whatever audio channels are used.

It seems to be an issue with certain encodes. In the image below, the three files on the left I have issues with when audio channels are set to anything other than 2.0, those on the right work fine whatever number of channels are selected.

The only pattern I can see is that multichannel AAC is causing the problem. What other files should I test to narrow it down?

Yes, you can’t passthrough AAC. That will play in LPCM mode.
You need to select the Multichannel HDMI audio device and set channels to 7.1 to have a chance of it working.

Yep, tried that, doesn’t work.

Audio output device ALSA: AML-MESONAUDIO, HDMI
Number of channels 7.1

Things were fine in the previous kernel.

That’s not the correct audio device.
You are not even using Amlogic-ng build…

I put on 20.0 today to see if that solved the problem, it hasn’t.

Now select the Multichannel HDMI device and set channels to 7.1

Still the same problem, but I haven’t changed anything since you suggested that before

Does the MESONAUDIO audio device mean that I’m not on the 4.9 kernel? Is that why you thought I was not on ng?

I’m installed to internel, but the Android 7.1 version I flashed (HQYG-TX7-nikodi-20180104) still has the 3.14 kernel. Does a dual boot install to internal use any resources from the Android partition that might cause a conflict?

Sorry, MESONAUDIO exists on GXL devices, and AUGEAUDIO is on newer chips.
I think that you probably don’t even have the Multichannel HDMI option, as it’s only available on newer devices.
That said, I’m not sure whether there’s a solution for this issue for GXL.

You may want to try enable passthrough and AC3 transcoding, set channel count to 2.0 and you will have a new setting in the passthrough options. Maybe that will provide an acceptable workaround.

Thank you, glad we seem to have got to the bottom of it.

I just have four audio output device options:

ALSA: Default (AML-MESONAUDIO, Analog), PCM
ALSA: AML-MESONAUDIO, PCM
ALSA: AML-MESONAUDIO, HDMI
PULSE: Default, Bluetooth Audio (PULSEAUDIO)

I’ll try your suggestion, but maybe just leaving the output at 2.0 and using my receiver’s Dolby Prologic II capabilities might be simplest.

Yes, but then you downmix the audio to 2 channels, and then upmix them back.
With AC3 transcoding, the system will transcode AAC to AC3 and it should, at least in theory, only have 1 stage of processing.

Not too taxing on the S905X CPU?

Should be able to handle it ok.

Interestingly it stops the stutter and freezing of the video, but there’s still no sound, so I’ll stick to PLII or maybe even go back to non-ng. Thanks for your time anyway.

Try build 19.1.0

It’s highly recommended to upgrade to at least minimum CoreELEC 19 Matrix as EOL for 9.2 was announced!

About | FAQ | Terms of Service | Privacy Policy | Legal Notice