Do amlogic-ng builds work well on GXL(S905X/S905D/S905W) devices?

Mecool KM8 (s905x) video freezes after a few seconds, I think there is some problem with the audio drivers. When audio passthrough is enabled it works normally. I tried all the output options of PCM, analog, HDMI and it’s the same. The settings are identical to 9.2.6. Any idea what it might be

Same here, did you happen to have found a fix or workaround? mp4 doesn’t play (don’t have much of that anyway) but AAC is a bigger issue for me. Wish I had waited before upgrading, I can already hear my wife saying “I told you so: if it works …”.

I think I found a solution. After I changed the number of audio channels to 2 audio output on the hdmi now works. For some reason on the 3.14 kernel multiple channels worked without problems

1 Like

Today i tested and succesfully install Amlogic-NG built on GXL_p212_2G dtb file
CoreELEC-Amlogic-ng.arm-9.2.7-Generic.img

Device was old X96 2GB 16G S905X wechip brand.
booting CE-NG from SD card without any problem but can not possible install to internal by ceemmc tool.
ssh comm and show

Install in single boot mode not possible!
No DT partition was found

I thing problem was about kernel? 4.19 or version android.
generic android in tvbox was about android 6 version (marshmallow or lolipop) cant remeber
a try update to android version 7 and more.

i search solution by [honolulu1] user
so i search and download image [ROM] ATVXperience on Mini M8S II (p212 board, S905X)
(atvXperience_v4_S905X_RT_BCM.7z)

flash this rom into box - i made i little hack by short pins to NAND to easy connect Amlogic USB burning tool. see photo


(i tried many others images and mostly work as android tvbox but atvXperience_v4_S905X
is able boot from sdcard easyway and work ceemmc tool from NG built)

android boot up and work over wifi
so i reboot CE-ng from SD card wihout problem
repeat operation over CEEMMC -X tool and install coreelec into internal flash.–worked for me
and finaly i install BL301 Wake-Up feature [inject_bl301]… not tested but its show in menu.

EDIT: one of two usb port does not work… working usb port tested with USB flash, keyboard, wifi_dongle
i ussualy use only ir remote and ir arduino_micro as IR keyboard or only keyboard KP.

EDIT2 thx to Frakkin64 post
Copy this script to: /storage/.config/autostart.sh (Or add the contents if you already have a autostart.sh) autostart.sh (123 Bytes) This script will set the USB controller type to “3”. (0:normal, 1:host, 2:device, 3:otg) After implement the script two reboots are needed to become active at all. If CE get updated a additional reboot after the update is needed.
USB is back :slight_smile:

3 Likes

Any issues with the USB ports? Some S905X boxes have issues with one or both usb ports in Matrix, best case they can have power if not unusable for RF keyboards or usb to ethernet adapters.

This solved it for me on an S905D, one port is configured for host mode and you have to switch it to OTG.

May work on your device as well.

1 Like

Ok, if a moderator can pin this box Bqeel M9C Max [S905X/2G/16G] as working box with -ng builds (workaround with an script for enabling both usb ports in autostart.sh after an bootloader upgrade) maybe someone who also has it could be brave and try Matrix. Was my daily driver with Matrix installed on internal memory until my brand new Odroid C4 arrived and I had to retired it.

Hi, I’ve a problem with the Mecool K1 Pro. The box working fine with the CoreELEC 19.1-Matrix_rc2 image, but I can’t activate the original remote.
“echo “meson-ir * mecool” > /storage/.config/rc_maps.cfg” doesn’t work. What can I do?

Search forum!
On Matrix it’s now ending .toml!

The system looks for a file named “mecool” in /storage/.config/rc_keymaps/ that stores the key maps.
I used the one from CE 9.2.6

Hi all, I’m happy to report successful installs of CoreELEC 19.1-Matrix_rc2 over legacy CoreELEC 9.2.7 on my two S905X boxes with 1/8 GB, an X96 and a Trongle X4. I first flashed Aidan’s Android TV rom v7.5 to upgrade the bootloaders.

They’re running great, noticeably smoother than before. The USB ports work fine on both.

Thank you for your work guys, it is very much appreciated.

I’m having problems with some HEVC encodes.

The symptoms are always the same: no sound, then stuttering of the video, then freezing of the video - all happens after only a few seconds from the start.

The bug is present in 9.27 and the 19.x builds.

Log here: http://ix.io/3sH8

A sample would go a long way

Apologies.

Here are three short samples that trigger the bug zipped together

https://mega.nz/file/QckxjIRC#m1-zolwwS6DbeaAgeXtB6tgewOougWv6RdGy6oMA1CM

Hmm…, all 3 samples play on my Mecool KM8-S905X (CE ng.9.2.7_Linux v.4.9.113) flawlessly without any problems…

Thanks for testing them. Good to know that it seems solvable. I wonder what the difference is for me?

I’m using a Bqeel 2GB M9C MAX upgraded with Aidan’s ROM [S905X] [v7.5] (UNIVERSAL)

What ROM did you use to install the later Android version?

My KM8 runs on original Rom the box came with; it’s Android 7.1 version and I never upgraded it to newer versions because they had all locked Bootloader.

Ah, okay. Thank you.

Ok. Here’s an update to my problem:

It seems to be related to the audio channels. 2.0 works fine, 4.0 seems to work, but all the other options either have no sound, or cause the stuttering and crash. I was using the 5.0 setting before.

Select HDMI Multi-Channel audio device and set channels to 7.1 - That is useful for non-passthrough.
And obviously, enable the Passthrough toggle at the bottom of the audio menu (make sure you’re in Expert mode first)

About | FAQ | Terms of Service | Privacy Policy | Legal Notice