Do amlogic-ng builds work well on GXL(S905X/S905D/S905W) devices?

Once again recorded microsd night version of ng, does not load beyond the splash screen, x96 s905x 1Gb - gxl_p 212_1g. dtb.

One more question: I’m currently running libreelec from an usb stick. If I try this version (on a different usb stick), can I go back to the old one? (I’m asking because of the different aml_autoscript).

Yes you can, just use the toothpick method to get the usb with LE back booting.

1 Like

Ok, today I finally tried the ng version. What I did

  1. Cloned the usb stick with the working libreelec (9.0.something, the last one supporting the mecool k1 pro).
  2. Booted it to confirm the clone worked and upgraded to coreelec (“normal” version) by putting the tar file in the .upgrade folder and then changing the label of the boot partition (from LIBREELEC to COREELEC).
  3. Upgraded the plugins and installed the missing one (oscam) taking it from libreelec (I need it to read a legit card with an usb reader, AFAIK tvheadend doesn’t do it by itself). I also found that coreelec uninstalled webgrab+ (why, oh, why?) but I least I could install it again from the thoradia repo.
  4. Used it for a couple of days then upgraded to the ng version with the tar file and the .nocompat flag. It rebooted fine, no toothpick needed :sweat_smile:
  5. The dvb wasn’t working, I had to select the media_build drivers and then it worked.

@olivluca glad that worked for you. The CoreELEC NG build should be the best currently available build for the mecool k1 pro.

I confirm X96 MAX PLUS (X905X3-4+64-1000 LAN) works fine with CE ver. 9.2.3 and up (before that BT was broken).
Most config can use the ones from X96 air (especially VFD and ir remote)
Working: AC5G WIFI/1000M LAN/BT/USB3/USB2/VFD/IR remote/4K HDR S/PDIF
Even install to emmc script works like charm :wink:

how could you select the drivers media_build?

x96 Xgody glx_s905x_2gb originally android box changed to corelec loads runs but occiasionally crashes. Wont speed search and locks up, then reboots. Reverted back to the nightly 9.2 builds which are working amazingly good.

With the “coreelec module drivers” plug-in then “Dvb drivers from the latest kernel”

I haven’t tested extensively, so test on your own, but so far
coreelec-ng seems to work on

Beelink MXIII-II,

provided a newer firmware from a different manufacturer is flashed. The latest is and probably the last firmware for this deice is "113MO ", but because of some old bootloader ,ng builds cannot be installed in internal memory. Installing a firmware that was for android 7 fixes this.
I have followed instructions from this post,
flashed the suggested firmware and it seems to work, (wifi and bluetooth as well).

If anyone wants me to try any specific functionof this box, pls ask. I don’t have an ir remote.

1 Like

Mecool KM8 (s905x) video freezes after a few seconds, I think there is some problem with the audio drivers. When audio passthrough is enabled it works normally. I tried all the output options of PCM, analog, HDMI and it’s the same. The settings are identical to 9.2.6. Any idea what it might be

Same here, did you happen to have found a fix or workaround? mp4 doesn’t play (don’t have much of that anyway) but AAC is a bigger issue for me. Wish I had waited before upgrading, I can already hear my wife saying “I told you so: if it works …”.

I think I found a solution. After I changed the number of audio channels to 2 audio output on the hdmi now works. For some reason on the 3.14 kernel multiple channels worked without problems

1 Like

Today i tested and succesfully install Amlogic-NG built on GXL_p212_2G dtb file

Device was old X96 2GB 16G S905X wechip brand.
booting CE-NG from SD card without any problem but can not possible install to internal by ceemmc tool.
ssh comm and show

Install in single boot mode not possible!
No DT partition was found

I thing problem was about kernel? 4.19 or version android.
generic android in tvbox was about android 6 version (marshmallow or lolipop) cant remeber
a try update to android version 7 and more.

i search solution by [honolulu1] user
so i search and download image [ROM] ATVXperience on Mini M8S II (p212 board, S905X)

flash this rom into box - i made i little hack by short pins to NAND to easy connect Amlogic USB burning tool. see photo

(i tried many others images and mostly work as android tvbox but atvXperience_v4_S905X
is able boot from sdcard easyway and work ceemmc tool from NG built)

android boot up and work over wifi
so i reboot CE-ng from SD card wihout problem
repeat operation over CEEMMC -X tool and install coreelec into internal flash.–worked for me
and finaly i install BL301 Wake-Up feature [inject_bl301]… not tested but its show in menu.

EDIT: one of two usb port does not work… working usb port tested with USB flash, keyboard, wifi_dongle
i ussualy use only ir remote and ir arduino_micro as IR keyboard or only keyboard KP.

EDIT2 thx to Frakkin64 post
Copy this script to: /storage/.config/ (Or add the contents if you already have a (123 Bytes) This script will set the USB controller type to “3”. (0:normal, 1:host, 2:device, 3:otg) After implement the script two reboots are needed to become active at all. If CE get updated a additional reboot after the update is needed.
USB is back :slight_smile:


Any issues with the USB ports? Some S905X boxes have issues with one or both usb ports in Matrix, best case they can have power if not unusable for RF keyboards or usb to ethernet adapters.

This solved it for me on an S905D, one port is configured for host mode and you have to switch it to OTG.

May work on your device as well.

1 Like

Ok, if a moderator can pin this box Bqeel M9C Max [S905X/2G/16G] as working box with -ng builds (workaround with an script for enabling both usb ports in after an bootloader upgrade) maybe someone who also has it could be brave and try Matrix. Was my daily driver with Matrix installed on internal memory until my brand new Odroid C4 arrived and I had to retired it.

Hi, I’ve a problem with the Mecool K1 Pro. The box working fine with the CoreELEC 19.1-Matrix_rc2 image, but I can’t activate the original remote.
“echo “meson-ir * mecool” > /storage/.config/rc_maps.cfg” doesn’t work. What can I do?

Search forum!
On Matrix it’s now ending .toml!

The system looks for a file named “mecool” in /storage/.config/rc_keymaps/ that stores the key maps.
I used the one from CE 9.2.6