Do CoreElec includes driver for Realtek RTL8156 2.5Gbps NIC?

I’ve just purchased an A95x max box. While awaiting for the delivery, I’m wondering if I can use my USB RTL8156 2.5Gbps NIC on it. I purchased the set top box primarily for TV recording. I’ve got a few USB TV sticks that is known working on it. I’m going to record TV shows into an internal SSD and I want the .ts files to be transferred to my PC fast. It would take much less time if the box is 2.5Gbps enabled.

No, but here’s a test build for you to try when you get your box.

A new RTL8152 driver was added tonight, it should also handle RTL8156 NICs.
Try the newest nightly build when you get your box.

Thanks, I’ll try and report once I receive the box.

The driver seems to be only paritally working.
I tried CoreELEC-Amlogic-ng.arm-9.2-nightly_20200619-Generic.img.gz on A95x max box v81
if I use g12a_s905x2_4g_1gbit.dtb device tree, no onboard NIC is detected
if I use g12a_s905x2_4g.dtb device tree, onboard NIC is detected but cannot get IP address by DHCP (I’m going to try manual connection later)
if I insert a USB RTL8156 NIC, it can be detected, can get IP by DHCP, can download add-ons from repository, but TVheadend server do not respond to connection request
(the IP address of USB RTL8156 NIC is 192.168.1.48, if I connect to http://192.168.1.48:9981 there is no respond)
I can now only connect via wifi (IP address of wlan0 is 192.168.1.49, I can connect to TVheadend by connecting to http://192.168.1.49:9981)
I’m planning to take a look at the log file a week later when I have time

Not sure about the internal nic. But you can disable it for testing purposes.
Also try checking performance with iperf.

I contacted support team of my USB TV-stick
because the driver for S905 has TVheadend integrated
and they config the TVheadend to shutdown automatically if the TV-stick is not found
they said there is compatibility issue between current driver and my TV box
that’s why TVheadend shutdown automatically and I won’t be able to connect to it
They will try to fix this problem in future drivers

I tried to install TVheadend from repository instead of using the one integrated in the TV stick driver
and It works. (Although my TV-stick is still not detected)

So the problem lies in the TV-stick driver and not the RTL8156 driver
thanks for your work and please keep the RTL8156 driver in future releases

Cheers!

26 posts were split to a new topic: Internal Ethernet not working A95X Max S905X2

About | FAQ | Terms of Service | Privacy Policy | Legal Notice