Internal Ethernet not working A95X Max S905X2

BTW, is it possible to check which wired network chip is inside my TV box using SSH?
because the internal NIC is still not working
I think the name of the network chip should be registered in some sort of file but I don’t know which one
it would be great if you can add the driver for the internal NIC as well

I have the V81 board and Ethernet is working fine using g12a_s905x2_4g_1gbit.dtb device tree.

That’s is strange, there is no wired network detected at all if I use g12a_s905x2_4g_1gbit.dtb

It is indeed and as far as I know, there were only 2 board types manufactured, the original having different WiFi/BT but as far as I know, the same Ethernet.

Does it work under Android?

It works under Android. Maybe I’ve got different network chips with you

At least that rules out a hardware issue.

I don’t know the commend to identify the particular chip, although I suspect that it will show itself up after using dmesg|paste

Running CPU-Z under Android should also identify it.

No info about network is shown
But I downloaded cpu-z with wired network. It works

What does it show under the device tab?

This is the device tab

One of them should show a lot more info about the hardware.

Nothing more, I’m sure

OK, I am used to seeing a lot more when using it, so no idea why it is devoid of useful info.

Well I’m sure that somebody will soon tell you the best SSH command to use to identify it.

In fact there are many apps called cpu-z
not sure if you are using the same one
I installed another cpu-z
also don’t have network info

The original CPU-z is made by CPUID.

I know, but CPUID’s cpu-z don’t have network info too

This is the one by CPUID

I tried installing CE again with g12a_s905x2_4g_1gbit.dtb device tree as stated by Compent. I disabled wireless networks and only enabled wired networks as shown below:

No connection is detected

No wired connection is detected with g12a_s905x2_4g_1gbit.dtb, so I go back to g12a_s905x2_4g.dtb with my RTL8156 NIC attached

Although a NIC is detected, it cannot get IP address by DHCP, manual input of IP & subnet mask doesn’t work as well.eth1 is RTL8156 which works.

This is a strange one and indicates a board revision that has not been mentioned before (or a fake).

I guess one step it to open the box and look at the board to see exactly what NIC chip is onboard.

Luckily this box is easy to get into because of the SSD bay and getting at the board is simple enough.

I took a picture of the IC adj to the RJ45 socket which I believes to be the network controller. As my phone doesn’t have macro function, this is the best pic I can take. Is it RTL8210?

Hard to spot. There is no RTL8210F on Realtek website.
But marking could also be RFL8211F, which is listed