Dolby Digital EAC3 no sound on pass thru playing video with 23.976 frame rate

I’ve installed Coreelec 9.02 on an SD card and am running it on a generic S905 box (Antsir) which connects to my AV amp via HDMI, and I have pass-thru audio enabled for all audio types. The amp is a Pioneer VSX-922.

The problem I have is that when playing any video with a Dolby Digital Plus soundtrack, AND that has a 23.976 frame rate, I get no sound from my amp. In fact, the amp does nothing and does not display that it’s receiving a DD+ signal. However, any other frame rate (including 24.000) and it works correctly, giving me audio and displaying it has a DD+ signal. All other audio types (DTS, DTS-MA, Dolby Digital (not EX), TrueHD) all play fine when the frame rate is 23.976.

If I disable pass-through for DD-EAC3, I get sound, albeit decoded to PCM, so this is a workaround, but not ideal. Also, if I disable frame rate switching, so that it plays at 60hz, I get the DD+ sound played ok.

I should point out when running Libreelec, I don’t get this problem - that plays 23.976 material with DD+ fine with pass-thru enabled.

I ran with debugging enabled but it fails to upload it to ix.io as I think the kodi log is too big, so i’ve uploaded it to hxxps://we.tl/t-KxNsf9i2g6. The other log files are at http://ix.io/1LdB. The logs show me firstly playing a 23.976/DD+ file (no sound) followed by a 24.000/DD+ file (sound ok from the amp).

Thanks

Could you also upload 1 minute example for test?

I’ve put two sample files at https://we.tl/t-bXLufHmBRp - the 23.976 one (no sound) and the 24.000 (sound ok)

Just tried on my S912 box and on N2. Both files audio plays correctly. I see correct 23.97/24 and DD+ on my Onkyo receiver too.
Did you follow kodi audio settings recommedation?
https://kodi.wiki/view/Audio_quickstart_guide

Yes, I’ve followed those pretty much (my amp is 5.1 so number of channels is set accordingly).

I found another earlier thread from someone who was having a similar issue:

His amp is also a Pioneer and similar model to mine, so I wonder if there’s something Pioneer amps don’t like about the way Coreelec bistreams DD+ ? But, as I said, the amp is fine if I use Libreelec to stream DD+

Could you try 7.1 just for test in kodi settings?

Changing to 7.1 makes no difference.

Do you still have the old CE or LE build that works?
Run it and do the following in SSH:
Before playing each sample, run dmesg -c.
Run your sample and do dmesg | paste.
Post the links.

Yes, I have Kszaq’s Libreelec build (based on Krypton) on another box. Here’s the logs:

http://ix.io/1Lfp (the 23.976 sample)

http://ix.io/1Lfr (the 24.000 sample)

Can you run dispinfo command in CE?
I think you may have a bad color depth and chroma setting in CoreELEC that may somehow affect the AVR.

Ok, it’s here - http://ix.io/1LfP

Colour depth: 10-bit from log…
Try to choose limit display color depth to 8 bit reboot and try again…
And does this output was while watching this 23.976 video? Because in dispinfo it shows 1920x1080p60hz

Well that seems to have fixed it! :slightly_smiling_face:

So obviously trying to send 10bit to an Amp that doesn’t support it is wrong, but what a bizarre way for it to manifest itself affecting just one type of audio at one refresh rate. Yes, it’s definitely outputting at 24Hz so not sure why the log was showing 60hz?

Anyway, thanks for all your help and I’m glad i was a relatively simple thing to fix. :partying_face:

@renzz, great to hear that! Could you please replay the 23.976 sample without forcing 8-bit and report the dispinfo during playback one more time?

@CI6N0Z - here you go - http://ix.io/1Lif

Everything seems fine. You could try to change your HDMI cable and/or whitelist resolutions to see if it solves the issue. If not, forcing 8-bit seems to be the only way to make this working. I’ve Pioneer VSX-933 and don’t have this problem.

I suspect you know that both your Kodi box and your AVR doesn’t support HDR10, so if you wan’t to watch 10-bit HDR content, you have to swap both or connect your (new) box directly to your TV as your AVR can’t passthrough BT.2020.