Dolby Vision for Minix U22X-J (Max) and Ugoos AM6+

You’re right on lg c6 internal(btw can you multi pattern 2023.10 10000 to P5 to test on tv internal), but tested All other on minix u22 xj max incl. your profile 8 CMv2.9 and l1+l2.

P.S attached is pics of hardware info from minix u22 xj max.

Unfortunately, when I convert this pattern to profile 5, it breaks its properties and the pattern no longer works properly.

I suspected also as i tried it in tsmuxer and couldn’t get it to work. Btw is great having you here, you will be great addition in getting coreelec to perfect the system and thanks for all your work.

1 Like


Seems taking a while for moderation in the other forum - so will ask here also until that hopefully speeds up:

Could you use your HDFury Vertex utility to capture the AVI InfoFrame.
See page 34 here:

For both the Y and N case i.e.

echo Y > /sys/module/hdmitx20/parameters/dovi_tv_led_bt2020


echo N > /sys/module/hdmitx20/parameters/dovi_tv_led_bt2020

thanks very much for your testing done.

This toggle is hidden when your display doesn’t support LL_DV.

you’re right. There is a bt709 flag in the signal :(. it’s not displayed on the vertex OSD but it is in the GUI software. AppleTV / x800m2 does not have any flag. Chromecast GTV has a rec709 flag. here some pics: d — ImgBB

thx, will look at a change where we can remove that so have all the permutations to test with - on the plus side modern TV / TV side implementations seem unfazed and look to be doing the right things anyway.

I am still holding out I like the bt.2020 better for my E8, but read your comments on previous testing so will need to look again over more material.

Yes, it’s only visible if TV does support LLDV reported by EDID.

@Portisch I’m still getting broken decoding on the latest nightly. Here is the pastebin with the log and images. This is seems to be universal among all the DV content that I have and thre breakdown in image processing happens at exactly the same spot.

Edit: I tried it in LLDV mode and had the same exact error. Howerver, I could not get a log because the system hung when I exited. The issue was not present on 20240322.

Happy to see you here.

1 Like

FWIW, I just tested on my 2023 Hisense TV and No flag, REC709 or REC2020 makes no difference. The TV OSD reported REC709 for no flag and REC2020 when the flag is active. So it seems to only matter for older TVs maybe… unknown | Slowpoke Pics … Will try to check on the C2 too later but I didn’t see any color difference between the x800m2 and ugoos in all the tests I did so it is safe to assume that the C2 also ignore that flag(TV VRR osd doesn’t even report a flag)

No difference with that flag on/off when viewed from my LG G2; tested in a pitch black room.

OSD reports a blank when flag is not set.

@Portisch Comparing the logs from 2024-03-26 with 2024-03-31, it appears that on the 26 it would do a bunch of CVideoPlayer::ProcessVideoData and then run info : running thread: video_thread, but on the 31 it now does info : running thread: video_thread and then CVideoPlayer::ProcessVideoData. Could this possibly be causing an issue? It also seemed to be processing more data before running CAMLCodec::OpenDecoder on the 26th. On the 26th it runs pts:0.000 to pts:3.170 beforeCAMLCodec::OpenDecoder, but on the 31st it only runs pts:0.042 to pts:0.542.

my Sony A95L reported nothing with no flag and REC2020 when th flag was set. No differences in pq

I just loaded up the v21 0331 nightly. On 1917 it starts ok (I didn’t let it play long to see if it was stable), but it is basically unable to seek/skip in this movie, just becoming a still frame that updates every 30 seconds or so to the next frame. Oddly it did manage to catch up by skipping hundreds of frames a couple times (Player debug info) but usually it didn’t. When it did advance to the next frame the skip counter went up by 1 if that’s any help to anyone.

I tried a different FEL movie and it seemed to seek/skip without issue. Same with a MEL movie. But I literally spent a few seconds testing each of these.

I don’t see anything like @Astrotrain is seeing though.

1 Like

Same here. V21 latest nightly will sometimes freeze when seeking. The same file has no problem seeking in v20.5

Seek in CE-21 FEL is currently unstable, but we are testing already some items to get this fixed.


I had this issue when I set UI at 4k. When back @1080p it was ok

Thank for the tip. I tried that, but it didn’t seem to work. I guess I’ll wait for the next round of fixes and test again.

Can the OSD be displayed when a problem occurs?
If not, maybe the HDMI cable is the problem?