Dolby Vision for Minix U22X-J (Max) and Ugoos AM6+

Need use usb3 pendrive in homatics, lot faster.
Anyway I have beelink gt King in same chipset, and not noticeable faster, as my homatics boxes.

The AM8 (S928X-J) doesn’t have dual decoders though, right?
So it’ll never be able to support FEL like the AM6B+ (S922X-J), correct?
Or, am I missing something?

Also, does anyone know whether the S922X-J and/or S928X-J utilize the CMv4 Dolby Vision SDK , or the CMv2.9 DoVi SDK like the S905X4-K?

Thanks!

Is there a way to see if FEL is actually working? I see the DV logo activate on the TV, but even clicking “Stream Info” doesn’t show the dolby vision info.

1 Like

Datasheet seems to elude to it being able to decode 4x 4K@60 simultaneously, which makes me think it has 4, but not sure if I’m reading that correctly. Something newer down the line with similar DV FEL support and AV1 decoding is mostly what I was thinking would be cool.

All SoC since g12a support dual decoder. Also up to 8 decoder in parallel.

We think the suffix K doesn’t support FEL but the suffix J do. But we are not sure.

2 Likes

I just ordered AM6b+ for AliExpress to test, currently i have Nvidia shield 2019 pro and ATV 4k so hopefully Ugoos will be my final box that do DV right, my question is there any tutorial on how to install CoreElec and can i use USB flash drive instead of SD card ?

You’ll have FEL playback support but lack proper tv-led with Ugoos. There is always some con with these players.

1 Like

what’s the problem with AM8 and CE atm?

Would be nice to have a AV1 capable device with dv fel support if the CE Team can figure it out.

There is a Amlogic S928X thread in general with that info.

What is causing the tv-led limitation with this device? And what are the implications of this for someone with an LG OLED?

as far as I unstand this topic: the AM Logic boxes do some processing or tonemapping, even with tv led dolby vision activated. So tonemapping is done twice (in box and in tv). with tv led, the signal should be passed through to the tv untouched.

Have tested many FEL films and they all seem to play ok with the exception of one: Ghost in the Shell

I have a fully wired connection, tried playing this film with or without subtitles / compatibility track audio (ac3 5.1), no dice. The audio plays ok, but the video has to “catch up” and plays like a powerpoint.

It is a P7 FEL remux, I can provide a log if someone can tell me where to capture it.

https://wiki.coreelec.org/coreelec:ce_support

I was having the same issue with player led DV. Purple/green tinted colours when playing Dolby Vision content.
My setup: LG C8, Onkyo TX-NR676E receiver, Ugoos AM6B+

I noticed that the Ugoos was sending a YUV 4:2:2 36 bit signal to the receiver (RGB 12 bit when using TV-led mode), so I configured it to force display colour depth 10 bits and force colour subsampling to 4:2:2 (accessible in Settings / System / Display).

Now the green/purple tint is gone in Dolby Vision and the signal is a YUV 4:2:2 24 bit signal, maybe it will help you, too.

Hello, I ve bought an Ugoos am6b+ after I ve learned about coreelec. Its running on a usb stick and I am using it with a Philips 806/12 and samsung q800a + swa 9500s for audio.

I seem to have problems with playback of profile 7 MEL movies. I play them with PlexMod4KODI. I haven’t watched a full movie yet, but I’ve checked out first 5-10 minutes of multiple movies. While FEL movies and profile 8/5 seem to work fine, but MEL movies (Dune 2021 and Gran Turismo tested) seem to cause the player to freak out at certain moments in movies (image freezes while audio is going, than player gui appears, audio lags for a moment and movie skips a second or something like that).

I tried different remuxes and tried packing my own mkv from bdmv files, but the problem still remains on these movies. Turning off DV in settings allows the movies to play them normally in hdr10. At the moment solution seems to be just using Profile 8 remuxes asfaik profile 8 ~ profile 7 MEL (correct me if I am wrong, cause I am a bit of a noob), but having working 7 would be nice.
Logs: https://paste.coreelec.org/kU76IW
Player info:

@liquidion

Just tested a bunch of different releases and they all worked fine. Made sure they were all p7 fel files.

@rraatt

Had something similar happen with men in black 25th anniversary edition yesterday, which is also mel. It would freeze at specific shots every single time while the audio played, and resume after couple of seconds.
I tried rebooting and then it worked fine after that, never had any freezes. I use tv-led.

FEL releases work fine. It’s MEL ones, I rebooted the system multiple times and tried different remuxes, it freezes in the same spots every time. I use tv-led too.
Edit: understood, that beginning was addressed to other person, btw I have ghost in the shell profile 7 FEL, works fine.

Could you tell me the time the video freezes, I’d like to check.

In gran turismo its around 40 seconds, when alloys face is shown in playstation productions bit. For Dune around 1.20 where a spice harvester is shown. There are more further, gran turismo is especially bad.

Something weird is going on, I couldn’t reproduce it
with Gran Turismo, tried a couple of releases and confirmed that they were Mel. Then I tried Dune and it froze right around where you said it would.

Now it also freezes in Gran Turismo, and Men in Black.

A reboot didn’t resolve it this time, I wonder what’s going on.

Edit: Another reboot and Men in Black played fine. (around 21:26) But others don’t, so who knows what’s going on.

1 Like