EDID Override - Injecting a Dolby VSVDB Block

Hi, sorry but with update six everything goes in HDR, even if I select DV on demand with LED DV st.
DV movies are all in HDR
Before everything worked
I also noticed that if you activate DV, the next time you switch to an HDR movie it messes up with the colors and resolution.

Ps. I installed the Omega_devel_20240609154632 version and everything works correctly. I have a standard DV and HDR10 projector.

Gianni

Same here. It looks the same to me.

Hello, after few test, it is clear the maxlum value is not taken by the engine for DV->SDR conversion. So does it take maxlum from VSVDB even if it would be counter intuitive ?

Just checking you looked at the dmesg and see it sending the values you expect?

No real idea what is it doing as closed source, but sounds like it takes the mode “SDR” and internally just limits ignoring the passed in min and max, guess not taking the VSVDB either as that would be higher than 100, guessing around 300 for a projector?

Could also try forcing back to graphics mode.

This is the main call into the dovi.ko (as I understand) and best estimation of what is feeding in:

int control_path
	(
	enum signal_format_enum in_format,					// SDR, HDR10, DV
	enum signal_format_enum out_format,					// SDR, HDR10, DV
	 
	char *in_comp, int in_comp_size,					// Metadata ?	
    char *in_md, int in_md_size,						// Metadata ?	
		 
	enum priority_mode_enum set_priority,				// Video or Graphics
	
	int set_bit_depth, 									// DV 12, DV no EL then 10, HDR10 10, SDR 10
	int set_chroma_format, 								// 0 !? maybe sub sampling and 422?
	int set_yuv_range,									// SMPTE

	int set_graphic_min_lum, int set_graphic_max_lum,	// grpahic min and max luminance (does change the OSD) Graphics priority I recall this may effect video as well.
	int set_target_min_lum, int set_target_max_lum,		// video min and max luminance (appears so far no effect).
	
	int set_no_el,										// Is there an enhancement layer.
	
	struct hdr10_parameter *hdr10_param,				// HDR10 display mastering and etc, from display.
	
	struct dovi_setting_s *output						// Core and luts setup, VSVDB - lots of info including repeat of some other info from above like in and out format.
	)

Will need more details, post photos of the version (to confirm) and your DV config as a starting point.

Not really the “developer” of the conversion process, just enabling/configuring/exposing options that are already in the amlogic linux implementation.

Faster switching for me and lower luminance in Kodi menus with fine control (I prefer darker kodi/menus).

Don’t know if diff between off and SDR - it is certainly engaging the DV Engine with SDR and previously others have seen a difference - needs capture analysis to tell - not something I can do.

As I said in the release notes, it is processing in the DV Engine as “SDR” this SoC/dovi.ko cannot handle processing as “HDR HLG” and throws errors if forced. For me the colours are off - overall more muted than native “HDR HLG” on my TV.

Ok, thank you

Yes I’ve seen values passing through, but not any visible sudden change in DV video playing on the fly.
In my case my VSVDB was around 280nits maxlum, but I can’t visually confirm right away that it was taking 100 or 280.

I’ll try that:

  • Modifying VSVDB to spot any difference, In this case I need to be in DV “on demand” and play/stop between changes right ? I need to change values and also I’ll try changing color primaries values to see if it has any impact.

Question : Do you know if bt709 is the only color space output possible with this DV->SDR conversion ?

Before digging in the so called “graphic mode”, let me try to be sure VSVDB is not - mistakenly - involved

Yes, the VSVDB is changed before playback starts - applied only once each time.

Ok I can send you some photos, but I can assure you that I only use the flag on “DV on Demand” and “DV LED standard”. Apparently the DV signal is not sent, but only HDR (only on DV certified panels?)
I have the 20240906 version in my archive as the latest version and this version works correctly sending the DV signal.

with version 20241306
MKV in DV format = HDR flag on TV and HDMI information
MKV in HDR Format = HDR flag on TV and HDMI Information
MKV in HDR10 Format = HDR flag on TV and HDMI information

What you have described should work fine, and does for me.
So need more info - something else must be affecting the outcome.

Can either just go back to the old version, or work together to find out why - if want to find out why, first step is double checking the setup and a quick photo/screenshot from a phone directly to the forum would be the simplest approach - next would be logs and troubleshooting.

Not that I don’t believe what you are saying but been in the S/W business for 35 year and many times things are miss-communicated where just observing the situation can clarify a lot up-front first.

This result is not correct, with DV signal I must have a DV flag
I’ll send you the photos today

1 Like

My previous conclusion is this is a limitation elsewhere in Amlogic regardless of DV VS10 etc. SDR is the fallback position, i.e. if not another HDR mode then it assumes SDR and as part of that assumes SDR is bt.709 - posted about this elsewhere and the reason why I could not yet fix the Amlogic issue with incorrectly identifying bt.2020 10bit SDR as HDR HLG!

I will send you the requested photos
DV_OK_1 and DV_OK_2 are with “CoreELEC-Amlogic-ng.arm-21.1-Omega_devel_20240604112155” update, in this case the signal is displayed correctly. Everything works


DV_NOK_1, DV_NOK_2 and DV_NOK_3 are with “CoreELEC-Amlogic-ng.arm-21.1-Omega_devel_20240613134127” update, in this case the signal is not displayed correctly.
Indeed in the case of “Encanto” it turns out to be an SDR with off-colour colours.
Sometimes it makes a mistake if you switch from a DV film to an HDR film



I had this “glitch” with first 20240613 version, to my surprise, because all previous versions worked OK.
What I did to fix it, I turned Mode to Off and played a DV film. It played correctly; after that setting Mode to “On” or “On demand” everything worked as expected, also after updating to latest 20240613 version that came few hours after first 20240613…

I tried using your settings, but I couldn’t reproduce the bug. DV played correctly for me…

believe there is something changed in offical nightly build on June 13rd.

I faced the same problem , now it’s unable to playback DV content correctly by update with your bulid(tar)

All p5 webdl were green/purple, all UHD BD can just playback in HDR10

Maybe try what @Sholander said.
Turn Mode: off, then play a DV file. After that turn Mode: On or On Demand, then play a DV file…

do you mean I missed an update version?

If I understand correctly you have the same problem?