Fail to boot with media_build (8.99.1)

I had problems updating my Beelinkgt1 standard (s912), it blocked in the Coreelec logo and wouldn’t start. No SSH. I tried a fresh install and it worked but after installing drivers dvb from last kernel (I have a Xbox tuner and was trying to choose the correct driver because I couldn’t remember anymore the one I chose in previous release) it add to restart and the problem happened again. Wouldn’t start. I’m going back to previous release, configure everything, make a backup (I didn’t make one in a long time) and try again the new release …


I have same problem on KVIM2 as Vascobraga

So when I try the drivers from last kernel (penguin) I get this at the reboot and all gets blocked. In the following reboot it stays in the logo with the version nr on top.

Edit: I confirmed that with the other two module drivers my Xbox tuner does not appear in tvheadend server.

I can confirm the same issue with media_build drivers from the latest kernel! My device is stuck on the boot logo.
With the other module from the latest kernel (Crazy Cat) drivers, my Hauppauge Win TV Dual DVB T/C tunner is recognized in Tvheadend but shows a lot of continuity errors.

Ping @afl1

Same here with Minix U9

We have now fixed this and it will be available in tomorrows nightly.


mine too is stuck on boot (Odroid C2, S905). is there a way to manually revert without SSH access?

edit: ok, I manually replaced the SYSTEM file on the eMMC card, rebooted, set the dvb drivers back to default and now I could successfully upgrade to 8.99.1

Which SYSTEM file did you use? I can’t bring up my system anymore. Even with the latest nightly from 31.01 it just freezes at the boot image.

@rosenrot have you tried the latest release? Do you have media_build enabled prior to update?

I’ve upgraded my NexbboxA95 (S905, using Device Tree gxbb_p200_1G_100M_RealtekWiFi) from 8.95.7 to (I run it from internal) using the CoreELEC-S905.arm- file. After upgrading, I got only a black screen. Also Network access (ssh, smb) didn’t work. From time to time the screen was switched off (my TV shows this) for a second and the switched on to black again.

I was able to rebuild the Box via SD Card to 8.95.7. Then I tried the Upgrade again with CoreELEC-S905.arm- file. Same result.

I’d rebuild the box again and updated it to 8.99.1 with the tar file. This worked.

Sorry, I’m not able to provied logs because og missing access to the box after install. Can you please check for S905 anyway?

PS: Upgrade to X96 S905X Box to worked fine.

@anon88919003 I only tried the build from 31.01 so far. I switched between the the different dvb drivers recently because I receive a lot of continuity errors on the TBS crazycat driver on my KI Plus. I will now update to And try the media_build tomorrow.

So I tried the nightly and after enabling media_build, showed some information scrolling when booting and reached Kodi. Then I tried to reboot and now the information scrolls in the same way but doesn’t reach Kodi.

So it booted fine until you enabled media_build?

Oh no! I just installed and I’m in the bootloop. Like here:

Update: The nightly works.

May I suggest pulling that release as a temporary solution to avoid other bootloops?

I don’t know if I’m explaining well, it always boots well when I make a fresh install, always, withe all the new versions and the nightly. It’s only when I activate the media_build that it fails in the reboot.
One time with the nightly and another with the 8.99.1 it reached Kodi but it was temporary. When I rebooted it failed again.

1 Like

What device and dtb are you using and do you have your adapter connected when this happens? Also are you using a remote.conf or meson-ir configuration?

I do have the KI Plus. I’m not sure about the remote.conf but I didn’t change anything since 6 months. The dtb is the one which was installed automatically. It works with 8.99.1, nightly0131.

Seems like s912 devices boot fine but have issues with media_build, whereas s905 devices don’t boot at all (and may suffer from the same media_build problem if they were to boot)