Gigabit LAN driver problem

I use USB 3.0

I found a .img that works, but now I have an error about temperature and I cannot find a range that will let finish the update. It stucks at 97%. Any idea ?

Thank you !

Maybe go here and see

I finally managed to revive the X86 MAX. Unfortunatelly, the only version that worked was the original ANDROID 9.0 (X96Max_V311_4G_9.0_V311P_20190722.img) The other images were getting errors at 4%. Now it works 100mbit LAN (it get’s the DHCP good IP ) but not 1000mbit :(.
I opened the box and saw that LAN is RTL8211F.

Could this be fixed by a nightly in the future ?

Thank you !

1 Like

If you see X96Max_V311R_P in android under device name then you should use this


@Pelican if I have V311R_P version of X96 Max, I should install this version of Android and it should solve Ethernet issues?
Currently the physical link is active, but DHCP cannot take an IP. Manually set IP and still not working, ping is not coming there.

Here is accumulated all firmwares for X96 Max R-realtek

Yes it will solve it.

1 Like

I updated to the version you mentioned but no success. Gigabit works on Android but not on CoreElec.
I used the same microds with the old coreelec. Maybe I should write another card with new img ?

Thank you !

PS: I opened the box. It appears that is a new revision becaus is not similar with what I found on internet.

Still no success. Any idea ?

Thank you !

You can test this custom-rom

I cannot install this ROM.( [ROM] XTMOD-ATV X96 Max - GT1 and some U211 devices)
It get’s error at 7 percent, “bootstage error”. Maybe is because I have a new revision of board. Q5X2_LP3 19215 . The only images that work are with ‘311R_p’.

So, everybody that has this X96 MAX with new revision PCB has this problem ? Or am I the only one ?

Thank you !

I guess I am the only one :(. is there any possibility this could be fixed , I don;t know…maybe in another android update in the future ? or the problem is in the CoreElec ?

Pinzarufilip you are not alone, I have the same box X96Max 4/32 with Android 9.0 firmware V311R_P_20190926-1519, I got the same problem – gigabit LAN doesn’t work under CoreElec 9.2.0 latest nightly build. Its 5Ghz WiFi is good enough for me, I didn’t bother to test its wired LAN speed until I saw this post. I believe it’s a software problem which can be solved later, we just have to wait a while.

1 Like

The same issue with Vontar X96 Max 905X2 4/64.

Workaround , but just 100M:
CoreELEC:~ # ethtool -s eth0 speed 100 duplex full

Then ping is working and hope streaming movies as well (i am not at home right now)
We must wait until someone fix the issue inside the driver:
CoreELEC:~ # ethtool -i eth0
driver: st_gmac
version: Jan_2016

We added a patch that should fix 1Gbit Ethernet issues, try the latest nightly.

Tested now, still not working :(. Exactly the same issue. Internet icon appears but it’s not working at all.

Streaming from my home dlna server is okay with this workaround :

CoreELEC:~ # ethtool -s eth0 speed 100 duplex full

60G 4k HDR movie is about traffic 85Mb/s, well still enough for 100Mb :wink:

@Alex_77 , Do you have the latest android version on your V311R_P x96 max device (V311R_P_20190926-1519)?

I am using the version : [X96Max_V311R_P_20190722-2021(8822)
But on my box it does not work at all the LAN. the internet icon appears but the internet is not working at all.

@TheCoolest , any other updates regarding 1Gbit ethernet issue ? OR should I install the latest android version and then remake a SD with CoreElec and see if it works?

Thank you !

No news, we’ve done what we could.