GT-King and Samsung TV 4K/HDR no signal

Hello guys, reading 4K video is now almost correct.
I still have two small problems.
For my examples, I use the videos of this website:

1- At the beginning of 4K videos, in the first three seconds, I have a black screen, the video stops and seems to synchronize to start again. this is only done once at the beginning of the video.
The Muse video does not have this problem:

2- During the playback of a 4K video, I regularly have micros tears in the image. Barely noticeable.

My kodi is currently 1080/60 video output and I have limited the color depth to 8 bit as you advised me.

I remain at your disposal to test by changing my settings.

  • No one advised you to limit color depth to 8 bit, unless it’s absolutely necessary.
  • Why are you watching 4K videos at 1080P?
  • If the video is 25/50FPS or 24FPS, running the TV at 60Hz will cause frame skips or stutter.
  • If you have a 4K TV, you should allow CE to automatically switch resolution, refresh rate and color space to match the video.
  • The 1 second stop when you start playback is a delay you can configure, and it is there for the auto refresh rate/resolution switching.
  • I read (here) that we have to limit color depth to 8 bit for solving one of my previous problems maybe it is a mistake (sorry but I am french). I read mostly 4K with 10 bit color death so I will modify that. Maybe it was a response for another guy ?

  • I watch 4K with KOdi user interface on 1080 because I read that it was independant of video signal output.
    if it is better to set to 4K in kodi, I will do it.

  • My tv is a samsung 75p 4K/60
    I am ok with you to let switch resolution, refresh rate and color space on auto to match the video but as I had problem before (reading 4K), to solve them I have been told to modify that.

Finding the perfect parameters in kodi depending of our own video hardware is not realy easy for everybody :wink:

It could be interesting to make a tuto on first message of this topic to guide everybody ?
Myself I open a topic on a french forum to help french people to deal with CoreElec.
All the advice you give me here are sent to my french topic -)

I will do more tests this night and will go back here to give results.

You should try resetting everything to default and starting over.
Default parameters should work fine for most users.
Some Samsung TVs may need you to force 4:2:2 for 4K to work correctly.

Resetting to default didnot solve micros tears in the image in 4K videos. It just minimize them a little.

Here are my parameters (I go back tu estuary skin for your facility).

Tomorrow morning I go to Paris for few days. I will not be able to make other tests before monday. Thanks for your help.

Another test with same vidéo Samsung 7 Wonders Of The World 4K Demo (3mn51sec) I only see two micros tears.

I try to read a 4K moovie (with french audio).
Video stops sometime
mediainfo for this file :
ID : 1 (0x1)
Nom complet : … M2TS
Format : BDAV
Format/Info : Blu-ray Video
Taille du fichier : 82,1 Gio
Durée : 2 h 43 min
Type de débit global : Variable
DĂ©bit global moyen : 71,7 Mb/s
DĂ©bit global maximum : 35,5 Mb/s

ID : 4113 (0x1011)
ID de menu : 1 (0x1)
Format : HEVC
Format/Info : High Efficiency Video Coding
Profil du format : Main 10@L5.1@High
HDR_Format/String : SMPTE ST 2086, HDR10 compatible
Identifiant du codec : 6
Durée : 2 h 43 min
Largeur : 3 840 pixels
Hauteur : 2 160 pixels
Format à l’écran : 16/9
Images par seconde : 23,976 (24000/1001) Im/s
Espace de couleurs : YUV
Sous-Ă©chantillonnage de la chrominance : 4:2:0 (Type 2)
Profondeur des couleurs : 10 bits
Gamme de couleurs : Limited
Coordonnées de chromaticité : BT.2020
Caractéristiques du transfert : PQ
Coefficients de la matrice : BT.2020 non-constant
MasteringDisplay_ColorPrimaries : BT.2020
MasteringDisplay_Luminance : min: 0.0050 cd/m2, max: 10000 cd/m2
MaxCLL : 500 cd/m2
MaxFALL : 200 cd/m2

Audio #1
Langue : Anglais

Audio #2
Langue : Anglais

Audio #3
Langue : Anglais

Audio #4
ID : 4355 (0x1103)
ID de menu : 1 (0x1)
Format : AC-3
Format/Info : Audio Coding 3
Nom commercial : Dolby Digital
Identifiant du codec : 129
Durée : 2 h 43 min
Type de débit : Constant
DĂ©bit : 640 kb/s
Canaux : 6 canaux
ChannelLayout : L R C LFE Ls Rs
Echantillonnage : 48,0 kHz
Images par seconde : 31,250 Im/s (1536 SPF)
Profondeur des couleurs : 16 bits
Mode de compression : Avec perte
Taille du flux : 750 Mio (1%)
Langue : Français
ServiceKind/String : Complete Main

This configuration should work correctly.
Your TV should switch into 4K resolution and the correct refresh rate when you start playback.
Make sure that the resolution whitelist is empty.

Yes it worked almost good but I just want to test
parameters/System/CoreELEC option : Tone map SDR to HDR
but I had problem (after reboot).
So I unset this option and reboot.

Since, I can’t read most of 4K movies.
a few seconds after beginning, dark screen (on yatse I can see that movie is always reading)
after other seconds, my tv takes control and says :“no signal”
I stop movie with Yatse, TV go back to kodi screen.

Another 4K movie, the dark screen is at the beginning of the reading (not few seconds later).

Arfff !!! very sensible. When it works, don’t touch anything ! I I regret.

But maybe a problem of going back in parameters ?

I reinstalled last update (tar file) in update directory but nothing changes.

  1. What problem did you have with SDR to HDR tonemapping? Also, why would you want to use it anyway?
  2. I already told you that Samsung TVs may need to have the 4:2:2 option turned on in CoreELEC settings menu. This should fix the no signal issue.
  3. You get a black screen in the beginning because the resolution and refresh rate are being adjusted to match the content. That is normal.

1 after setting on SDR to HDR option, reading 4K movies gives black screen (I suppose that it was this option which was the source of that). So I go back to SDR to HDR = Off but problems goes on.
I didnt need this option on, I just want to test with SDR 4K movies to see if better colors.

2 I tried setting on 4.2.2. option tuned in CoreELEC but problem was always the same for 4K movies.

3 having a black screen at the begining may be normal but always black screen and reading movie always working (I can see it in yatse android application), that is not normal and it makes me very difficult to see movie :slight_smile:

… but other 1080 movies work …

[EDIT] my new post below in this new topic must be appoved again. why ?

SDR to HDR option will play any content in HDR mode. This isn’t something you want enabled, unless you know exactly why you want it turned on.

Black screen is normal for ~1-2 seconds in the beginning, when the resolution and refresh rate are changed. It should not remain black, and you should not have a No Signal message on the TV.
Also, you never said what TV model you have. 75P Samsung 4K doesn’t tell us anything.

  • I’m splitting this topic into a separate thread, as this thread hijacking has gone long enough.
  • Is your GT King connected directly to your TV or do you have an AVR?
  • Make sure that HDMI 2.0 is enabled on the TV’s HDMI port where the GT-King is connected.
  • Make sure that you have a not-very-long (1-3 meters) High-Speed Premium Certified HDMI cable, which can properly handle the required 18Gbps bandwidth.

Your problem is with your equipment and/or configuration, it’s not a CoreELEC problem.

The HDMI connection is in place of oldest RPI with LibreElec which had no connection problem.

My GT King is connected via HDMI to Denon AVRX2500H which is connected via HDMI to a recent TV Samsung UE75MU7005

4K movies where read correctly before I change SDR to HDR option.

Actually the problem is not with 10BIT HDR x265 4K files (demo files) but with 8_bit SDR x265 4K files
demo files seems to have not this problem. They only stop to commut to HDR (I suppose) like before, but movie can be read. No black screen and wonderful colors !.

  • Old RPI did not support 4K or HDR, so that is irrelevant.
  • Denon receivers can be problematic. You need to make sure that you have HDMI 2.0 enabled in the receiver configuration too. And they do require 4:2:2 to be enabled in CoreELEC.
  • The MU70** series should handle HDR just fine, but I don’t know if you need to enable anything in the TV menu for 4K/HDR signals.
  • I suggest that you connect the GT-King directly to your TV for testing, to make sure that the AVR is not the problem. After you get it to work reliably, you can then try to fix it with the AVR in place.

I validated HDR+ in TV Samsung video expert mode and it seems to work now.
As I said before, I leave tomorrow morning for Paris so I will make other test not before monday.

Thanks for your help

HDR10+ is something different, it’s similar to the SDR to HDR option in CoreELEC. You should keep that off for best picture quality and colors results.

1 Like

Yes I think because problem now with Demo file in 4K HDR

Sorry, I don’t understand. In the previous post you said it worked, but now you’re saying there is still a problem?
HDR10+ simulates HDR with SDR material. It also does strange things to true HDR10 content, and it should be disabled.
It’s possible that your HDMI cables simply cannot reliably pass the bandwidth requirement of a 4K HDR signal.

OK thanks, when I will come back home on monday, I will test other hdmi cable.

It seems to be HDMI cable between Beelink and Denon !!
I replaced it with the original beelink HDMI cable.
I will make more tests later.
Thanks all of you and good night