Gtking-pro no sound on 3.5jack

Hello, magicians

I’m super new to the CoreElec, just got it installed on internal of my GT-King Pro and for some reason I have no sound on my 3.5jack, I can’t check HDMI/Bluetooth, because right now I’m out of devices with speakers on those outs. I tried switching all audio modes, none produced any sound, nor system kodi sounds, or any movies or airplay streams… any ideas where to poke ?

log link:

thanks in advance

Make sure that the selected audio device is PCM (analog)

Try installing the latest nightly build and see if that fixes the problem.

Thanks for answering, yeah I tried all available modes :confused:

I’m not sure how to use nightly builds though, the link from welcome page doesn’t feature any builds, only archive folder has some, any guides how to use nightly build properly ? Any way to install them from already installed CE on internal ?



Latest (203.73MB2020-05-20 00:24:50)

SMB into your box and drop the latest .tar into .Update Folder.


Thanks, got it. Still no sound on 3.5 :frowning:


P.S. Double checked on Android TV, everything works fine out the 3.5mm there, so no hardware issue.

Have you tried to not leave on default but actively select the AML-AUGESOUND, PCM?

Yeah, tried all of them, with no luck

Maybe take a closer look at your 3.5mm audio jack, if it’s wiring confronts GTKing’s connector.
It’s a know thing that different manufacturers use different order in wiring these connectors.

I’m not sure what do you mean, I checked correct functionality on a dual-boot ATV OS on the same port, not sure how to check wiring tho

Just saying that there are different wires going to different pins on jacks/connectors.

Look at this article and the table in it to see what I mean.

The GTK Pro has a DAC, so it’s possible that it behaves differently from GTK and may need its own DTB.

Yeah, pro has per-channel ESS9018JPA dacs and RT6862D amps, any chance this problem can get looked into ?

We’ll look into it.

Thanks a lot!

For a quick test:

1 Like

Hey, thanks, will try! Putting in the update folder will work fine ?

No, this is just a device tree. Save it on your computer and copy to your gtking-pro in some folder (like downloads). Then overwrite original device tree.

mount -o remount,rw /flash
cp /flash/dtb.img /flash/dtb.img_orig
cp g12b_s922x_beelink_gt_king-analog_sound.dtb /flash/dtb.img
mount -o remount,ro /flash

Doesn’t boot anymore, stuck at Android TV splash screen (it shows up for a sec before CE is booted), now it’s permanent, unreachable via ssh as well

You had to do something wrong. How do you boot CoreELEC - from USB stick or SD card?

It’s on internal, dualboot with ATV