[Guide] S922X-J (Ugoos AM6b+) CoreELEC installation and FAQs

i saw an oldskool test colour picture 2 times, then nothing.
waited 5min. thats to long i guess?

tried again. no test picture anymore.

checked the sd card, seems perfect, latest change was my remote config file.

i’m trying again

Should be less than a minute. Check if you’re using the right dtb file.

1 Like

sorry im so stupid. was using my installed hdmi cables from another device - into avr then oled… changed to direct TV it works within seconds. sorry! maybe add that hint on top in case more like will come… :slight_smile:

Glad it work!

1 Like

yep me too :slightly_smiling_face:

I would need a little help with putting it on the emmc. I want to do that directly before starting the skins and settings… adb what?

Start off on external media and then transfer to the emmc later if you’re not completely comfortable. Everything will be preserved. Otherwise, read the links and follow along. It’s not as daunting as it sounds. Once you connect to your device via putty, it’s fairly easy.

1 Like

ah thanks! preserve is good!

putty. that’s way out of my league!!
I remember oldskool custom Roms for Android and I think with my nas. that’s either a perfect one step guide or I will leave it…

happy Monday!

well maybe I wasn’t pressing the recovery button enough but corelec never loaded but I got an And4oid udating graphic and then a menu of commands “boot” etc. that didn’t work either. Did I mess things up?

Unplug, try again, and, if it still doesn’t work, recheck your boot media.

This might be common knowledge but I might as well share that I tried one of my 2.5GbE USB to Ethernet dongles and it works out of the box in CoreELEC.

Got ~2.3Gbit speeds running Iperf to my server.
However, I guess the noisy USB3 port killed the Bluetooth connectivity so my Harmony remote was unresponsive during the testing.

Could be a cool little feature for someone who does not need the Bluetooth.
2.5Gbit is very overkill hence the cool factor.

It looks scarier than it is, but you’ll get it within minutes. First go to Settings → CoreElec → Services. Make sure SSH is enabled. Then go to Settings → System Information. Note the IP address.

Open up putty, type that IP address and click “Open”. That’s it, you’ve connected to CoreElec vs SSH! The default username password is root / coreelec

Now you can just type “ceemmc -x”, and select option1 (dual boot) when it comes up. Press “Y” at the prompts that show up, and done. You’ve successfully loaded your OS into emmc and can remove the slower SD card.


And to add to that, you don’t even need to download Putty.
If you have powershell installed on windows the SSH functionality is built in.

  1. Open powershell
  2. Enter: ssh root@IP.TO.UGOOS
  3. Enter the password: coreelec

So it boots to CE but now I can’t get the remote to work I did copy the remote.conf file to the root of the boot usb - any ideas? It did work once for one button push but no lonber.

My Ugoos remote was dead on arrival, it never worked at all.
If you have a USB mouse you can use that instead and try to connect/re-pair the remote from the CoreELEC Bluetooth menu.

Thanks I’ll give that a try.

With a mouse I can get to the BT selector however I don’t know which is Ugoos AM6B+‘s remote (and I believe in try to pair it by simultaneously pressing the vol up & down buttons I unpaired my soundbar’s BT remote - at least I think that’s what happened. Any way to identify which BT address is the Ugoos’?

UR-01 is the name of the remote

Also make sure you keep the antenna on or the Bluetooth will be worse than it already is.

1 Like

I have the antennae screwed in but I don’t see "UR-01 in the available BT devices.

Then it isn’t in pairing mode.

Like this?:
[ 4.096435@5]- mmcblk0: emmc:0001 BJTD4R 29.1 GiB
[ 4.101036@5]- mmcblk0boot0: emmc:0001 BJTD4R partition 1 4.00 MiB
[ 4.107185@5]- mmcblk0boot1: emmc:0001 BJTD4R partition 2 4.00 MiB
[ 4.113343@5]- mmcblk0rpmb: emmc:0001 BJTD4R partition 3 4.00 MiB
[ 4.119999@5]- meson-mmc: Enter aml_emmc_partition_ops
[ 4.124895@5]- meson-mmc: [mmc_read_partition_tbl] mmc read partition OK!
[ 4.131212@5]- meson-mmc: add_emmc_partition

1 Like