H96 Max S905X2 working Coreelec

You may need to disable wifi in order to test ethernet speed.
Also, this is unlikely to be a CE problem, but rather the limited wifi capabilities of the box or the addon you are using.
Try iperf.

Appreciate the response, did some more testing today.

WiFi is disabled. Only connection is Ethernet.

When I run a speed test on my laptop using Ethernet, I get about 130Mbps download - I then unplug that cable from my laptop and plug it into the H96 box and run a speed test and it caps out just under 8Mbps download. The box Ethernet is 10/100M so I’m not expecting the full 100, but certainly not as low as 7-8. If I unplug from the box and plug into my laptop again I get the full 130Mbps again.

I’m not familiar with iperf yet, but will read up on it and try it out during the week.

Could this have something to do with Ethernet drivers on the box?

Highly unlikely. iperf lets you test your local network throughput. You need another PC or device to test with, should be wired for best performance.
You’ll need to install the Network Tools addon to install iperf on CE.

Already installed the Network tools addon, will try to figure out iperf over the next few days.

As a side note, I got my hands on another brand new android box (Viden M16). Booted up android and ran a speed test using Ethernet - 92Mbps. Rebooted to CE on SD card - 9.2.1 stable - turned off wireless and ran a speed test using only Ethernet - 7Mbps. Tried again with latest nightly, still 7Mbps. Seems to me like CE is capping network speed at 7-ish.

Much more likely it’s just something with the speedtest addon, perhaps on these devices.

Don’t use speedtest addon in CE, it could show not correct values…
Install entware (🆕 Entware package manager )
Execute this commands

opkg install python python-pip
pip install speedtest-cli

And after you can use speedtest-cli command for correct internet speed tests

Im currently using the Arnu Box addon . Seems to be reasonably accurate compared to my pc results.

Edit: See below… thanks to Kostaman I re found the link in the Kodi repository. cheers

At least use the Speedtest Addon from Official Kodi Repo.

Or SSH into your box and run command below.

curl -s https://raw.githubusercontent.com/sivel/speedtest-cli/master/speedtest.py | python -

OK I initially thought I was, thanks.
Same looking . Must of been blind. Have removed linky above.

How is the status of CE when it comes to this box? Does everything work from the box after installing CE (remote, lan etc etc) or do I need to configure remote files?

Just set up a 2nd box. Working ok from 1st boot.
Used latest release9.2.1 and remote file as in 1st few posts above.

So the issue is resolved and man do I feel silly now!

After running iperf and getting the same results (~10Mbps down/up), I decided to take a look at my network setup. My current setup was modem/router --> gigabit switch --> H96. I decided to bypass the switch, make a small network config change and boom - 92Mbps!

My modem/router DHCP server should be assigning all IPs in the 192.168.1.xxx range, but for some reason all devices connected to the switch were getting 192.168.122.xxx IPs. As soon as I changed the box to static 192.168.1.x I was getting max speed. So I’m glad to say that everything now works perfectly and accept my sincerest apologies for insinuating that the issue was with CE. Thanks for all you do and keep the great work!

I will soon be getting a second box (X96 Max with gigabit LAN) and I can’t wait to get CE up and running on it as well.


After I updated my H96 Max S905X2 to Android 9, the USB 2 port isn’t working anymore.
I extracted the .dtb file from android, but I don’t know how to use it or convert it for CE so I decided to send it to you, perhaps you can do something.dtb.img.gz (78.8 KB)

Actual dtb for CE - g12a_s905x2_4g.dtb - no gigabit.

Thank you.

Finally tried the ceemmc -vx command and it worked without a hitch. Box is running great, fast and stable with 9.2.1. Only thing that I think needs fixing is the blue LED status light. It’s still “reversed” - LED on when box is off, LED off when box is on. I recall someone saying this is a .dtb issue. Has anyone figured out how to “fix” the LEDs?

Did you try a Coreelec build 9.2.1 etc and the requisite dtb contained therein?
(Check 1st few posts at beginning of thread)

Yes. i am tested with stable and also with nightly, with android 8.1 frmware both ports works, with amdroid 9 firmware only the usb 3 port work. in android both ports works. the firmware version I can put in my box is https://drive.google.com/file/d/1StoI3PsOP5w86MV6xt7grDOKXJi48Y8Q/view?usp=drivesdk

H96 max x2 (Amlogic S905x2) Firmware Android 9.0 LPDDR3

Yes I also found that in android 9.0 only one USB port functions. I am using the GT King port rom. I tried also the BL301 injection and it is true that I can turn on the box once it is completely turned off with my original remote control (I cannot do this in the Android!!!). The only “problem” is that the led is red when ON and blue when OFF. Finally my USB ports keep having power even after I completely turn OFF my box, but this is a common problem both in Android (8.0 and 9.0) and coreelec, so I suppose it is a hardware problem and not software.

" The only “problem” is that the led is red when ON and blue when OFF. " - this is not problem, I think it must be. the blue led means that it is in standby or suspend mode. and usb power can be turned on or off in settings, at least in nightly build.

You know that in official roms (either Android 8.0 or 9.0) the led is blue when the box is ON and the led is red when it is in sleep or shut down state. So in coreelec is reversed, that’s why I refer to it as a minor “problem” (meaning something different than the official or what you were used in).
As far as the power to USB ports, as I already know it is not the same to all H96 max X2 boxes. It differs from box to box (due to different boards, ram being DDR3 or DDR4 etc). I think that once I tried to turn the power off to USBs through the settings in coreelec but if I remember well without success (they still had power).

Probably as thirsty as you say, I no longer know how it is in android that I don’t use it much anymore, I am 99% used to CE.