H96 Max S905X2 working Coreelec

I just reinstalled the latest nightly 0906 from a clean slate. I used the g12a_s905x2_4g.dtb and the remote.conf provided by bazzle. The box, remote, ethernet and wifi are working fine. However, the LED status light seems reversed - blue when off and blank when on. Also, once powered off using the remote I cannot power it back on with the remote - have to unplug/replug the power cable. I’m running from a USB thumb drive. Anyone experiencing this also?

My box is H96 Max X2 with 4GB.


powered off button on ir = sleep ( blue led)

OK, I see. How do I power it back on with the remote? Pressing the red button doesn’t turn it on.

You cant atm.
That part doesnt work. I leave mine on 24/7.
I have the power supply plugged into a smart switch so if it goes pear shaped I can remotely turn off/on with Alexa voice control.

OK, I see. Thanks for the heads up. Hope this will be worked out in coming builds.

You can use this guide:
@bazzle @EBAL

1 Like

I press number 2 on my remote, which seems to Power it on…

last night i installed it with pen drive its super easy took 10mins only boot is also super fast
i will post full review in night after testing everything

The only issue I’ve come across, relates to disconnecting external USB storage drives, which causes a reboot on my system.

hi guys i tried all audio video formats all working fine.
DTS HD MA passthrough done
DOLBY TRURHD passthrough done
while playing HEVC 4K video it reboots coreelec.
while shutdown instead of red light it indicates blue light.
i use air mouse that comes with this device in optional it works good.
wifi detected and connected no issues.
everything works smooth.
thank you very much coreelec team.
last question my pendrive is now 512MB how to get its real size actually its 16gb i tried all format options but still its 512mb

worked fine on mine device. ejected and mounted no restart

you can powered up with ir?

i will try and update

Yes. I can.
(See my post above. Does this not work for you?)

no, not work. from sleep ( blue led) with INFRARED remote. maybe with bluetooth airmouse, I don’t try yet.
i think the problem is that power off system is only sleep mode (blue led) power off from android is done correctly (red led), and from this state i can start tvbox and with IR.

Pressing the ‘2’ button on the factory remote wakes up my box from sleep mode (blue LED). And I didn’t have to install the BL301 injection script for this to work.

So far so good!

Button “2” not work for me.
I use MXQ Pro 4K with longpress buttons remote files and all the buttons work correctly. the only problem is that the shutdown is not done correctly and does not return from sleep mode.

Your mistaken, there is 2 partitions, 512mb is just the first partition and you will find the remaining space allocated to the second partition.

1 Like

Button “2” only works to turn back on.
If I use it when ON screen flashes a bit and im not sure what its doing so I leave it alone.
Latest 20190917 working great.
I had no issues with 20190911 from SD card other than a soft reboot happening at start up. Phew :wink:

Nightly 20190919 still OK :slight_smile: