H96 Max S905X2 working Coreelec

Should be :slight_smile:

GREAT works on H96 MAX X2 without any problems using ceemmc -x command.
Yet another question. There is remote config file in the start of this thread. Where should I put files in it please?

This works:
amremote
Many of you will be most familiar with this method, amremote typically gives a much better user experience with the bundled remotes with generic devices.

To use an amremote configuration simply copy your remote.conf file to either the root folder of your SD card / USB flash drive or to /storage/.config/remote.conf .

NOTE: after the first time you boot your device with an amremote configuration it will automatically reboot whilst modifications are made to your dtb to enable amremote.

You can change back to meson-ir at any time by simply removing the remote.conf file and rebooting.

Please run this on a SSH connection of your device and post the output:

CoreELEC:~ # dmesg | grep mmcblk
[ 4.018878@3] mmcblk0: emmc:0001 CKTM4R 58.2 GiB
[ 4.018993@3] mmcblk0boot0: emmc:0001 CKTM4R partition 1 4.00 MiB
[ 4.019115@3] mmcblk0boot1: emmc:0001 CKTM4R partition 2 4.00 MiB
[ 4.019237@3] mmcblk0rpmb: emmc:0001 CKTM4R partition 3 4.00 MiB
[ 4.020937@3] meson-mmc: [mmcblk0p01] bootloader offset 0x000000000000, size 0x000000400000
[ 4.021028@3] meson-mmc: [mmcblk0p02] reserved offset 0x000002400000, size 0x000004000000
[ 4.021041@3] meson-mmc: [mmcblk0p03] cache offset 0x000006c00000, size 0x000046000000
[ 4.021134@3] meson-mmc: [mmcblk0p04] env offset 0x00004d400000, size 0x000000800000
[ 4.021146@3] meson-mmc: [mmcblk0p05] logo offset 0x00004e400000, size 0x000000800000
[ 4.021156@3] meson-mmc: [mmcblk0p06] recovery offset 0x00004f400000, size 0x000001800000
[ 4.021166@3] meson-mmc: [mmcblk0p07] misc offset 0x000051400000, size 0x000000800000
[ 4.021175@3] meson-mmc: [mmcblk0p08] dto offset 0x000052400000, size 0x000000800000
[ 4.021184@3] meson-mmc: [mmcblk0p09] cri_data offset 0x000053400000, size 0x000000800000
[ 4.021194@3] meson-mmc: [mmcblk0p10] param offset 0x000054400000, size 0x000001000000
[ 4.021203@3] meson-mmc: [mmcblk0p11] boot offset 0x000055c00000, size 0x000001000000
[ 4.021212@3] meson-mmc: [mmcblk0p12] rsv offset 0x000057400000, size 0x000001000000
[ 4.021222@3] meson-mmc: [mmcblk0p13] tee offset 0x000058c00000, size 0x000002000000
[ 4.021231@3] meson-mmc: [mmcblk0p14] vendor offset 0x00005b400000, size 0x000010000000
[ 4.021241@3] meson-mmc: [mmcblk0p15] odm offset 0x00006bc00000, size 0x000010000000
[ 4.021325@3] meson-mmc: [mmcblk0p16] system offset 0x00007c400000, size 0x000074000000
[ 4.021336@3] meson-mmc: [mmcblk0p17] data offset 0x0000f0c00000, size 0x000d7ec00000
[ 4.021422@3] meson-mmc: [mmcblk0p18] CE_STORAGE offset 0x0000f0c00000, size 0x000d7ec00000
[ 4.021510@3] meson-mmc: [mmcblk0p19] CE_FLASH offset 0x000e6f800000, size 0x000020000000
[ 11.440431@3] EXT4-fs (mmcblk0p18): couldn’t mount as ext3 due to feature incompatibilities
[ 11.446854@3] EXT4-fs (mmcblk0p18): mounted filesystem with ordered data mode. Opts: (null)

screenshots of “dmesg | grep mmcblk”:

screenshots of “ceemmc -v”
image

P.D: With the last nightly, it already installs me without problems in single boot

But the single installation is still missing the dto partition.
I just pushed a update and it will be available tomorrow on next nightly.
Best would be recover the box by an Android image and install tomorrow again as the dto partition should then be included.

Now I wear, do you want me to do some test?

Would be nice if u can recover your box with Android and then do again a single mode installation.
Run the tool with ceemmc -vx and post the complete output when finished.

Ok, I’m done and start without problems in single mode. I leave here the output of the command:
https://pastebin.com/HfGGypsS

Nice, thank you. Looks like expected!

Hello everyone I have a problem with an H96 max x2 I can not run coreelec I do not know if it will be the tree tested with
g12a_s905x2_4g
g12a_s905x2_4g_1gbit
and tested with coreelec CoreELEC-Amlogic-ng.arm-9.2-nightly_20191118-Generic
and other
CoreELEC-Amlogic-ng.arm-9.2.0-Generic.img
and it does not work
could you pass me one that works with the H96 max x2

Did you read the 1st few posts?

Hi.

I have just received an H96 Max X2 4/32 and I am trying to install CE on it.

I recorded the last ng Generic nightly with Rufus 3.8. Later, copy the g12a_s905x2_4g.dtb as dtb.img in the root directory, as well as the remote.conf.

Then, I inserted the toothpick in the AV hole, I turned it on, but CoreELEC does not boot up.

Instead, a screen saying:

Android Recovery
Amlogic/u214/u214
9/PI/20190703

and a big Android robot in the middle, with an red exclamation mark saying “No command”.

I tried with 9.2.0 stable and g12a_s905x2_2g.dtb, but the same result.

What am I doing wrong?

Thanks!

bazzle
I have read it a few times but there is no way the USB turns on turns on TV turns off USB light black screen and nothing

Descripción del producto

Configuración del sistema:
CPU: Amlogic S905X2 Quad Core
GPU: ARM Dvalin MP2
RAM: 4GB DDR3
ROM: 64GB eMMC
OS: Android 8.1
WIFI: 2.4/5.0GHz IEEE 802.11 a/b/g/n
Codificador de video:H.265
HDMI:HDMI 2.1up to 4K2K@60FPS
Bluetooth:4.0

I have it running too, and installed correctly in single mode.

I advised that boot time is higher than usb boot, it takes a lot of time now. Once booted all is running fine.

FYI I have a S905X with CE on internal, and it’s very fast booting from internal, faster than usb.

What could be the reason? Can you check this or can I help you with some test?

That’s because of the boot priority: SD, USB, eMMC.
The bootloader have a 5s timeout for USB devices. That’s a security reason and will not be changed as this boot priority is need in case of recovery.

Thanks for your quick response.

Sorry I haven’t explained correctly I think, the time to start coreelec to boot with the priority times it’s correct, I am refering to the time that once appears the CE boot splash screen to when CE it’s fully started.

In the 905X it takes a few seconds, and with the 905X2 it takes a minute or more sometimes.

Sorry, does anybody know why my H96 Max does not boot from the uCard, but comes to Recovery saying “No command”?

I tried flashing it with Wind32Diskimager with the same result.

What am I doing wrong?

Thanks!

Have you tries a different uSD card sometimes they are not compatible. Are you saying it boots from USB but not uSD or have you not got it to work with CE on either.