H96 Max S905X2 working Coreelec

This one:
CoreELEC-Amlogic-ng.arm-9.2.0-Generic.img.gz

dtb:
g12a_s905x2_4g

Will try this tomorrow.thx mate

Hello mate
Yes i found the reset but that was not needed if u used the Android terminal with the reboot update command at least once.
I already used the images suggested by pinkytt and still no luck.even tried another ad card but same outcome.will try the 2gbdtb i got suggested but i am sure i have 4gb as i checked my storage

thanks for all the advice but I give up. I already had the correct CE and I tried every device DTB file like 4gb and 2gb nothing works.
U can see the bios of h96 x2 and than black screen

Thats unfortunate.

Can you try Coreelec from an USB?

That’s strange. Maybe you should check in adroid if yours box have s905x2 cpu. My colleague recently bought some Android box that should have Amlogic cpu, but it was fake with Rockchip. In case of Rockchip RK3328 (I don’t think it should have better cpu) you can try Libreelec.

Another noobie here…
Installed CE and it works fine, but…
Can’t install any addon/skin, all it does - failing…
Been 10 times thru all settings can’t find a setting what will cure this stupid error…

Please who is waking me up with the right answer…

Greetings from a sunny but cold Holland

Koos

As I cant either.
Not bothering me though.
Post up on the more general area of this site maybe>

https://discourse.coreelec.org/c/help-support

Guys, what about swapped blu/red led? Any progress (nightly builds or script)?

Not really. It’s probably a DTB issue, and we currently only have generic DTBs for the S905X2 boxes.

Please help. You write that NG builds doesn´t support installtointernal command in H96 max x2. but I have installed 9.2.0 stable from CE download page. If I run this command it returns:
-sh: installtointernal: not found
I have CoreELEC (official): 9.2.0 (Amlogic-ng.arm) on SD card now. Any idea?

You need to use latest nightly and read ceemmc guide:

Hi, I know the function is not officially supported. But when I try to make a single boot mode. Give this error and do not install it in emmc. Even if you continue corrupting the Android emmc but do not install it.

The error is “Could not find” dtbo “partition”, then I leave some screenshots:

Before installing.
image

When the installation begins.

P.D: The dual boot mode works without problems.

dtbo partition is part of the system on VIM3(L) so it search for.
Use dual-boot now until it get fixed.

Please boot your device enter SSH console and enter: dmesg | grep mmcblk and paste the output.
Or start the the tool like ceemmc -v and post the output.

@SamWilson, try latest(today) nightly and check if single boot works now.
Also please upload info requested by Portsch

OK, what now? (H96 max x2)

CoreELEC (official): 9.2.0 (Amlogic-ng.arm)
CoreELEC:~ # ceemmc
-sh: ceemmc: not found
CoreELEC:~ # ceemmc -h
-sh: ceemmc: not found
CoreELEC:~ # ceemmc -x
-sh: ceemmc: not found
CoreELEC:~ #

Should I also use latest nightly NG or non ng?

Please could anyone gives correct and straight answer? I have H96 MAX X2. You wrote that NG build does not has installtointernal nor ceemmc. But I can´t use non NG build for this device (there is no DB for this device in non NG build). So it means I just have no possibility to install CE internally on this device? Thank you for explaining.

Answer is the same as in my previous message:

9.2.0 is not nightly

Thank you. https://relkai.coreelec.org/CoreELEC-Amlogic-ng.arm-9.2-nightly_20191113-Generic.img.gz is the right version for H96 MAX X2 ?