H96 Pro first boot

First boot, doesnt continue in the configuration screen, choose the name press next and doesnt continue… anyone knows the reason, i format and change the dtb files the one 2gb ram and 1 gb network, and 2gb only not luck

Have you added a remote configuration?

Remote works fine? i change the name … I tried also use a keyboard and nothing can get click in the next button on the screen

Which device do you have and which dtb did you use?

h96 pro i used gxm_q200_2g

Your chip ?? S905 / S905x / S912 / ???
Ethernet 100 or 1000 ???

CPU: S912 Octa core ARM Cortex-A53 CPU up to 2GHz (DVFS)
GPU: ARM Mali-T820MP3 GPU up to 750MHz (DVFS)
Memory size: 16GB
Storage extension: Support MicroSD(TF) ,Up to 32GB
Wifi: 2.4GHZ/5.8GHZ 802.11a/b/g/n /ac
Ethernet: Ethernet 100M/1000M
Bluetooth: BT 4.1

Also when i boot i can connect using ssh…
first screen press next not problem
second screen change the name no problem when i want press next doesnt do anything


Are you booting via SD Card ??
Please disclose details of the SD Card.
Brand etc.

@javcarbe you really have to elaborate more in your posts if you want us to help you, help us to help you.

I’m guessing by ‘deb’ files you mean dtb?

Have you tried gxm_q201_2g?

I tried both sd cards

SanDisk - Ultra 32GB microSDHC Class 10 Memory Card
PNY 64GB Turbo Performance Flash Memory Card - Up To 90MB/S Read Speed, Class 10, MicroSDXC - P-SDUX64U190-GE

No I didnt try gxm_q201_2g. But i tried
same situation
I will try later other dtb file…
I go inside the folder and copy the dtb to the root, then rename dtb.img that is the correct process or i need move the file and rename it.

I can’t get any log, because i can’t pass the first screen. But i can SSH; is any command i can use to skip the first screen (setup screen)

Yes Logfile Advanced

I used a diff program to copy the img file (rufus) now boot, the new problem is when i want copy the advacesettings i got this message
disk is write-protected
I did something wrong?

That means files can not be written, that would explain your problem.

How can I fix this problem, the sd card works fine with my computer?

What on earth are you doing ? Copy img file ?
BURN IMAGE. What image of CoreELEC are you talking about this time ?

Working ?? Working what ? You better read from the start on how to burn CE Image and choose correct device tree for your hardware or we are not going to get anywhere understanding what you are doing.

Download the relevant img.gz file NOT the tar

Use rufus to select & burn the file. to create the image. In the root folder there will be a folder of device trees, copy the one you need to the root of the sd card, rename it to dtb.img

Then while pushing in the reset button, plug the power lead in, after a few seconds release the reset button.

if it doesn’t boot, try copying a different device tree, no need to burn a new image

i used Win32DiskImager is the program i used to create the sdcard, never pass the first screen (coreelec configuration screen), the rufus created the sd card and boot pass the first screen(coreelec configuration screen).
the image i used is CoreELEC-S912.arm-8.95.1.img

i explain when i tried to copy something in the sd card (using the network) got the error disk is write-protected how can i fix this problem