Hardkernel Wifi Module 5B not working (Odroid-N2+)

Hi there!

Brand new Odroid-N2+ user here having just got my unit last week. Had installed the latest CoreELEC Matrix stable image and everything working okay. I purchased the Hardkernel wifi and bluetooth module along with my unit, but it doesn’t seem to be working/CoreELEC does not recognize it. I have bluetooth enabled in the CoreELEC settings as well. The adapter itself works (both Wifi and Bluetooth) as I tested it out on the same unit but running off an Ubuntu image.

May I ask if this module is supported? Any chance I can get it to work?

To add: I just tried these instructions mentioned by a previous user, and created an autostart.sh file via SSH.

Rebooted, still did not work. I also tried using chmod to give execute permissions to the file but it still did not work.

When I try to boot with the wifi adapter plugged in, coreelec boots but it gets stuck in the splash screen. When I unplug the adapter, it immediately resumes loading/booting into kodi.

Here are the logs, hoping someone can help and point me in the right direction.

http://ix.io/3sjh

Output when I run lsusb with the adapter connected:

Bus 002 Device 002: ID 05e3:0620 Genesys Logic, Inc. USB3.1 Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0bda:1a2b Realtek Semiconductor Corp. RTL8188GU 802.11n WLAN Adapter (Driver CDROM Mode)
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Do you have ssh enabled? If yes boot with adapter attached and after a minute or two open ssh session and post url you get

paste /storage/.kodi/temp/kodi.log
paste /storage/.kodi/temp/kodi.old.log

Hi, I waited a little longer for good measure and to my surprise this time around it booted. Not sure what happened, or if it just needed a couple more minutes to initialize/run. That might be an error on my part as I was expecting it to work right away…

Anyway, the wifi is working now, but it still can’t seem to detect the bluetooth.

Here you go:
http://ix.io/3sju
http://ix.io/3sjv

How long does it need to get into Kodi? Almost 3 minutes?

Can you try to remove and insert adapter, run modeswitch command and restart Kodi? Is BT visible then? And how long does Kodi needs to start this time?

system kodi stop
usb_modeswitch -KW -v 0bda -p 1a2b
system kodi start

I noticed when I removed and inserted the adapter back in, it’s back to not being recognized. Have to run the modeswitch command manually for it to recognize again.

So I timed it now and from boot to my Kodi screen (note I still have the autostart.sh script present) it takes a little over 1.5 mins. Wifi OK, BT still not working.

usb_modeswitch must be run on every boot or every time adapter is attached.

I see, thank you. Is there any way to troubleshoot the bluetooth portion or is this module in particular not fully supported at this time?

You can post dmesg after wifi is recognized?

dmesg | paste

I’m not familiar with such devices and don’t really know how to proceed.

http://ix.io/3smc

Run this two commands and reboot. Check if BT is working. If not post dmesg again.

mkdir -p /storage/.config/firmware/rtl_bt
wget -O /storage/.config/firmware/rtl_bt/rtl8821a_config.bin https://linoskoczek.eu/files/rtl8821a_config.bin

I have an identical problem with the new model 5B wifi usb adapter. I solved the problem in the same way with the autostart.sh script. Whether this is the only way or in future upgrades we can expect native coreelec support for this adapter.
The adapter is working for now, but the boot and shutdown is slowed down

And what commands are run?

Firmware download must be done only once. When this will be confirmed to work the firmware will be added to CE.

The first thing I did was install Addons> System Tools

and then I created the autostart.sh script and placed it in the config directory with the following contents

system code stop
usb_modeswitch -KW -v 0bda -p 1a2b
system code start

I also tried with two commands in the post above for BT and it doesn’t work.

For information, I don’t even need BT, so I tried to turn it off, but it also doesn’t work.
The system takes more than one or two minutes to boot

So we are talking about 2 different issues.

Sorry I wrong quote the script. The following is correct if it means something

#!/bin/sh

(
usb_modeswitch -KW -v 0bda -p 1a2b
) &

Tried the two commands and did a reboot, bluetooth portion of adapter still not working

http://ix.io/3oCV

You use a one year old image, update first to last stable 9.2.7 or better 19.2-Matrix_rc2 and make a log with clean fresh install. CE-19 do have more WiFi/BT support then 9.2

Sorry I am not sure what you mean? Just checked my setup and went to coreelec settings->about page and it says I am already on 19.2-Matrix_rc2. I just set up the unit earlier in the month and pulled the latest stable image from the download page.

I just ordered the same module (5B) and running into the same issues. Will update if I can get it going :slight_smile:

About | FAQ | Terms of Service | Privacy Policy | Legal Notice