HDR Problems on S912 and S905

I am really struggling to get HDR videos to play correctly.

I have had a s905 and now have a s912 and on both of these devices HDR content is a lot darker and less detailed than when viewing the exact same files played through the LG Plex app on my LG B7 tv.

Pausing on the same scene on both sources and switching between them you can clearly see how much brighter and more detailed the image is on the built in tv plex app.

I have tried your CoreElec build, Kszaq’s build, and OpenPHT 1.9 by Veisen based on Kszaq’s libreelec build.

When comparing between the 2 sources I have used the technicolor expert picture setting for both sources and gone through and made sure EVERY setting is exactly the same.

I have tried using the

echo “echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr” >/storage/.config/autostart.sh

Nothing works.

I read somewhere the the s905 boxes do not put out true 10bit and it is converted somehow but the s912 does put out true 10 bit so i bought one of those but have the same problem.

I just read somewhere that the new test builds of libreelec here http://test.libreelec.tv/ are better but i have not had much luck getting them to boot yet.

What is different in these to yours ?

HDR is an ongoing issue and is not the best on Amlogic devices, the kernel used by the LE test releases is newer than the kernel we use in CE and is better for HDR however it has a number of audio and video related playback issues.

It is one of the issues we are looking at as well as having the colour space change automatically to 444,10bit upon detection of BT2020 content.


Thanks 4 the quick reply

That is kinda the conclusion i was coming to which is a shame but i am still quite new to all this and would love if you could clear a few things up for me.

A… is there actually a difference between s905 and s912 when it comes to outputting 10bit ?

B… Can the Rockchip devices like the Rock64 do a better job of HDR than AMlogic or are they still limited by the kernel ?

C… What in your opinion is the best device and OS for playing HDR content now and also in the future when the new kernel is more stable.

D… Is there any plan for to add support for the Rock64 in CoreELEC ?

E… Any ideas when the automatic colour space changing and real HDR support are coming ?

F… How long is a piece of string ? :slight_smile:


I can answer some of your questions.

A) The S912 has a proper 10bit pipeline for HDR other S905 devices are doing some dithering.

B) I have no idea with Rockchip devices however someone more knowledgeable may be able to answer this.

C) Any personal opinion would be biased and each device and each OS/build has it’s own pro’s and con’s at the present, however saying that the future looks promising with the shift to a mainline kernel and I would say the S912 device is better on paper but if it does not get the necessary Mali blobs then it won’t be usable in the future.

D) There is some interest in adding Rockchip builds but I’m not 100% sure on the plans at the moment.

E) No ETA, we have it almost working though.

F) That depends how long you cut it.

Rockchip devices like the Rock64 can’t do HDR in either LibreELEC or CoreELEC as of today unless there is some secret unreleased proof of concept.

Hi there,

maybe this dark problem is sometimes bad hdmi cable or tv?! I have a Sony KD-65XE9305 and a Denon 4K HD Receiver. My S912 and S905x boxes goes through that receiver to the TV. And i must do the picture in HDR mode a little bit darker, cause for me its a little to bright with the normale HDR settings on my tv. So i think that it is not really a CoreElec / LibreElec problem… i never had any problem in the last builds with darker HDR pictures. BTW i use two S912 (H96pro and Beelink GT Ultimate) and S905x (somthing cheap boxes with 2GB from china ;)) )


1 Like


I have a LG B7, and I have no problem with any of my S905X boxes getting HDR to look right. I have both Kszaq’s built and the latest CE and both look fine.
When you start a video, does the TV even switch into HDR mode? In LG TVs, every input can have different picture settings, so perhaps you need to do some tweaking.

Edit: It’s important to note the S905 doesn’t support HDR, only the S905X and newer SoCs do.

I had also problems to boot the S905-version from http://test.libreelec.tv .

My Beelink S905X-box is connected to my Bose Soundtouch AVR and the AVR to my 79UF8609 (4K-TV), all connections with 18Gb/s quality HDM-cables.

Booting the CE-versions makes no problems (but dark HDR-picture).
Booting the S905-version from http://test.libreelec.tv stops after the LE-splashscreen.

Booting is ok for me, when I connect my Beelink-box to the TV-HDMI-input directly (skipping the AVR).
Then I change the default Kodi-GUI resolution from 3840p@60fps to 1920p@60fps .
After that booting works with my original configuration (with AVR).
But there is no display playing UHD-videos with more than 50fps. Only UHD@24fps or UHD@30fps work.
But these HDR UHD-videos show better colors (are brighter) than the latest CE-versions.
But I stick with CE because LE has other drawbacks.

So for me something has changed in HDMI-synchronization between the old 3.14 kernel used by CE and the new one used by LE.

I have tried playing HDR using Kodi directly from my similar Sony TV and the issue is the same; washed out colours but the file hardly plays, so it doesn’t appear to be a media box / CE issue.

Thanks for all the replys everyone

I think some of you are slightly confused though by what i meant.

The HDR videos play back fine, they activate HDR on my b7, the colours look fine and the image quality looks ok too.
The image doesn’t look paticuarly dark if you have nothing to compare it to.
When I pause the video on a brightish scene and compare that exact same scene with the image from the built in plex app on the tv by switching back and fourth between sources, it is clearly visible that the image the s912 produces is quite a bit darker and less detailed than the one from the LG plex app.

This is not an issue with hdmi cables, i have tried a few different ones which are all brand new 4k hdr capable.

It is not a issue with tv settings as both sources are set up EXACTLY the same like i said in the 1st post.

The s912 has been connected directly to the tv and also connected to the tv through my Denon x3400, and yeilds the same results either way.

adamG in his reply confirmed this is a software issue with most if not all kodi embedded builds for AMlogic devices and probably other devices too.

Hopefully the software improvements regarding HDR will come soon.
And maybe those of you with LG oleds can expirement for yourselfs.

Thanks pepeq.
I will defiantly give that a try !

When i tried the librelec test build i was also going through my AVR.

I read somewhere that another solution may be to do the whole holding the reset button while booting thing again to reset the bootloader.

I’ll try both options over the weekend and report back.

Make sure that you have Dynamic Contrast set to Low in both HDMI and ‘Smart’ inputs.
I have a B7, and everything I seen so far looks identical when I do a side by side comparison.

If you have a specific scene in mind, let me know what to check and I will just to make sure, if I have it.

  1. Congratulations, with 8.90.2 the colormapping of HDR-scenes looks much better for me!.
    The too dark pictures I had with my 4k-HDR-movies have now nearly the same brightness as the same scenes in the non-HDR version of the same movie.
    It looks the same as in the LE-devel versions I mentioned in my last posts.

question to developers: what has changed compared to 8.90.0/1?

  1. the key-mapping of my Harmony-remote works as before.

  2. booting seems to be faster

  3. 3D-autoswitching works when starting a 3D-movie. But after stopping the 3D-movie the GUI stays in 3D-mode (3D-mode is not deactivated). The TV does not get the signal to deactivate the 3D-mode and there is also no info from the skin, that 3D-mode is deactivated. Automatic 3D-deactivation is set in Settings. When then a 2D-video is started, a message that no 3D-signal was found and the 3D-mode is deactivated.


1 Like

@pepeq we made absolutely no changes that would affect HDR so dramatically.

There is a minor changelog posted with each release but it is difficult to go into great detail and we try to keep thing’s simple and easy to understand for people so we just list the most relevant changes.

As for your 3D issue I would ask that you open an issue on GitHub or a separate thread for any issues experienced as it is difficult to keep track of bugs on the forums even more so when the thread title is ‘HDR problems’ and not ‘3D problems’.

@anon88919003: sorry to put the 3D-problem in a wrong thread.
I will open an issue on GitHub soon.
I really appreciate your hard work (and ofc the work of the other developers)! :smiley:

1 Like

@anon88919003: Can any of the changes made affect the old HDR flickering problems reported and resolved time ago?
I mean, in 8.90.1 those problems where gone, as expected, but they returned in 8.90.2.
HDR flicker appears when in 444:10bit mode, very anoying.

In these threads they reported problem solved (tested by myself with your releases), almost for flicker, banding still present but mitigated with some manual tweaks.


I’m sorry but we made absolutely no changes to anything relating to HDR between .1 and .2.

I own a KIII Pro (which is powered by S912) and I watched HDR 4K movies on my Sony Bravia both on 8.90.1 and 8.90.2 and I have not noticed any differences between versions or any other issues with darker/dimmed image. So this can be what others are saying - your TV or its settings. These new TV’s have a lot of image processing options that could affect you.

Take a look at this clip with 444,10 bits enabled (echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr)

With my Sony OLED KD55A1 it’s now showing flickering, when it’s not happening with 8.90.1 so anything is broken in this release.
Same TV, same cable, same S905X box…

@anon88919003 I’m not telling you made changes in HDR, but maybe something is reverted back anywhere.
I don’t know exactly if these can make a difference, but OSMC team made some changes for fixing this, and in fact they worked in LE/CE till now.
In current LE release it’s fixed and now it’s broken in CE.

The banding fixes by osmc have never been in CE or LE.

The only major change in .2 was IR everything else was minor bumps to packages.

I don’t know how you are experiencing different behaviour between the 2 releases.