Homatics Box R 4K Plus

I used the following procedure:
Create a file with the content provided in my last comment and name it NOKIA.
Use Filezilla and copy this file in /storage/.config/rc_keymaps/ on the device.

Create a file named rc_maps.cfg with the following content:
meson-ir * NOKIA

Use Filezilla and copy this file in /storage/.config/ on the device.

Open SSH connexion to the device and:
systemctl stop kodi
systemctl stop eventlircd
ir-keytable -a /storage/.config/rc_maps.cfg -s rc0
systemctl start eventlircd
systemctl start kodi

Enjoy, hope this will work for you.

Just copy the file and reboot - no need for all those ssh commands.

Hello vpeter, thanks for the info :+1:

Thank you for your answer

Everything works.

1 Like

got my homatics box yesterday and now trying to boot coreelec.

However I am unable to boot coreelec.

USB stick create commands:
dd bs=1M conv=fsync if=./CoreELEC-Amlogic-ne.aarch64-20.3-Nexus_nightly_20230729-Generic.img of=/dev/sdb
cp sc2_s905x4_4g_1gbit.dtb …/dtb.img

Pressing reset when plugging in power gets me to boot screen which says.
Press RESET again to enter Recovery mode.

Have tried 2 different USB sticks. ANyone has any idea what can be wrong?

Wrong dtb. Try proper one

Which is the proper one then ?


EDIT: Tried sc2_s905x4_sei_smb_280.dtb aswell, but same issue.

keep it pressed until you see coreelec logo

I let go to early…

Got to the coreelec boot logo,
But it’s stuck at …zing file system / (Can’t read begining of text it’s outside of screen, comprezing?).

Have a Kingston DataTraveler Micro 3.1 stick, so shouldn’t be this slow. Has been sitting there for a couple of mins now… Can’t remember it was this slow on sd card’s.

EDIT: Got it up and working and DV/HDR seems to be working fine… However does anyone have any fast USB stick to recommend?

Samsung (Fitplus) 3tnica the 64gb ones there tiny but fast

will order one. Everything is extremely laggy with the current one.

Can usb drive speed affect smb browsing speed? Browsing kodi menus seems fast enough, but browsing an smb is a bit slow. Also, I didn’t notice this on earlier versions of CE, 06-28 and earlier.

Edit: it was better today, didn’t notice lag in smb browsing

Sei is the proper one :stuck_out_tongue_winking_eye:

just as an update for others.

today i had to setup a dmz vlan for other reasons and before deleting it decided to make a google account and check if my box had an upgrade available.
it hast not. androidtv its stuck at version 11.8.4674 (which i guess is what it shipped with since android says its security patch level is from February 2023)

Do you guys know of and status update regarding the homatics firmware with fixed DV ?

I do a (edited) copy/paste from a Homatics Telegram channel, were I posted this info a wile ago.

There is a story to be told over the updates for the Homatics R Plus (not Dune). I got this info from my Homatics contact.

Not all updates are controlled by Homatics for the boxes, sometimes a distributor has a say on the update program. I still had one R Plus on V4674 and it did not get the update, Homatics said the update was pushed to all users (that are known to them). All my other R Plus boxes got it by OTA (I have a total of 5 from them).

I received a new R Plus box on last Tuesday and during setup, V5310 was pushed as update. So as it should be.

But my first box came from a Dutch shop, and I guess from a distributor, Homatics is speaking of, still no update for that one. So I requested a update on serial of the box and got it.

So if the box comes from a (big) distributor (not Homatics), it could take longer for the update to arrive.

thank you for your reply.
And really scary to read that hardware distributors have some sort of control over software.
Yet another reason i wont trust androidtv.
As soon as the firmware is upgraded ill reset atv before it gets back into my media vlan.

I cant even think of any good reason why anybody else beside android and the devs of homeatics should have any say in the software matter …

I followed the advice and emailed them my serial number. hopefully that helps.

Thank You Friend for the help, can You please help me with this doubt should the file NOKIA have the extension .cfg or .hwdb
Thank You Friend and have awesome weekend.

Found some bugs(maybe known already?)
Homatics is connected to receiver.

  1. If power on(inserting power plug) the device will not send CEC signal to power on receiver/TV. If waiting to long to turn on TV a broken image will be displayed and need to reboot reinserting power plug.

  2. Homatics box goes to sleep when turning of TV/reciver. However when turning on TV, box will not wakeup from standby.

Don’t think it’s possible to get any logs for this… With Android TV above is working.

1 Like

No extension for the file NOKIA :wink:

This aren’t bugs, it’s config items.
And connect the device directly to TV as AVR are known to cause CEC/EDID issues.