How might I be able to turn system 'ON' from an 'OFF' state with my IR remote?

Is this possible?

What steps might I take? Is it as simple as a keymap edit? Thanks guys!

Currently using N2 with latest stable release 9.0.3.

Thanks again!

All you need is to do a search or look in the guides section. It’s there for a reason, enjoy:

Thanks so much for this!

One quick question,

Where it says “Press now the desired button on your IR remote” …

Is it possible to utilize a long press alternatively? Or is this just a limitation of the method?


Long press to turn on your N2 doesn’t make sense.

I have an N2 as well. I setup mine to use a silver apple remote from my old apple tv. There is no power button on the apple remote. Can I just use any button from the apple remote (like the center button) to wake the n2 without causing a problem for that buttons regular function when the n2 is up and running?

You can use any button.

so, I just tried the instructions.

when I press the button I want to use, I get this:

CoreELEC (official): 9.0.3 (Amlogic-ng.arm)
CE-N2:~ # systemctl stop kodi
CE-N2:~ # systemctl stop eventlircd
CE-N2:~ # ir-keytable -u
Protocols changed to irmp
Waiting for IRMP decode event. Please, press CTRL-C to abort.
Received IRMP code: scancode=‘0x005d00de’, IRMP protocol = 11, decode_type is undefined!
Received IRMP code: scancode=‘0xffffffff’, IRMP protocol = 11, decode_type is undefined!
Received IRMP code: scancode=‘0x000400de’, IRMP protocol = 11, decode_type is undefined!
Received IRMP code: scancode=‘0xffffffff’, IRMP protocol = 11, decode_type is undefined!

according to the instructions a implementation/code mapping for u-boot would be needed but there is nothing in the intructions on how to do this.

I did try every other button on the remote as well but none of them gave the response that could be used in config.ini (assuming I’m interpreting this all correctly)

Is it complicated?

It seems that protocol is not supported. Try with another remote.

Got it working thanks!

So I didnt need a long press, the single button will be mapped to “power on” when n2 is off, and it can be mapped to another command once the n2 is on. Thanks!

1 Like

Ugh. So, I’m not having any fun with this right now and could use a bit of help.

So, i have my apple silver remote working perfectly to navigate Kodi but it does not have a power button to wake or power on my n2 and apparently i can’t use it for that purpose even if i just try and use any button.

So i went through my box o’ goodies and found another remote. It’s a zotac mce type thing. I tested the power button on it and got my n2 happily waking and powering on with that. Then I tried mapping all the other buttons and creating a rc_maps.cfg and and rc_keymaps file for it but after i got it all done i have to press every button twice to make anything happen.

Any ideas? Is there a fix?

Nevermind. I think I have discovered the problem. This stupid remote bounces between 2 codes for each and every button.