How to configure VFD

Try this one.
hk1-rbox-x4-vfd.conf (1.3 KB)

If it doesn’t work, try to change
And reboot

Also, don’t post the whole kodi log, just use dmesg | paste from SSH.

Sorry, I just looked at the code, and it seems that the driver doesn’t support hardware I2C communication with these controllers.
You’ll have to disable the I2C interface in the DTB and then you should be able to use the conf file from my previous post here: How to configure VFD - #654 by TheCoolest

Thanks I will try a new dts later. Here are the full logs again, I thought you might what to see the python error in OpenVFD

That is expected behavior.

Here is the dtc output of the dtb I created that still doesn’t work. i2c disable dts - from what I can tell the only change from stock is i2c@6a000 is now also disabled.

You can use fdtput to set /soc/apb4@fe000000/i2c@6c000 status to disabled

mount -o rw,remount /flash
fdtput -t s /flash/dtb.img /soc/apb4@fe000000/i2c@6c000 status disabled

Just tried that, no change even in the dtc output.

Not dtc output. Use the normal dtb file, run the command and try the vfd from this post

I was only using dtc to see the changes. stock dtb.img with the ftput no changes here is dmesg

You didn’t use the correct vfd.conf file.

1 Like

CoreELEChk:~ # curl -o vfd.con
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1189    0  1189    0     0    796      0 --:--:--  0:00:01 --:--:--   796
CoreELEChk:~ # diff vfd.conf .config/vfd.conf
CoreELEChk:~ # sha256sum vfd.conf .config/vfd.conf
02f15edcd889504ff2c0363c7bf6b4706a78fcfcaa4405323cafee9f93932c1f  vfd.conf
02f15edcd889504ff2c0363c7bf6b4706a78fcfcaa4405323cafee9f93932c1f  .config/vfd.conf

Redownload it from the PC.

[   22.993247@1]- OpenVFD: vfd_gpio_clk:		#0 = 0x00; #1 = 0x00; #2 = 0xFF; 
[   22.993884@1]- OpenVFD: vfd_gpio_dat:		#0 = 0x00; #1 = 0x00; #2 = 0xFF; 
[   22.994675@1]- OpenVFD: vfd_gpio_stb:		#0 = 0x00; #1 = 0x00; #2 = 0xFF; 

means you’re running the vfd file with the hw i2c config.

1 Like

Ok cool that could be the problem all along now I get the clock, plus ethernet and play/pause images. Thanks for your patience. I will try with stock for fun.

Edit stock without a change didn’t work.

1 Like

I pushed the vfd to the repository, so thanks for helping with getting this device added.
We’ll update the VFD wiki to reflect the required changes to the DTB.

1 Like

Hi The Coolest. Long time since we last spoke so hope you are keeping well. I have just recently brought a Tanix X4 S905X4 4GB box and installed the latest compatible CE 19.5 rc2 firmware. The no BT or WiFi problem I have responded to elsewhere with an SSH paste result. But turn to you here as I would like to get the front panel display working in CoreELEC. I’ve tried various VFD.CONF files all without success.

So can you refresh my memory as to what I need to do to get help with the production of a suitable vfd.conf file, or is there already a suitable one available that I have not yet found ?? Do I need to SSH into CoreELEC or do I need to use some command in horrid Android with the terminal emulator app. Please help as this box seems excellent except it has only a 100Mb Ethernet port not gigabit as I expected. I am using the generic sc2_s905x4_4g DTB for this device with a standard 100Mb LAN port. The 1G Lan port DTB just will not boot at all into CE and seems the box is definitely only with a 100MB LAN port.

Hi, I’m good, thanks.
We can start by running the following command in Terminal on Android:
cat /sys/kernel/debug/gpio
That’s the easiest way to check for the pins. Next option would be to extract the DTB from Android, that could potentially have this data as well.
You can follow this guide, in most cases it works:

1 Like

I have a Tanix X4 and it works with the HK1 driver but like everything else on this box the display is upside down.

The are (no graphics) and the temperature is quite different from what Kodi shows and it is furnace.

Please show a pic.

1 Like

I tried the HK1 both X4 and X3 vfd files and neither work I still get a permanent 8888 display. So cannot understand how you got an upside down display ??

Hi TheCoolest

I installed the Terminal Emulator and tried that command line with and without a space after cat but I only get an error with file not found ??

Seems without any WiFi or BT drivers available for the Tanix X4 this box is a waste of money but at least I usually only use Ethernet connection but this is only 100Mb not Gigabit :frowning: