How to configure VFD

I finally found a solution to my problem. I reinstalled CE ng 20.0 instead of CE ne, and the display works correctly with the conf x96-max-ultra-vfd.conf in the post above.
Thank you.

1 Like

Používám CE20-NE na stejném boxu jako TY. A displej mi funguje.

Thank you for your reply Borec1. I did a NE installation from scratch and indeed it works and without installing OPENVFD. But anyway bluetooth does not work with NE, nor with an Asus BT400 dongle unlike NG. Is this also the case for you? Thank you

Bluetooth mi také funguje. Je třeba ho povolit. Udělal jsi to?

Yes i did it. It isn’t recognized, neither the dongle. The dongle is recognized by NG, but not the box BT

Hi. I have box BLOW: BLOW
I do not have the original firmware, I use modified sbx_x96mini_atv_9_3
I have copies of the BLOW partitions and from which I extracted the DTB (I made them once in TWRP).
I replaced the DTB (_aml_dtb.PARTITION file) in the slimbox firmware with AMLogicTools_V7.1.0_Donate with the original remote control it works again :slight_smile:
Unfortunately, the display does not work.

I installed CoreELEC 20.0 and try to run VFD but it doesn’t work. I am using gxl_p281_2g
OpenVFD service installed but probably not working:

Ă— openvfd.service - OpenVFD Service
     Loaded: loaded (/usr/lib/systemd/system/openvfd.service; disabled; preset: disabled)
     Active: failed (Result: exit-code) since Sat 2023-03-04 07:17:18 UTC; 10min ago
   Duration: 501ms
    Process: 3242 ExecStart=/usr/lib/coreelec/openvfd-start (code=exited, status=1/FAILURE)
    Process: 3294 ExecStopPost=/usr/sbin/rmmod openvfd (code=exited, status=1/FAILURE)
   Main PID: 3242 (code=exited, status=1/FAILURE)

Mar 04 07:17:17 CoreELEC systemd[1]: Started openvfd.service.
Mar 04 07:17:17 CoreELEC openvfd-start[3278]: modprobe: ERROR: could not insert 'openvfd': Invalid argument
Mar 04 07:17:17 CoreELEC openvfd-start[3287]: Open device failed.
Mar 04 07:17:17 CoreELEC openvfd-start[3287]: : No such file or directory
Mar 04 07:17:17 CoreELEC systemd[1]: openvfd.service: Main process exited, code=exited, status=1/FAILURE
Mar 04 07:17:17 CoreELEC rmmod[3294]: rmmod: ERROR: Module openvfd is not currently loaded
Mar 04 07:17:18 CoreELEC systemd[1]: openvfd.service: Failed with result 'exit-code'.

GPIO from Android:

gpiochip1: GPIOs 401-500, parent: platform/pinctrl@4b0, periphs-banks:
 gpio-422 (                    |mute_gpio           ) out hi    
 gpio-436 (                    |amlsd               ) out hi    
 gpio-449 (                    |amlsd               ) in  hi    
 gpio-486 (                    |sdio_wifi           ) out lo    
 gpio-487 (                    |sdio_wifi           ) in  hi    
 gpio-497 (                    |bt_rfkill           ) out lo    

gpiochip0: GPIOs 501-511, parent: platform/pinctrl@14, aobus-banks:
 gpio-503 (                    |key                 ) in  hi    
 gpio-505 (                    |fd655_dev           ) out hi    
 gpio-506 (                    |fd655_dev           ) out hi    

DTB partition from BLOW

Try this VFD.
blow-s905w-vfd.conf (1.2 KB)

Wow, you’re amazing :slight_smile:
It works but badly. Now I’m using CoreELEC 19.5 Matrix:

This should fix the time, but icons will probably not be correct.
blow-s905w-vfd.conf (1.2 KB)

Better and now the time works. I noticed that if the ethernet cable is connected, there is a colon between the hour and the minute. When I disconnect the cable the colon disappears.
The network icon flashes:

Can you check which icon lights up if you connect to wifi?

Wifi does not work - does not detect Wifi - only Wired connection.

Ok, try this:
blow-s905w-vfd.conf (1.2 KB)

Now it’s even better. There is only time and the colon is blinking :slight_smile:
How to set the time zone echo "TIMEZONE=Europe/Warsaw" >> /storage/.cache/timezone
the VFD display shows fine but Kodi is wrong about one hour earlier.

You can set it in the Settings → Interface → Regional

I didn’t have this setting - I changed it to Poland and now it’s OK :slight_smile:

1 Like

Hi there, I have a Wechip V9 S905X3 4GB (Wechip V9) and installed Amlogic-ng.arm-19.5-Matrix-Generic with sm1_s905x3_4g device tree. All works fine, except front display stays black, despite trying almost all S905X3 vfd.conf I could find. Seems as if something is occupying that gpio pin. Please help!

Here is GPIO from Android 9:

And here is the dmesg OPenVFD output using t95-max-plus-s905x3-vfd.conf:

6.395254@3]- OpenVFD: Version: V1.4.1
[ 6.395263@3]- OpenVFD: vfd_gpio_clk: #0 = 0x00; #1 = 0x4A; #2 = 0x00;
[ 6.395266@3]- OpenVFD: vfd_gpio_dat: #0 = 0x00; #1 = 0x49; #2 = 0x00;
[ 6.395269@3]- OpenVFD: vfd_gpio_stb: #0 = 0x00; #1 = 0x00; #2 = 0xFF;
[ 6.395272@3]- OpenVFD: vfd_gpio0: #0 = 0x00; #1 = 0x00; #2 = 0xFF;
[ 6.395275@3]- OpenVFD: vfd_gpio1: #0 = 0x00; #1 = 0x00; #2 = 0xFF;
[ 6.395277@3]- OpenVFD: vfd_gpio2: #0 = 0x00; #1 = 0x00; #2 = 0xFF;
[ 6.395280@3]- OpenVFD: vfd_gpio3: #0 = 0x00; #1 = 0x00; #2 = 0xFF;
[ 6.395282@3]- OpenVFD: vfd_gpio_protocol: #0 = 0x00; #1 = 0x00;
[ 6.395286@3]- OpenVFD: vfd_chars: #0 = 0x00; #1 = 0x01; #2 = 0x02; #3 = 0x03; #4 = 0x04;
[ 6.395290@3]- OpenVFD: vfd_dot_bits: #0 = 0x00; #1 = 0x01; #2 = 0x02; #3 = 0x03; #4 = 0x04; #5 = 0x05; #6 = 0x06;
[ 6.395293@3]- OpenVFD: vfd_display_type: #0 = 0x01; #1 = 0x00; #2 = 0x00; #3 = 0x06;
[ 6.395298@3]- OpenVFD: Detected gpio chips: periphs-banks, aobus-banks.
[ 6.395302@3]- OpenVFD: “periphs-banks” chip found. base = 410, pin count = 86, pin = 74, offset = 484
[ 6.395304@3]- OpenVFD: “periphs-banks” chip found. base = 410, pin count = 86, pin = 73, offset = 483
[ 6.395305@3]- OpenVFD: Skipping vfd_gpio_stb evaluation (0xFF)
[ 6.395307@3]- OpenVFD: Skipping vfd_gpio0 evaluation (0xFF)
[ 6.395308@3]- OpenVFD: Skipping vfd_gpio1 evaluation (0xFF)
[ 6.395309@3]- OpenVFD: Skipping vfd_gpio2 evaluation (0xFF)
[ 6.395310@3]- OpenVFD: Skipping vfd_gpio3 evaluation (0xFF)
[ 6.395333@3]- OpenVFD: can’t request gpio of dat_pin
[ 6.395350@3]- openvfd: probe of openvfd failed with error -22

Thanks in advance!

Which icons does this display have?
But try this one:
wechip-v9-vfd.conf (1.2 KB)

Wow it works! Thousand thanks.

I got a X96 Max+ Ultra 4GB RAM, 100Mbps Ethernet phy

It has 6 icons (going top to bottom, starting on left)

1st column

  1. USB
  2. CARD

2nd column
3. Top Half of WiFi
4. Bottom Half of WiFi

3rd column
6. Wired Ethernet

I am using x96-max-ultra-vfd.conf provided here.
I am booting from MicroSD and connect wirelessly
The display shows the clock correctly, and as for the icons, it is lighting up

  1. APPS
  2. The Bottom part of the WiFi icon

How to get it to show CARD instead of APPS and the full WiFi icon (if applicable). Thanks a lot for your continued support