How to configure VFD

I volunteered to configure a strange S905W2 TV Box called Leotec Show 2 432 of a friend. The original firmware sucked so much that it didn’t even allow me to insert the WiFi password.

Tried a custom rom (slimBOXtv for Vontar X2) but WiFi and VFD wasn’t working. Moreover, USB Burning Tool no longer detects the box, so now I can’t try different roms.

Fortunately I could install CoreELEC-NE and is working fine, the only thing missing is the VFD.

The VFD has the FD6551 chip. How can I find or make the correct vfd.conf for this strange box? I don’t have access to its original firmware anymore.

Can I adapt the vfd.conf of another box that also has the FD6551 VFD chip?


If you can’t install the original firmware, I don’t think it’s going to be easy.
I need to know what are the original pins used by the display, it’s only available in the original firmware.
If you manage to find the DTB file from the original firmware (where VFD worked) it is often enough.

1 Like

Thanks for the fast reply!

I already contacted the customer support and asked them for the stock firmware, then I’m going to try to flash the u-boot.bin with BootcardMaker, maybe this will make the box detectable again by USB Burning Tool.

Customer support sent me the original firmware.

I unpacked the firmware and then the _aml_dtb.PARTITION:

It has 3 files:

s4-s905w2-2g.dts (85.6 KB)
s4-s905w2-4g.dts (85.6 KB)
s4-s905w2-1g.dts (85.6 KB)

Is this enough to get the VFD working with your help?



	fd655_dev {
		compatible = "amlogic, fd655_dev";
		dev_name = "fd655_dev";
		status = "okay";
		clk_pin = <0x1d 0x2d 0x1>;
		dat_pin = <0x1d 0x2c 0x1>;

Is this what we need?

Yes, that’s a good find.
Looks like this config should work for you:
ltc-box42-vfd.conf (1.2 KB)

1 Like

Thanks it’s working!

Do you know if VFD is difficult to configure in Android?

In the internal memory I have the slimBOXtv firmware (for Transpeed AV1), the WiFi is working, but as expected the remote and VFD don’t work.

I know what files I need to change for the remote to work, but have no idea about the VFD.

I’m not sure about Android. The Android image must have the VFD driver built-in, and the DTB needs to have the correct configuration for it.

1 Like

So was looking around and saw a post where someone asked for help with a vdf file for there TX 3 mini.

They was told to boot to Android and run

cat /sys/kernel/debug/gpio

I have ran this and and this is what it says

If some can help that would be great and thank you for all the great work you guys n gels do.

I have just extract the dtb file files from the android that’s running on it with everything working if these help

Also can I use the dtb file I extract as is on CoreElec?

dtb.img (256 KB)

How to extract VFD driver from android and use it in CoreELEC ? Noob here haha

Why would you want to do that?

Try this one in CE and let me know if it works correctly or not.
tanix-tx3-mini-vfd.conf (1.3 KB)

because I have tried many VFD.conf for my X96 X4 box, not all symbols in the VFD works correcly.
I can say that because when I use OpenVFD app, in the setting there is toggle to turn ON/OFF some symbols and it does not work as intended. This is not a deal breaker for me but just curious where the VFD driver located inside android so I can try extract it and import to coreelec system.

You can’t extract it, in most cases it’s built right into the kernel.

1 Like

Goodnight!!! I’m from Brazil and I have a T95 Max Plus where I use the latest version of EmuELEC 4.6 Stable. Before, I was in EmuELEC 4.6 Test and the vfd.conf file of this TV Box worked perfectly in this test version. It was enough for me to update to EmuELEC 4.6 Stable that the vfd.conf file stopped working. On my Box panel the only information that appears are: CE4. Could you help me to reactivate the LED panel of my T95 Max Plus in EmuELEC 4.6 Stable? Thanks in advance for the help.

This isn’t the place to get support for EmuELEC, they have their own forum.

OK! I have a test version of EmuELEC that uses CoreELEC as a base. I immediately thought it would be the same system. I’ll look for the EmuELEC Forum. Thank you for your attention.

Everything is working great on X96Air but is there a way to show a progress bar while playing a movie?

A progress bar was not part of the plan, because I don’t know how a progressbar should look like on a 4 digit 7 segment display.


I’d like to ask for help. I have X96 Max+ TV box model 2101w. The string inside the box shows ‘Q5X3_141 V4.1 20112’.

It has the following controller: AiP1628.

I’ve tried different configurations from this repository GitHub - arthur-liberman/vfd-configurations: vfd.config - A collection of configuration files for linux devices with a front facing display..

However, the VFD does not show any time nor string when I try. Sometimes when I load the configuration I loose Ethernet.
Does someone have this model and the VFD working?

Any idea which are the correct pins? Based on the datasheet to the model it’s SPI driven.

Unfortunately I wiped the whole board and installed there postmarketOS that I’m porting there running mainline kernel and u-boot.

I did take screenshots of HW Info App but unfortunately I didn’t check the gpios.

Is there another way or do I have to find the proper image with Android and flash it there?

Also I assume the information is part of the image and the manufacturer puts the “right” image there, correct?

Also the mainline kernel I’m running is 6.3.3 and the kernel module for openvfd had to be changed a little as it wouldn’t compile.