How to configure VFD

Hey …
Is it possible to use the display on Dune HD premier 4k pro ? It’s the same like Homatics Box R4k+ but with display and 2,5 HDD bay …

I’ve tried some files from here but no success…
It’s my first box with LCD display and I don’t know how to configure it.

Need some help…

Hi, it should be possible.
Is the pic taken when in Android?
To be able to help I need the GPIO configuration of the box in Android:

If you can’t get that, then a DTB dump you can do from CoreELEC.

cat /sys/kernel/debug/gpio does not work or it really don’t exist…

I think the problem is …

When I boot the box first time , there’s no display working. But after I installed Dune hd Media Center the display appears. Maybe no general Android support with the display ?

Here the DTB …
dtb.img.gz (100.0 KB)

So what to do with that file ?

I think that this was brought up to me some time ago.
Dune has an Android app that they use to run the display. If memory serves, I couldn’t figure out exactly how it was configured.
Sorry for the delay.

A ok … Thanks for looking at…

I have tried most of the configs in this topic for my TX3 Max. Many work, but only the time is shown (no icons). I would appreciate some help.

You need to install the OpenVFD addon in Kodi.

Everything is installed as instructed.


Do you know if it’s possible to control the “led” on gt king II ?

CE Settings:
System LED

1 Like

If you found a tanix config where the clock works correctly, then the icons should work too. As long as the addon is enabled and the advanced settings are disabled.
You can also use the addon to set display brightness, try it and see it takes any effect or not.
Also, you didn’t even mention which version of CE you are on:

The main use of this box is to run EmuELEC. However, and since the documentation of EE regarding this issue is not enough, and after I found this topic, I prepared an SD card with CE 19.3 only to find out that the result is exactly the same.

# cat /sys/kernel/debug/gpio
gpiochip1: GPIOs 401-500, parent: platform/pinctrl@4b0, periphs-banks:
 gpio-422 (                    |mute_gpio           ) out hi    
 gpio-436 (                    |amlsd               ) out hi    
 gpio-449 (                    |amlsd               ) in  lo    
 gpio-474 (                    |?                   ) out hi    
 gpio-476 (                    |openvfd             ) in  hi    
 gpio-477 (                    |openvfd             ) out hi    
 gpio-486 (                    |sdio_wifi           ) out hi    
 gpio-487 (                    |sdio_wifi           ) in  hi    
 gpio-497 (                    |bt_rfkill           ) out hi    

gpiochip0: GPIOs 501-511, parent: platform/pinctrl@14, aobus-banks:
 gpio-503 (                    |key                 ) in  hi    
 gpio-505 (                    |openvfd             ) out hi


# This file must be renamed to vfd.conf and placed in the /storage/.config/ folder.
# Tanix TX3-MINI (S905W) configuration
# [0] 0 = &gpio, 1 = &gpio_ao.
# [1] pin number -
# [0] Reserved - must be 0.


# < DHHMM > Order of display chars (D=dots, represented by a single char)


# Order of dot bits. Typical configurations:
# Display Type 0, 1 usually has Alarm, USB, Play, Pause, Col, Ethernet, Wifi dots
# Alarm = 0, USB = 1, Play = 2, Pause = 3, Col = 4, Eth = 5, Wifi = 6
# Display Type 2 usually has APPS, USB, SETUP, CARD, Col, HDMI, CVBS dots
# APPS = 0, USB = 1, SETUP = 2, CARD = 3, Col = 4, HDMI = 5, CVBS = 6
# Display Type 3 Power, LAN, Col, Low Wifi, High Wifi
# N/A = 0, N/A = 1, Power = 2, LAN = 3, Col = 4, Low Wifi = 5, High Wifi = 6


# [0] - Display type.
# [1] - Reserved - must be 0..
# [2] - Flags. (bit 0 = '1' - Common Anode display)
# [3] - Controller.


#functions='alarm usb play pause colon lan wlan'
functions='usb colon eth wifi'

This will be my last reply to you on this topic.
You need to install the OpenVFD addon in kodi. If you see the clock, everything is configured correctly.

I have tried many conf. No Display, I need help!
I have an T95 plus with Amlogic S905x4 this one:
T95 plus

My cat /sys/kernel/debug/gpio on Android shows:

gpiochip0: GPIOs 425-511, parent: platform/fe000000.apb4:pinctrl@4000, periphs-banks:
 gpio-425 (GPIOA_14            )
 gpio-426 (GPIOA_15            )
 gpio-427 (GPIOB_0             )
 gpio-428 (GPIOB_1             )
 gpio-429 (GPIOB_2             )
 gpio-430 (GPIOB_3             )
 gpio-431 (GPIOB_4             )
 gpio-432 (GPIOB_5             )
 gpio-433 (GPIOB_6             )
 gpio-434 (GPIOB_7             )
 gpio-435 (GPIOB_8             )
 gpio-436 (GPIOB_9             )
 gpio-437 (GPIOB_10            )
 gpio-438 (GPIOB_11            )
 gpio-439 (GPIOB_12            )
 gpio-440 (GPIOB_13            )
 gpio-441 (GPIOB_14            )
 gpio-442 (GPIOB_15            )
 gpio-443 (GPIOC_0             )
 gpio-444 (GPIOC_1             )
 gpio-445 (GPIOC_2             )
 gpio-446 (GPIOC_3             )
 gpio-447 (GPIOC_4             )
 gpio-448 (GPIOC_5             )
 gpio-449 (GPIOC_6             |cd                  ) in  hi 
 gpio-450 (GPIOC_7             )
 gpio-451 (GPIOE_0             )
 gpio-452 (GPIOE_1             )
 gpio-453 (GPIOE_2             )
 gpio-454 (GPIOD_0             )
 gpio-455 (GPIOD_1             )
 gpio-456 (GPIOD_2             |spk_mute            ) out lo 
 gpio-457 (GPIOD_3             )
 gpio-458 (GPIOD_4             )
 gpio-459 (GPIOD_5             )
 gpio-460 (GPIOD_6             |fd6513_dev          ) out hi 
 gpio-461 (GPIOD_7             |fd6513_dev          ) out lo 
 gpio-462 (GPIOD_8             )
 gpio-463 (GPIOD_9             )
 gpio-464 (GPIOD_10            )
 gpio-465 (GPIOD_11            )
 gpio-466 (GPIOH_0             )
 gpio-467 (GPIOH_1             )
 gpio-468 (GPIOH_2             )
 gpio-469 (GPIOH_3             )
 gpio-470 (GPIOH_4             )
 gpio-471 (GPIOH_5             |avout_mute          ) out hi 
 gpio-472 (GPIOH_6             |fd655_dev           ) out hi 
 gpio-473 (GPIOH_7             |fd655_dev           ) out hi 
 gpio-474 (GPIOH_8             )
 gpio-475 (GPIOX_0             )
 gpio-476 (GPIOX_1             )
 gpio-477 (GPIOX_2             )
 gpio-478 (GPIOX_3             )
 gpio-479 (GPIOX_4             )
 gpio-480 (GPIOX_5             )
 gpio-481 (GPIOX_6             |sdio_wifi           ) out hi 
 gpio-482 (GPIOX_7             |sdio_wifi           ) in  hi 
 gpio-483 (GPIOX_8             )
 gpio-484 (GPIOX_9             )
 gpio-485 (GPIOX_10            )
 gpio-486 (GPIOX_11            )
 gpio-487 (GPIOX_12            )
 gpio-488 (GPIOX_13            )
 gpio-489 (GPIOX_14            )
 gpio-490 (GPIOX_15            )
 gpio-491 (GPIOX_16            )
 gpio-492 (GPIOX_17            |bt_rfkill           ) out hi 
 gpio-493 (GPIOX_18            |bt_rfkill           ) in  hi 
 gpio-494 (GPIOX_19            |bt_rfkill           ) out hi 
 gpio-495 (GPIOZ_0             )
 gpio-496 (GPIOZ_1             )
 gpio-497 (GPIOZ_2             )
 gpio-498 (GPIOZ_3             )
 gpio-499 (GPIOZ_4             )
 gpio-500 (GPIOZ_5             )
 gpio-501 (GPIOZ_6             )
 gpio-502 (GPIOZ_7             )
 gpio-503 (GPIOZ_8             )
 gpio-504 (GPIOZ_9             )
 gpio-505 (GPIOZ_10            )
 gpio-506 (GPIOZ_11            )
 gpio-507 (GPIOZ_12            )
 gpio-508 (GPIOZ_13            )
 gpio-509 (GPIOZ_14            )
 gpio-510 (GPIOZ_15            )
 gpio-511 (GPIO_TEST_N         )

Hope for Help!
Thanks Shadowevil

Let’s start with this one.
t95-plus-s905x4-vfd.conf (1.2 KB)
If it doesn’t work, try swapping 47 and 48 and see if that one works.

The Clock shows correct Time now!

The Indicators and the Clock Colon dont work Correct.
If i change the Display Brightness to 3 all the Indicators and the Clock colon on:

from 4-7 nothing happend. I have disabled all Indicators, but no effect.

The first pic doesn’t look right. The time should always consist of 4 numbers, not 3.
Try this config, maybe it’ll fix the clock. After that we can look at icons.
t95-plus-s905x4-vfd.conf (1.2 KB)