How to Edit config.ini?

Hi all, i managed to somehow edit the config.ini file a while back but no idea how i did it.

I added the following code.
usbpower=1

And that is working

I want to try the following code
remotewakeup=‘0x00100076’
decode_type=‘0xb’

I think i plugged my emmc into my pc before, but now it just will not recognise it any more??.

how can i open or edit this file, i can ssh into core elec ok. just not sure where to go from here?.

Thanks.

to edit config.ini:

ssh to CE
mount -o rw,remount /flash
nano /flash/config.ini

1 Like

Plug it in to your PC again and just ignore the Windows message that pops up.
In the root of the card, which is formatted to Fat32 and recognized by Windows, you’ll find your config.ini file. Best to edit it and save with Notepad++…

Ok when i type nano /flash/config.ini nothing happens.

And as for plugging it into the pc, ive tried over and over, i just cant see any drives?

eeek sorry forgot i shut down kodi to read the ir codes lol, hence nano /flash/config.ini was not responding. All working fine now thanks guys x

Oh bugger looks like i messed something up, i can suspend and wakeup with the 2 buttons i assigned, but now i have no other ir controls at all?

How do you run the ir thing that runs on setup, ?.

Maybe i entered the run decode type ?

Thanks i figured out what i did wrong, i forgot to enter the remotewakeupmask line. It was taking ages to re-engage the remote, seems fine now.

I have also disabled all cec options in the adapter settings, but when i suspend and then say change channel to tv the n2 starts up again? is this the cec on my tv?

What I think it’s currently faulty and you cannot disabled CEC at all. It is default enabled, but it can not be disabled.
The hdmi_cec variable in config.ini is without function right now.
I will fix it next day’s.

Ah i see, ive not touched the setting in config.ini was just changing the adaptor settings in the GUI.

Not to worry, will look forward to it.

I pushed a change for this. Try tomorrow next nightly and set hdmi_cec=0 in config.ini.
Then the N2 should not wake up anymore and CEC should not work at all.
I don’t know if you still need to disable CEC in Kodi.

Cool thanks, well i`m on auto update so will try then. Nice one.