How to install coreelec on amlogic.aarch64 (sunnybox g7s)

hi I have an amlogic 905 device with libreelec 8.2.5 amlogic aarch64 installed on EMMC
I read the guide but the ALL the recovery(s) methods and bood sd did not work for me.
I know how to install the original android
know how to install using recovery toothpick the libreelec 8.2.0 :
factory_update_param.aml and the

I updated later to libreelec 8.2.5 amlogic aarch64.
I also have the DTB of the device.

my goal is to have the latest Coreelec installed if possible using update with Tar
also this did not work for me:

LibreELEC (community): 8.2.5 (Amlogic.aarch64)
LibreELEC:~ # cat /proc/device-tree/le-dt-id
cat: can’t open ‘/proc/device-tree/le-dt-id’: No such file or directory

thanks in advance!

One step at a time please.
Burn the latest Generic stable version of CE to an SD Card.
Once that is done using your PC / Mac navigate to the SD Card
Look for the correct device tree in a folder called Device trees.
Find the device tree that matches your hardware specs.
I just Googled your box ?
Amlogic S905
1000M Ethernet
Example : gxbb_p200_2G_1Gbit
Copy the device tree to the root of the sd card and rename it to dtb.img
It should boot from the SD Card.

It will not boot from SD probably because installed libreelec on emmc. Anyway I can update it without re burning android image?

I have no idea what LE version you’ve had installed internally but if you had Kszac’s versions it should boot. The Arch64 version you’re naming means nothing to me. I left LE builds over a year ago. No idea what script is installed.
I’ve booted from Kszac’s LE builds 7.0 internal installs to CE SD Card installs no problem.
Didn’t even have to toothpick. Inserted CE Sd Card image and it booted.

So what should I do now?
Burn Android and start from there?

That’s what i would do :wink:

ok using the dtb you suggested solved it.
my mistake was trying to use the original dtb.img from the vendor.
remote is not working but I guess it will be solved
thanks a lot!!!

can you help me with the remote issue? non of the keys working. thx

Start reading above link.